CVE-2005-0983
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:16:14
NMCOS    

[原文]Quake 3 engine, as used in multiple games, allows remote attackers to cause a denial of service (client disconnect) via a long message, which is not properly truncated and causes the engine to process the remaining data as if it were network data.


[CNNVD]Quake 3远程拒绝服务漏洞(CNNVD-200505-282)

        游戏引擎处理长于1022个字符的命令时存在漏洞,远程攻击者可能用来执行拒绝服务攻击。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:activision:call_of_duty:1.4
cpe:/a:id_software:wolfenstein_enemy_territory:2.56
cpe:/a:activision:call_of_duty:1.5b
cpe:/a:activision:return_to_castle_wolfenstein:1.1
cpe:/a:activision:call_of_duty_united_offensive:1.41
cpe:/a:id_software:quake_3_arena:1.1.7
cpe:/a:activision:call_of_duty_united_offensive:1.51b
cpe:/a:id_software:quake_3_arena_server:1.29f
cpe:/a:id_software:quake_3_arena_server:1.29g
cpe:/a:id_software:quake_3_arena:1.31
cpe:/a:id_software:wolfenstein_enemy_territory:1.0.2
cpe:/a:raven_software:soldier_of_fortune_2:1.0.3
cpe:/a:activision:return_to_castle_wolfenstein:1.0
cpe:/a:id_software:quake_3_arena:1.16
cpe:/a:id_software:quake_3_engine
cpe:/a:lucasarts:star_wars_jedi_knight_jedi_academy:1.0.11
cpe:/a:raven_software:soldier_of_fortune_2:1.0.2
cpe:/a:lucasarts:star_wars_jedi_knight_ii_jedi_outcast:1.0.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0983
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0983
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-282
(官方数据源) CNNVD

- 其它链接及资源

http://aluigi.altervista.org/adv/q3msgboom-adv.txt
(UNKNOWN)  MISC  http://aluigi.altervista.org/adv/q3msgboom-adv.txt
http://bani.anime.net/banimod/forums/viewtopic.php?p=27322
(UNKNOWN)  MISC  http://bani.anime.net/banimod/forums/viewtopic.php?p=27322
http://marc.info/?l=bugtraq&m=111246796918067&w=2
(UNKNOWN)  BUGTRAQ  20050402 In-game players kicking in the Quake 3 engine
http://www.securityfocus.com/bid/12976
(UNKNOWN)  BID  12976

- 漏洞信息

Quake 3远程拒绝服务漏洞
中危 资料不足
2005-05-02 00:00:00 2006-09-22 00:00:00
远程  
        游戏引擎处理长于1022个字符的命令时存在漏洞,远程攻击者可能用来执行拒绝服务攻击。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.activision.com/en_US/home/home.jsp" target="_blank"

- 漏洞信息

15269
Quake 3 Engine Long Message Client DoS
Denial of Service
Loss of Availability

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-02 Unknow
2005-04-02 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Quake 3 Engine Message Denial of Service Vulnerability
Unknown 12976
Yes No
2005-04-02 12:00:00 2009-07-12 11:56:00
Discovered by Luigi Auriemma <aluigi@..>.

- 受影响的程序版本

Raven Software Soldier Of Fortune 2 1.0 3
Raven Software Soldier Of Fortune 2 1.0 2
LucasArts Star Wars Jedi Knight: Jedi Academy 1.0.11
LucasArts Star Wars Jedi Knight II: Jedi Outcast 1.0.4
id Software Quake 3 Arena Server 1.29 g
id Software Quake 3 Arena Server 1.29 f
id Software Quake 3 Arena 1.31
id Software Quake 3 Arena 1.16 n
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0
id Software Quake 3 Arena 1.1.7
id Software Quake 3 Arena 1.1.7
Activision Wolfenstein: Enemy Territory 2.56
Activision Wolfenstein: Enemy Territory 1.0.2
Activision Return to Castle Wolfenstein 1.1
Activision Return to Castle Wolfenstein 1.0
Activision Call of Duty United Offensive 1.41
Activision Call of Duty United Offensive 1.5.1 b
Activision Call of Duty 1.5 b
Activision Call of Duty 1.4
Activision Wolfenstein: Enemy Territory 2.60

- 不受影响的程序版本

Activision Wolfenstein: Enemy Territory 2.60

- 漏洞讨论

A denial of service vulnerability reportedly affects the Quake 3 engine. The vulnerability can be exploited remotely. Messages sent by clients that are greater than 1022 characters in length will cause the server to crash. It is not known what precisely causes the crash. It may be due to a buffer overflow vulnerability. If that is the cause, remote code execution could be possible.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

According to the advisory author, only Wolfenstein: Enemy Territory 2.60 includes a fix for this vulnerability.

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站