CVE-2005-0966
CVSS6.4
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:16:06
NMCOPS    

[原文]The IRC protocol plugin in Gaim 1.2.0, and possibly earlier versions, allows (1) remote attackers to inject arbitrary Gaim markup via irc_msg_kick, irc_msg_mode, irc_msg_part, irc_msg_quit, (2) remote attackers to inject arbitrary Pango markup and pop up empty dialog boxes via irc_msg_invite, or (3) malicious IRC servers to cause a denial of service (application crash) by injecting certain Pango markup into irc_msg_badmode, irc_msg_banned, irc_msg_unknown, irc_msg_nochan functions.


[CNNVD]Gaim IRC协议插件标记语言注入漏洞(CNNVD-200505-733)

        Gaim是一款可在多种操作系统平台上执行的实时通讯软件。
        Gaim IRC协议插件中存在输入验证漏洞,可能导致拒绝服务攻击。

- CVSS (基础分值)

CVSS分值: 6.4 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9185The IRC protocol plugin in Gaim 1.2.0, and possibly earlier versions, allows (1) remote attackers to inject arbitrary Gaim markup via irc_ms...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0966
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0966
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-733
(官方数据源) CNNVD

- 其它链接及资源

http://gaim.sourceforge.net/security/index.php?id=14
(VENDOR_ADVISORY)  CONFIRM  http://gaim.sourceforge.net/security/index.php?id=14
http://marc.info/?l=bugtraq&m=111238715307356&w=2
(UNKNOWN)  BUGTRAQ  20050401 multiple remote denial of service vulnerabilities in Gaim
http://sourceforge.net/project/shownotes.php?group_id=235&release_id=317750
(PATCH)  CONFIRM  http://sourceforge.net/project/shownotes.php?group_id=235&release_id=317750
http://www.mandriva.com/security/advisories?name=MDKSA-2005:071
(UNKNOWN)  MANDRAKE  MDKSA-2005:071
http://www.novell.com/linux/security/advisories/2005_36_sudo.html
(UNKNOWN)  SUSE  SUSE-SA:2005:036
http://www.redhat.com/support/errata/RHSA-2005-365.html
(UNKNOWN)  REDHAT  RHSA-2005:365
http://www.securityfocus.com/archive/1/archive/1/426078/100/0/threaded
(UNKNOWN)  FEDORA  FLSA:158543
http://www.securityfocus.com/bid/13003
(UNKNOWN)  BID  13003
http://xforce.iss.net/xforce/xfdb/19937
(UNKNOWN)  XF  gaim-irc-plugin-bo(19937)
http://xforce.iss.net/xforce/xfdb/19939
(UNKNOWN)  XF  gaim-ircmsginvite-dos(19939)

- 漏洞信息

Gaim IRC协议插件标记语言注入漏洞
中危 输入验证
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        Gaim是一款可在多种操作系统平台上执行的实时通讯软件。
        Gaim IRC协议插件中存在输入验证漏洞,可能导致拒绝服务攻击。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        http://gaim.sourceforge.net/downloads.php

- 漏洞信息 (F37030)

Gentoo Linux Security Advisory 200504-5 (PacketStormID:F37030)
2005-04-17 00:00:00
Gentoo  security.gentoo.org
advisory,denial of service,vulnerability
linux,gentoo
CVE-2005-0965,CVE-2005-0966,CVE-2005-0967
[点击下载]

Gentoo Linux Security Advisory GLSA 200504-05 - Gaim contains multiple vulnerabilities that can lead to a Denial of Service. Versions less than 1.2.1 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200504-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Low
     Title: Gaim: Denial of Service issues
      Date: April 06, 2005
   Updated: April 06, 2005
      Bugs: #87903
        ID: 200504-05:02

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Gaim contains multiple vulnerabilities that can lead to a Denial of
Service.

Background
==========

Gaim is a full featured instant messaging client which handles a
variety of instant messaging protocols.

Affected packages
=================

    -------------------------------------------------------------------
     Package      /  Vulnerable  /                          Unaffected
    -------------------------------------------------------------------
  1  net-im/gaim       < 1.2.1                                >= 1.2.1

Description
===========

Multiple vulnerabilities have been addressed in the latest release of
Gaim:

* A buffer overread in the gaim_markup_strip_html() function, which
  is used when logging conversations (CAN-2005-0965).

* Markup tags are improperly escaped using Gaim's IRC plugin
  (CAN-2005-0966).

* Sending a specially crafted file transfer request to a Gaim Jabber
  user can trigger a crash (CAN-2005-0967).

Impact
======

An attacker could possibly cause a Denial of Service by exploiting any
of these vulnerabilities.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Gaim users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=net-im/gaim-1.2.1"

References
==========

  [ 1 ] CAN-2005-0967
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0967
  [ 2 ] CAN-2005-0966
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0966
  [ 3 ] CAN-2005-0965
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0965
  [ 4 ] Gaim Vulnerability Index
        http://gaim.sourceforge.net/security/

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200504-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
    

- 漏洞信息

15277
Gaim IRC Plugin Multiple Function Arbitrary Gaim Markup Injection
Remote / Network Access Denial of Service
Loss of Availability
Exploit Public

- 漏洞描述

Gaim contains a flaw that may allow a remote attacker to inject arbitrary Gaim markup. The issue is triggered due to multiple functions of the IRC protocol plugin. It is possible that the flaw may allow a remote attacker to inject arbitrary Gaim markups over IRC resulting in a loss of integrity.

- 时间线

2005-04-01 2005-03-25
2005-04-03 Unknow

- 解决方案

Upgrade to version 1.2.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Gaim IRC Protocol Plug-in Markup Language Injection Vulnerability
Input Validation Error 13003
Yes No
2005-04-05 12:00:00 2007-02-28 09:26:00
Discovery of this vulnerability is credited to Jean-Yves Lefort.

- 受影响的程序版本

Ubuntu Ubuntu Linux 4.1 ppc
Ubuntu Ubuntu Linux 4.1 ia64
Ubuntu Ubuntu Linux 4.1 ia32
Slackware Linux 10.1
SGI ProPack 3.0
S.u.S.E. Linux Professional 9.3 x86_64
S.u.S.E. Linux Professional 9.3
S.u.S.E. Linux Professional 9.2 x86_64
S.u.S.E. Linux Professional 9.2
S.u.S.E. Linux Professional 9.1 x86_64
S.u.S.E. Linux Professional 9.1
S.u.S.E. Linux Professional 9.0 x86_64
S.u.S.E. Linux Professional 9.0
S.u.S.E. Linux Personal 9.3 x86_64
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
Rob Flynn Gaim 1.2
Rob Flynn Gaim 1.1.4
+ Conectiva Linux 10.0
+ Conectiva Linux 9.0
+ Conectiva Linux 4.1
+ Gentoo Linux
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Ubuntu Ubuntu Linux 5.0 4 powerpc
+ Ubuntu Ubuntu Linux 5.0 4 i386
+ Ubuntu Ubuntu Linux 5.0 4 amd64
Rob Flynn Gaim 1.1.3
+ Red Hat Fedora Core3
+ Red Hat Fedora Core2
Rob Flynn Gaim 1.1.2
+ Red Hat Fedora Core3
+ Red Hat Fedora Core2
Rob Flynn Gaim 1.1.1
Rob Flynn Gaim 1.0.2
+ Gentoo Linux
+ Slackware Linux 10.0
+ Slackware Linux 9.1
+ Slackware Linux 9.0
+ Slackware Linux -current
Rob Flynn Gaim 1.0.1
+ Red Hat Enterprise Linux AS 3
+ RedHat Desktop 3.0
+ RedHat Enterprise Linux ES 3
+ RedHat Enterprise Linux WS 3
Rob Flynn Gaim 1.0
+ Conectiva Linux 10.0
+ Conectiva Linux 9.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
RedHat Linux 9.0 i386
RedHat Linux 7.3 i686
RedHat Linux 7.3 i386
RedHat Linux 7.3
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Desktop 4.0
RedHat Desktop 3.0
Red Hat Fedora Core3
Red Hat Fedora Core2
Red Hat Fedora Core1
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Peachtree Linux release 1
Rob Flynn Gaim 1.2.1
+ Conectiva Linux 10.0
+ Conectiva Linux 9.0
+ Gentoo Linux
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Red Hat Enterprise Linux AS 4
+ Red Hat Enterprise Linux AS 3
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux ES 3
+ RedHat Enterprise Linux WS 4
+ RedHat Enterprise Linux WS 3

- 不受影响的程序版本

Rob Flynn Gaim 1.2.1
+ Conectiva Linux 10.0
+ Conectiva Linux 9.0
+ Gentoo Linux
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Red Hat Enterprise Linux AS 4
+ Red Hat Enterprise Linux AS 3
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux ES 3
+ RedHat Enterprise Linux WS 4
+ RedHat Enterprise Linux WS 3

- 漏洞讨论

Gaim IRC protocol plug-in is reported prone to an input-validation vulnerability. The issue is reported to occur because of a lack of sufficient sanitization performed on 'irc_msg' data.

A remote attacker may exploit this vulnerability to execute arbitrary Gaim and Pango Markup language in the context of the user that is running the affected software.

This vulnerability is reported to affect Gaim version 1.2.0 and previous versions.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Vendor upgrades are available. Please see the referenced advisories for more information.


Rob Flynn Gaim 1.0

Rob Flynn Gaim 1.0.1

Rob Flynn Gaim 1.0.2

Rob Flynn Gaim 1.1.1

Rob Flynn Gaim 1.1.2

Rob Flynn Gaim 1.1.3

Rob Flynn Gaim 1.1.4

Rob Flynn Gaim 1.2

Slackware Linux 10.1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站