发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:47:48

[原文]SQL injection vulnerability in index.php for Lighthouse Squirrelcart allows remote attackers to execute arbitrary SQL commands via the (1) crn parameter in a show action or (2) rn parameter in a show_detail action.

[CNNVD]Lighthouse Development Squirrelcart SQL注入漏洞(CNNVD-200505-030)

        Lighthouse Squirrelcart的index.php存在SQL注入漏洞,允许远程攻击者通过(1)show操作的crn参数或(2)show_detail操作的rn参数来执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  squirrelcart-index-sql-injection(19904)
(UNKNOWN)  BID  12944

- 漏洞信息

Lighthouse Development Squirrelcart SQL注入漏洞
高危 SQL注入
2005-05-02 00:00:00 2005-10-20 00:00:00
        Lighthouse Squirrelcart的index.php存在SQL注入漏洞,允许远程攻击者通过(1)show操作的crn参数或(2)show_detail操作的rn参数来执行任意SQL命令。

- 公告与补丁


- 漏洞信息

Squirrelcart index.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Squirrelcart PHP Shopping Cart contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the 'crn' and 'rn' variables in the index.php script are not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2005-03-30 Unknow
2005-03-30 Unknow

- 解决方案

Upgrade to version 1.6.0 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Lighthouse Development Squirrelcart SQL Injection Vulnerability
Input Validation Error 12944
Yes No
2005-03-29 12:00:00 2009-07-12 11:56:00
Discovery is credited to Diabolic Crab <>.

- 受影响的程序版本

Lighthouse Development Squirrelcart 1.5.5
Lighthouse Development Squirrelcart 1.6

- 不受影响的程序版本

Lighthouse Development Squirrelcart 1.6

- 漏洞讨论

Squirrelcart is affected by an SQL injection vulnerability.

This vulnerability could permit remote attackers to pass malicious input to database queries, resulting in modification of query logic or other attacks.

Squirrelcart 1.5.5 and prior versions are vulnerable to this issue.

- 漏洞利用

No exploit is required.

The following proof of concept is available:'SQL_INJECTION&amp;action=show&amp;show_products_mode=cat_click&amp;PHPSESSID=2069dbe1646bdc46e4e78718e76e6d15

- 解决方案

The vendor has released patches for Squirrelcart 1.5.5 and prior versions. Squirrelcart 1.6.0 has been released as an upgrade as well. Please contact the vendor to obtain a patch or upgrade.

- 相关参考