发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:47:48

[原文]Cross-site scripting (XSS) vulnerability in Horde 3.0.4 before 3.0.4-RC2 allows remote attackers to inject arbitrary web script or HTML via the parent frame title.


        Horde 3.0.4的3.0.4-RC2之前版本存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过父类框架标题来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
        Horde 3.0.4的3.0.4-RC2之前版本存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过父类框架标题来注入任意Web脚本或HTML。

- 公告与补丁

        Horde Horde 3.0.4 -RC 2
        Horde Horde 3.0.4

- 漏洞信息

Horde Parent Frame Page Title XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

Horde contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user-supplied input upon submission to the the parent frame's page title. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-03-29 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 3.0.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Horde Application Framework Parent Page Title Cross-Site Scripting Vulnerability
Input Validation Error 12943
Yes No
2005-03-29 12:00:00 2009-07-12 11:56:00
The vendor reported this issue.

- 受影响的程序版本

S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Enterprise Server 9
Horde Project Horde 3.0.4 -RC 2
Horde Project Horde 3.0.4

- 不受影响的程序版本

Horde Project Horde 3.0.4

- 漏洞讨论

Horde Application Framework is prone to a cross-site scripting vulnerability. An attacker can supply arbitrary HTML and script code to the application when the page title of a parent frame is manipulated.

A successful attack can facilitate theft of cookie-based authentication credentials. Other attacks are possible as well.

Horde 3.0.4-RC2 is reported vulnerable, however, other versions may be affected as well.

- 漏洞利用

An exploit is not required.

- 解决方案

This issue has been addressed in Horde 3.0.4.

SUSE has released advisory SUSE-SR:2005:016 to address this issue. Please see the referenced advisory for more information.

Horde Project Horde 3.0.4 -RC 2

- 相关参考