发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:16:00

[原文]SQL injection vulnerability in InterAKT MX Shop 1.1.1 allows remote attackers to execute arbitrary SQL commands via the id_ctg parameter.

[CNNVD]InterAKT Online MX Shop SQL注入漏洞(CNNVD-200505-789)

        InterAKT MX Shop 1.1.1版本存在SQL注入漏洞,远程攻击者可通过id_ctg参数执行任意SQL指令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050331 MX Shop 1.1.1 and MX Kart 1.1.2 are vulnerable to multiple SQL injection vulnerabilities
(UNKNOWN)  BID  12957

- 漏洞信息

InterAKT Online MX Shop SQL注入漏洞
高危 SQL注入
2005-05-02 00:00:00 2005-10-20 00:00:00
        InterAKT MX Shop 1.1.1版本存在SQL注入漏洞,远程攻击者可通过id_ctg参数执行任意SQL指令。

- 公告与补丁


- 漏洞信息

MX Shop Category Module id_ctg Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

MX Shop contains a flaw that may allow a remote attacker to inject arbitrary SQL queries. The issue is due to the 'id_ctg' parameter in the 'Category' module not being properly sanitized and may allow a remote attacker to inject or manipulate SQL queries.

- 时间线

2005-03-31 Unknow
2005-03-31 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

InterAKT Online MX Shop SQL Injection Vulnerability
Input Validation Error 12957
Yes No
2005-03-31 12:00:00 2009-07-12 11:56:00
Discovery is credited to dcrab <>.

- 受影响的程序版本

InterAKT Online MX Shop 1.1.1
InterAKT Online MX Shop 3.6

- 不受影响的程序版本

InterAKT Online MX Shop 3.6

- 漏洞讨论

MX Shop is reportedly affected by an SQL-injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input before using it in SQL queries.

This vulnerability could permit remote attackers to pass malicious input to database queries, resulting in modification of query logic.

Successful exploitation could result in a compromise of security properties of the application. The impact of this issue depends on the underlying database that is being used.

InterAKT Online MX Shop version 1.1.1 is reported prone to these issues; other versions might also be affected.

- 漏洞利用

No exploit is required.


- 解决方案

The vendor has addresses this issue in MX Shop version 3.6.0 and later. Contact the vendor for information on obtaining the appropriate updates.

- 相关参考