CVE-2005-0932
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2011-03-07 21:20:49
NMCO    

[原文]Multiple SQL injection vulnerabilities in phpCOIN 1.2.1b and earlier allow remote attackers to execute arbitrary SQL commands (1) via the search engine, (2) the username or email fields in the "forgotten password" feature, or (3) the domain name in a package order.


[CNNVD]phpCoin SQL注入及文件包含漏洞(CNNVD-200505-807)

        phpCoin是个免费软件包,网络托管的分销商可使用它来管理客户,发票,订单等。phpCoin 1.2.1b及更早版本中存在多个SQL注入和文件包含漏洞,远程攻击者可能利用漏洞在主机上执行任意命令或非法访问数据库。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:coinsoft_technologies:phpcoin:1.2.1
cpe:/a:coinsoft_technologies:phpcoin:1.2
cpe:/a:coinsoft_technologies:phpcoin:1.2.1b

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0932
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0932
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-807
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/12917
(UNKNOWN)  BID  12917
http://www.gulftech.org/?node=research&article_id=00065-03292005
(UNKNOWN)  MISC  http://www.gulftech.org/?node=research&article_id=00065-03292005

- 漏洞信息

phpCoin SQL注入及文件包含漏洞
高危 SQL注入
2005-05-02 00:00:00 2006-03-29 00:00:00
远程  
        phpCoin是个免费软件包,网络托管的分销商可使用它来管理客户,发票,订单等。phpCoin 1.2.1b及更早版本中存在多个SQL注入和文件包含漏洞,远程攻击者可能利用漏洞在主机上执行任意命令或非法访问数据库。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.phpcoin.com/

- 漏洞信息

15160
phpCOIN Search Engine SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Unknown

- 漏洞描述

phpCOIN contains a flaw that will allow a remote attacker to inject arbitrary SQL code. The problem is that user-supplied input in the 'Search For' field is not verified properly and will allow a remote attacker to inject or manipulate SQL queries.

- 时间线

2005-03-29 2001-01-01
2001-01-01 Unknow

- 解决方案

Upgrade to version 1.2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站