CVE-2005-0908
CVSS4.3
发布时间 :2005-03-28 00:00:00
修订时间 :2008-09-05 16:47:39
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in Valdersoft Shopping Cart 3.0 allow remote attackers to inject arbitrary web script or HTML via (1) the lang parameter to index.php or (2) the searchTopCategoryID parameter to search_result.php.


[CNNVD]Valdersoft Shopping Cart 多个跨站脚本攻击漏洞(CNNVD-200503-141)

        Valdersoft Shopping Cart 3.0中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过(1) index.php的lang参数或(2) search_result.php的searchTopCategoryID参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0908
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0908
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200503-141
(官方数据源) CNNVD

- 其它链接及资源

http://securitytracker.com/id?1013565
(VENDOR_ADVISORY)  SECTRACK  1013565
http://www.securityfocus.com/archive/1/394406/2005-03-26/2005-04-01/2
(VENDOR_ADVISORY)  BUGTRAQ  20050327 Multiple sql injection, and xss vulnerabilities in Vladersoft Shopping Cart v.3.0

- 漏洞信息

Valdersoft Shopping Cart 多个跨站脚本攻击漏洞
中危 跨站脚本
2005-03-28 00:00:00 2005-10-20 00:00:00
远程  
        Valdersoft Shopping Cart 3.0中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过(1) index.php的lang参数或(2) search_result.php的searchTopCategoryID参数注入任意Web脚本或HTML。

- 公告与补丁

        

- 漏洞信息

15055
Valdersoft Shopping Cart index.php lang Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Valdersoft Shopping Cart contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'lang' variables upon submission to the index.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-03-27 Unknow
2005-03-27 Unknow

- 解决方案

Upgrade to version 3.0 or higher, obtained from the vendor site on or after March 30, 2005, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds. NOTE: The vendor has fixed the vulnerability without changing the version number.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站