CVE-2005-0887
CVSS7.5
发布时间 :2005-03-24 00:00:00
修订时间 :2008-09-05 16:47:36
NMCOS    

[原文]Eval injection vulnerability in Double Choco Latte before 0.9.4.3 allows remote attackers to execute arbitrary PHP code via the menuAction variable in (1) functions.inc.php or (2) main.php, which causes code to be injected into an eval statement.


[CNNVD]Double Choco Latte 多个任意代码漏洞(CNNVD-200503-133)

        Double Choco Latte 0.9.4.3之前版本中存在Eval注入漏洞,远程攻击者可以通过(1) functions.inc.php或(2) main.php中的menuAction变量将代码注入Eval语句,从而执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:michael_dean:double_choco_latte:0.9.4.2
cpe:/a:michael_dean:double_choco_latte:0.9.4.3
cpe:/a:michael_dean:double_choco_latte:0.9.3
cpe:/a:michael_dean:double_choco_latte:0.9.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0887
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0887
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200503-133
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/19806
(VENDOR_ADVISORY)  XF  dcl-file-include(19806)
http://sourceforge.net/project/shownotes.php?release_id=315144
(VENDOR_ADVISORY)  CONFIRM  http://sourceforge.net/project/shownotes.php?release_id=315144
http://securitytracker.com/id?1013559
(VENDOR_ADVISORY)  SECTRACK  1013559
http://secunia.com/advisories/14688
(VENDOR_ADVISORY)  SECUNIA  14688

- 漏洞信息

Double Choco Latte 多个任意代码漏洞
高危 输入验证
2005-03-24 00:00:00 2006-06-15 00:00:00
远程  
        Double Choco Latte 0.9.4.3之前版本中存在Eval注入漏洞,远程攻击者可以通过(1) functions.inc.php或(2) main.php中的menuAction变量将代码注入Eval语句,从而执行任意PHP代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Michael Dean Double Choco Latte 0.9.3
        Double Choco Latte dcl-0.9.4.4.tar.gz
        http://prdownloads.sourceforge.net/dcl/dcl-0.9.4.4.tar.gz?download
        Michael Dean Double Choco Latte 0.9.4
        Double Choco Latte dcl-0.9.4.4.tar.gz
        http://prdownloads.sourceforge.net/dcl/dcl-0.9.4.4.tar.gz?download
        Michael Dean Double Choco Latte 0.9.4 .2
        Double Choco Latte dcl-0.9.4.4.tar.gz
        http://prdownloads.sourceforge.net/dcl/dcl-0.9.4.4.tar.gz?download
        Michael Dean Double Choco Latte 0.9.4 .3
        Double Choco Latte dcl-0.9.4.4.tar.gz
        http://prdownloads.sourceforge.net/dcl/dcl-0.9.4.4.tar.gz?download

- 漏洞信息

14954
Double Choco Latte main.php Arbitrary PHP Code Execution
Remote / Network Access
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-03-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.9.4.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Double Choco Latte Multiple Vulnerabilities
Input Validation Error 12894
Yes No
2005-03-24 12:00:00 2009-07-12 11:56:00
Discovery is credited to James Bercegay from GulfTech Research.

- 受影响的程序版本

Michael Dean Double Choco Latte 0.9.4 .3
Michael Dean Double Choco Latte 0.9.4 .2
Michael Dean Double Choco Latte 0.9.4
Michael Dean Double Choco Latte 0.9.3
Michael Dean Double Choco Latte 0.9.4 .4

- 不受影响的程序版本

Michael Dean Double Choco Latte 0.9.4 .4

- 漏洞讨论

Double Choco Latte is reported prone to multiple vulnerabilities. These issues result from insufficient sanitization of user-supplied data and may allow an attacker to carry out cross-site scripting/HTML injection attacks and execute arbitrary PHP code on a computer.

Double Choco Latte 0.9.4.3 is reported vulnerable to the cross-site scripting/HTML injection issue.

Double Choco Latte 0.9.4.2 and prior versions are affected by the PHP code execution issue.

This BID will be updated when more information is available.

- 漏洞利用

An exploit is not required.

The following proof of concept demonstrating PHP code execution is available:
http://www.example.com/main.php?menuAction=htmlTickets.show;system(id);ob_start

- 解决方案

Double Choco Latte 0.9.4.4 is available to address these issues.


Michael Dean Double Choco Latte 0.9.3

Michael Dean Double Choco Latte 0.9.4

Michael Dean Double Choco Latte 0.9.4 .2

Michael Dean Double Choco Latte 0.9.4 .3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站