CVE-2005-0878
CVSS4.3
发布时间 :2005-03-23 00:00:00
修订时间 :2008-09-05 16:47:34
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in MercuryBoard before 1.1.3 allows remote attackers to inject arbitrary web script or HTML via the title field of a PM (private message).


[CNNVD]MercuryBoard 跨站脚本攻击漏洞 (CNNVD-200503-128)

        MercuryBoard 1.1.3之前版本中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过PM(个人消息)的标题字段注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mercuryboard:mercuryboard_message_board:1.1.2
cpe:/a:mercuryboard:mercuryboard_message_board:1.0.1
cpe:/a:mercuryboard:mercuryboard_message_board:1.1
cpe:/a:mercuryboard:mercuryboard_message_board:1.0.2
cpe:/a:mercuryboard:mercuryboard_message_board:1.0
cpe:/a:mercuryboard:mercuryboard_message_board:1.1.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0878
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0878
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200503-128
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/19797
(VENDOR_ADVISORY)  XF  mercuryboard-title-pm-xss(19797)
http://www.securityfocus.com/bid/12872
(VENDOR_ADVISORY)  BID  12872
http://secunia.com/advisories/14679
(VENDOR_ADVISORY)  SECUNIA  14679

- 漏洞信息

MercuryBoard 跨站脚本攻击漏洞
中危 跨站脚本
2005-03-23 00:00:00 2006-10-06 00:00:00
远程  
        MercuryBoard 1.1.3之前版本中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过PM(个人消息)的标题字段注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        MercuryBoard Message Board 1.0
        MercuryBoard MercuryBoard 1.1.3
        http://www.mercuryboard.com/index.php?a=downloads
        MercuryBoard Message Board 1.0.1
        MercuryBoard MercuryBoard 1.1.3
        http://www.mercuryboard.com/index.php?a=downloads
        MercuryBoard Message Board 1.0.2
        MercuryBoard MercuryBoard 1.1.3
        http://www.mercuryboard.com/index.php?a=downloads
        MercuryBoard Message Board 1.1
        MercuryBoard MercuryBoard 1.1.3
        http://www.mercuryboard.com/index.php?a=downloads
        MercuryBoard Message Board 1.1.1
        MercuryBoard MercuryBoard 1.1.3
        http://www.mercuryboard.com/index.php?a=downloads
        MercuryBoard Message Board 1.1.2
        MercuryBoard MercuryBoard 1.1.3
        http://www.mercuryboard.com/index.php?a=downloads

- 漏洞信息

14936
MercuryBoard Private Message title Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified, Coordinated Disclosure

- 漏洞描述

MercuryBoard contains a flaw that allows a remote cross-site scripting (XSS) attack. This flaw exists because the application does not validate the "title" field upon sending private messages to users. This may allow a user to create a specially crafted private message that would execute arbitrary script code in a user's browser within the trust relationship between their browser and the server.

- 时间线

2005-03-23 2005-01-26
2005-03-23 2005-03-20

- 解决方案

Upgrade to version 1.1.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

MercuryBoard Title Field HTML Injection Vulnerability
Input Validation Error 12872
Yes No
2005-03-23 12:00:00 2009-07-12 05:56:00
Discovery is credited to Secunia Research.

- 受影响的程序版本

MercuryBoard Message Board 1.1.2
MercuryBoard Message Board 1.1.1
MercuryBoard Message Board 1.1
MercuryBoard Message Board 1.0.2
MercuryBoard Message Board 1.0.1
MercuryBoard Message Board 1.0
MercuryBoard Message Board 1.1.3

- 不受影响的程序版本

MercuryBoard Message Board 1.1.3

- 漏洞讨论

MercuryBoard is affected by an HTML injection vulnerability.

The issue affects the 'title' field when a PM is sent to a user and may be exploited to execute arbitrary HTML and script code in the browser of a user when the user views the PM.

MercuryBoard 1.1.2 is affected by this issue. It is likely that this issue affects prior versions as well.

- 漏洞利用

An exploit is not required to leverage this issue.

- 解决方案

The vendor has released MercuryBoard 1.1.3 to address this issue.


MercuryBoard Message Board 1.0

MercuryBoard Message Board 1.0.1

MercuryBoard Message Board 1.0.2

MercuryBoard Message Board 1.1

MercuryBoard Message Board 1.1.1

MercuryBoard Message Board 1.1.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站