CVE-2005-0877
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:47:34
NMCO    

[原文]Dnsmasq before 2.21 allows remote attackers to poison the DNS cache via answers to queries that were not made by Dnsmasq.


[CNNVD]Dnsmasq多个远程漏洞(CNNVD-200505-239)

        Dnsmasq 2.21之前的版本允许远程攻击者通过并非由Dnsmasq作出的查询回答来使DNS缓存中毒。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:dnsmasq:dnsmasq:2.14
cpe:/a:dnsmasq:dnsmasq:2.19
cpe:/a:dnsmasq:dnsmasq:2.1
cpe:/a:dnsmasq:dnsmasq:2.2
cpe:/a:dnsmasq:dnsmasq:2.12
cpe:/a:dnsmasq:dnsmasq:2.3
cpe:/a:dnsmasq:dnsmasq:2.8
cpe:/a:dnsmasq:dnsmasq:2.9
cpe:/a:dnsmasq:dnsmasq:2.15
cpe:/a:dnsmasq:dnsmasq:2.11
cpe:/a:dnsmasq:dnsmasq:2.16
cpe:/a:dnsmasq:dnsmasq:2.17
cpe:/a:dnsmasq:dnsmasq:2.5
cpe:/a:dnsmasq:dnsmasq:2.7
cpe:/a:dnsmasq:dnsmasq:2.0
cpe:/a:dnsmasq:dnsmasq:2.18
cpe:/a:dnsmasq:dnsmasq:2.4
cpe:/a:dnsmasq:dnsmasq:2.6
cpe:/a:dnsmasq:dnsmasq:2.20
cpe:/a:dnsmasq:dnsmasq:2.10
cpe:/a:dnsmasq:dnsmasq:2.13

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0877
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0877
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-239
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/19826
(PATCH)  XF  dnsmasq-dns-cache-poisoning(19826)
http://www.securityfocus.com/bid/12897
(PATCH)  BID  12897
http://secunia.com/advisories/14691
(VENDOR_ADVISORY)  SECUNIA  14691
http://www.thekelleys.org.uk/dnsmasq/CHANGELOG
(UNKNOWN)  CONFIRM  http://www.thekelleys.org.uk/dnsmasq/CHANGELOG

- 漏洞信息

Dnsmasq多个远程漏洞
中危 资料不足
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        Dnsmasq 2.21之前的版本允许远程攻击者通过并非由Dnsmasq作出的查询回答来使DNS缓存中毒。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.thekelleys.org.uk/dnsmasq/dnsmasq-2.21.tar.gz

- 漏洞信息

15000
Dnsmasq Remote Cache Poisoning
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-03-23 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.21 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站