CVE-2005-0831
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:47:27
NMCOS    

[原文]PHP-Post allows remote attackers to spoof the names of other users by registering with a username containing hex-encoded characters.


[CNNVD]PHP-Post多个远程输入验证漏洞(CNNVD-200505-751)

        PHP-Post使得远程攻击者可以通过注册时使用含有十六进制编码字符的用户名来欺骗其他用户的用户名。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:php-post:php-post_web_forum:0.22
cpe:/a:php-post:php-post_web_forum:0.2
cpe:/a:php-post:php-post_web_forum:0.32
cpe:/a:php-post:php-post_web_forum:0.21
cpe:/a:php-post:php-post_web_forum:0.3
cpe:/a:php-post:php-post_web_forum:0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0831
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0831
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-751
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/12845
(PATCH)  BID  12845
http://www.securityfocus.com/archive/1/393695
(UNKNOWN)  BUGTRAQ  20050318 PHP-Post Exploit

- 漏洞信息

PHP-Post多个远程输入验证漏洞
中危 输入验证
2005-05-02 00:00:00 2006-09-22 00:00:00
远程  
        PHP-Post使得远程攻击者可以通过注册时使用含有十六进制编码字符的用户名来欺骗其他用户的用户名。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        PHP-post Web Forum 0.1
        PHP-Post PHP-Post 0.33
        http://www.php-post.co.uk/files/phpp.zip
        PHP-post Web Forum 0.2
        PHP-Post PHP-Post 0.33
        http://www.php-post.co.uk/files/phpp.zip
        PHP-post Web Forum 0.21
        PHP-Post PHP-Post 0.33
        http://www.php-post.co.uk/files/phpp.zip
        PHP-post Web Forum 0.22
        PHP-Post PHP-Post 0.33
        http://www.php-post.co.uk/files/phpp.zip
        PHP-post Web Forum 0.3
        PHP-Post PHP-Post 0.33
        http://www.php-post.co.uk/files/phpp.zip
        PHP-post Web Forum 0.32
        PHP-Post PHP-Post 0.33
        http://www.php-post.co.uk/files/phpp.zip

- 漏洞信息

14940
PHP-Post ASCII Character Username Spoofing
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-03-18 Unknow
2005-03-18 Unknow

- 解决方案

Upgrade to version 0.33 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHP-Post Multiple Remote Input Validation Vulnerabilities
Input Validation Error 12845
Yes No
2005-03-18 12:00:00 2008-03-27 06:19:00
PHOX is credited with disclosing the username spoofing issue. The cross-site scripting issues were reported by the vendor.

- 受影响的程序版本

PHP-post Web Forum 0.32
PHP-post Web Forum 0.22
PHP-post Web Forum 0.21
PHP-post Web Forum 0.3
PHP-post Web Forum 0.2
PHP-post Web Forum 0.1
PHP-post Web Forum 0.33

- 不受影响的程序版本

PHP-post Web Forum 0.33

- 漏洞讨论

Multiple remote input-validation vulnerabilities affect PHP-Post. These issues occur because the application fails to properly sanitize user-supplied input before including it in critical site functionality.

The issues reported are multiple unspecified cross-site scripting vulnerabilities and a username-spoofing issue.

An attacker may leverage these issues to execute arbitrary code in the browsers of unsuspecting users and to spoof previously registered usernames.

- 漏洞利用

No exploit is required.

- 解决方案

The vendor has released PHP-Post 0.33 to address this issue. Please see the references for more information.


PHP-post Web Forum 0.1

PHP-post Web Forum 0.2

PHP-post Web Forum 0.21

PHP-post Web Forum 0.22

PHP-post Web Forum 0.3

PHP-post Web Forum 0.32

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站