发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:14:59

[原文]Cross-site scripting (XSS) vulnerability in setuser.php of the Digitanium addon to PHP-Fusion 5.01 allows remote attackers to inject arbitrary web script or HTML via the (1) user_name or (2) user_pass parameters.

[CNNVD]PHP-Fusion Setuser.PHP HTML注入漏洞(CNNVD-200505-485)

        PHP-Fusion 5.01之Digitanium addon的setuser.php中存在跨站脚本攻击(XSS)漏洞,允许远程攻击者通过(1)user_name或(2)user_pass参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050319 [PersianHacker.NET 200503-10]PHP-Fusion v5.01 Html Injection
(UNKNOWN)  BUGTRAQ  20050319 Fw: [PersianHacker.NET 200503-10]PHP-Fusion v5.01 Html Injection Vulnerability
(UNKNOWN)  BUGTRAQ  20050319 Re: [PersianHacker.NET 200503-10]PHP-Fusion v5.01 Html Injection

- 漏洞信息

PHP-Fusion Setuser.PHP HTML注入漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
        PHP-Fusion 5.01之Digitanium addon的setuser.php中存在跨站脚本攻击(XSS)漏洞,允许远程攻击者通过(1)user_name或(2)user_pass参数来注入任意Web脚本或HTML。

- 公告与补丁


- 漏洞信息

PHP-Fusion setuser.php Addon Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-03-19 Unknow
2005-03-19 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHP-Fusion Setuser.PHP HTML Injection Vulnerability
Input Validation Error 12853
Yes No
2005-03-19 12:00:00 2009-07-12 10:56:00
Discovery of this vulnerability is credited to the PersianHacker Team <>.

- 受影响的程序版本

PHP-Fusion PHP-Fusion 5.0 1 Service Pack
PHP-Fusion PHP-Fusion 5.0
PHP-Fusion PHP-Fusion 4.0 1
PHP-Fusion PHP-Fusion 4.00

- 漏洞讨论

PHP-Fusion is reportedly affected by a HTML injection vulnerability. This issue is due to the application failing to properly sanitize user-supplied input passed to the 'setuser.php' script before using it in dynamically generated content.

This vulnerability is reported to affect PHP-Fusion version 5.01, however the vendor reports that the vulnerability might exist in an alteration that is planned for version 5.02. This alteration was recently released to the PHP-Fusion community as a mod for version 5.01.

This BID will be updated as soon as further information is made available.

- 漏洞利用

The following exploit is available:

- 解决方案

A fix for this issue is pending release. Customers are advised to edit 'fusion_core.php':

Look for the following line, located after line 150: if (isset($_POST['login'])) {
$result = dbquery("SELECT * FROM ".$fusion_prefix."users WHERE user_name='".$_POST['user_name']."' and user_password=md5('".$_POST['user_pass']."')");

Replace the above code with these 4 lines:

$user_name = stripinput($_POST['user_name']);
$user_pass = md5($_POST['user_pass']);
if (!preg_match("/^[-0-9A-Z_@\s]+$/i", $user_name)) { header("Location: ".FUSION_BASE."index.php"); exit; }
$result = dbquery("SELECT * FROM ".$fusion_prefix."users WHERE user_name='$user_name' and user_password='$user_pass'");

- 相关参考