发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:47:26

[原文]Buffer overflow in LTris before 1.0.10 allows local users to execute arbitrary code via a crafted highscores file.



- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(PATCH)  GENTOO  GLSA 200503-24

- 漏洞信息

高危 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:" target="_blank"

- 漏洞信息

LTris Global Highscores File Overflow
Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-01-25 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0.9 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Lgames LTris Local Global High Score File Buffer Overflow Vulnerability
Boundary Condition Error 12851
No Yes
2005-01-25 12:00:00 2009-07-12 10:56:00
The vendor announced this vulnerability.

- 受影响的程序版本

Lgames LTris 1.0.1
+ FreeBSD FreeBSD 4.8
+ FreeBSD FreeBSD 4.7
+ FreeBSD FreeBSD 4.6
Gentoo Linux

- 漏洞讨论

A buffer overflow vulnerability is reported to exist in LTris that may result in a local attacker obtaining elevated privileges. The flaw is reported to exist due to a lack of sufficient boundary checks performed when reading high-score data from the global LTris high-score file.

LTris versions prior to version 1.0.9 are reported prone to this issue.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 解决方案

The vendor has addressed this vulnerability and fixes are available:

Gentoo has released an advisory (GLSA 200503-24) and an updated eBuild to address this vulnerability. Gentoo users that are running the affected software may apply the update by issuing the following sequence of commands as a superuser:
emerge --sync
emerge --ask --oneshot --verbose ">=games-puzzle/ltris-1.0.10"

Lgames LTris 1.0.1

- 相关参考