发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:47:24

[原文]Cross-site scripting (XSS) vulnerability in PunBB 1.2.3 allows remote attackers to inject arbitrary web script or HTML via the (1) email or (2) Jabber parameters.

[CNNVD]PunBB 跨站脚本攻击漏洞(CNNVD-200505-563)

        PunBB 1.2.3中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过(1)电子邮件或(2)Jabber参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  punbb-email-jabber-xss(19725)

- 漏洞信息

PunBB 跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
        PunBB 1.2.3中存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过(1)电子邮件或(2)Jabber参数来注入任意Web脚本或HTML。

- 公告与补丁

        PunBB PunBB 1.2.3

- 漏洞信息

PunBB profile.php Multiple Field XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

PunBB contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user-supplied input in the 'Jabber' field upon submission to the 'profile.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-04-07 2001-01-01
2001-01-01 Unknow

- 解决方案

Upgrade to version 1.2.5 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PunBB Multiple HTML Injection Vulnerabilities
Input Validation Error 12828
Yes No
2005-03-16 12:00:00 2009-07-12 10:56:00
Discovery is credited to benji lemien <>.

- 受影响的程序版本

PunBB PunBB 1.2.3
PunBB PunBB 1.2.4

- 不受影响的程序版本

PunBB PunBB 1.2.4

- 漏洞讨论

PunBB is reportedly affected by multiple HTML injection vulnerabilities.

An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible such as the theft of cookie-based authentication credentials.

PunBB 1.2.3 is reported vulnerable, however, other versions may be affected as well.

- 漏洞利用

No exploit is required.

The following proof of concept is available:


- 解决方案

This issue has been addressed in PunBB 1.2.4.

PunBB PunBB 1.2.3

- 相关参考