CVE-2005-0814
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:47:23
NMCOS    

[原文]Unknown vulnerability in lshd in Lysator LSH 1.x and 2.x before 2.0.1 allows remote attackers to cause a denial of service via unknown vectors.


[CNNVD]Lysator LSH未明拒绝服务漏洞(CNNVD-200505-740)

         Lysator LSH 1.x和2.x中早于2.0.1的版本中Ishd存在未知的漏洞,远程攻击者可以通过未知向量来发起拒绝服务攻击。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:lysator:lsh:1.3.1
cpe:/a:lysator:lsh:1.1.8
cpe:/a:lysator:lsh:1.3.3
cpe:/a:lysator:lsh:1.4.2
cpe:/a:lysator:lsh:1.1.1
cpe:/a:lysator:lsh:1.5.3
cpe:/a:lysator:lsh:1.1.2
cpe:/a:lysator:lsh:1.5.4
cpe:/a:lysator:lsh:1.2.2
cpe:/a:lysator:lsh:1.1.3
cpe:/a:lysator:lsh:1.5.1
cpe:/a:lysator:lsh:1.3.5
cpe:/a:lysator:lsh:1.5
cpe:/a:lysator:lsh:1.1.9
cpe:/a:lysator:lsh:2.0.1
cpe:/a:lysator:lsh:1.2.5
cpe:/a:lysator:lsh:1.4.3
cpe:/a:lysator:lsh:1.3.7
cpe:/a:lysator:lsh:1.0.6
cpe:/a:lysator:lsh:1.0.3
cpe:/a:lysator:lsh:1.2.3
cpe:/a:lysator:lsh:1.2.4
cpe:/a:lysator:lsh:1.3.0
cpe:/a:lysator:lsh:1.0.7
cpe:/a:lysator:lsh:1.0
cpe:/a:lysator:lsh:1.1.4
cpe:/a:lysator:lsh:1.3.4
cpe:/a:lysator:lsh:1.0.5
cpe:/a:lysator:lsh:1.5.5
cpe:/a:lysator:lsh:1.0.1
cpe:/a:lysator:lsh:2.0
cpe:/a:lysator:lsh:1.2.1
cpe:/a:lysator:lsh:1.3.6
cpe:/a:lysator:lsh:1.0.2
cpe:/a:lysator:lsh:1.1.6
cpe:/a:lysator:lsh:1.5.2
cpe:/a:lysator:lsh:1.1.0
cpe:/a:lysator:lsh:1.1.7
cpe:/a:lysator:lsh:1.4
cpe:/a:lysator:lsh:1.3.2
cpe:/a:lysator:lsh:1.4.1
cpe:/a:lysator:lsh:1.1.5
cpe:/a:lysator:lsh:1.0.4
cpe:/a:lysator:lsh:1.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0814
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0814
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-740
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2005/dsa-717
(PATCH)  DEBIAN  DSA-717
http://secunia.com/advisories/14609
(PATCH)  SECUNIA  14609
http://lists.lysator.liu.se/pipermail/lsh-bugs/2005q1/000328.html
(VENDOR_ADVISORY)  MLIST  [lsh-bugs] 20050316 ANNOUNCE: LSH-2.0.1, fix for denial of service bug
http://xforce.iss.net/xforce/xfdb/19724
(UNKNOWN)  XF  lsh-lshd-dos(19724)

- 漏洞信息

Lysator LSH未明拒绝服务漏洞
中危 资料不足
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
         Lysator LSH 1.x和2.x中早于2.0.1的版本中Ishd存在未知的漏洞,远程攻击者可以通过未知向量来发起拒绝服务攻击。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Lysator LSH 1.5
        Lysator LSH 2.0.1
        http://www.lysator.liu.se/~nisse/archive/lsh-2.0.1.tar.gz
        Lysator LSH 1.5.1
        Lysator LSH 2.0.1
        http://www.lysator.liu.se/~nisse/archive/lsh-2.0.1.tar.gz
        Lysator LSH 1.5.2
        Lysator LSH 2.0.1
        http://www.lysator.liu.se/~nisse/archive/lsh-2.0.1.tar.gz
        Lysator LSH 1.5.3
        Lysator LSH 2.0.1
        http://www.lysator.liu.se/~nisse/archive/lsh-2.0.1.tar.gz
        Lysator LSH 1.5.4
        Lysator LSH 2.0.1
        http://www.lysator.liu.se/~nisse/archive/lsh-2.0.1.tar.gz
        Lysator LSH 1.5.5
        Lysator LSH 2.0.1
        http://www.lysator.liu.se/~nisse/archive/lsh-2.0.1.tar.gz
        Lysator LSH 2.0
        Lysator lsh-2.0-2.0.1.diff.gz
        ftp://ftp.lysator.liu.se/pub/security/lsh/lsh-2.0-2.0.1.diff.gz
        Lysator LSH 2.0.1
        http://www.lysator.liu.se/~nisse/archive/lsh-2.0.1.tar.gz
        Debian Linux 3.0 s/390
        Debian lsh-client_1.2.5-2woody3_s390.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_1. 2.5-2woody3_s390.deb
        Debian lsh-server_1.2.5-2woody3_s390.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_1. 2.5-2woody3_s390.deb
        Debian lsh-utils_1.2.5-2woody3_s390.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-utils_1.2 .5-2woody3_s390.deb
        Debian Linux 3.0 arm
        Debian lsh-client_1.2.5-2woody3_arm.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_1. 2.5-2woody3_arm.deb
        Debian lsh-server_1.2.5-2woody3_arm.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_1. 2.5-2woody3_arm.deb
        Debian lsh-utils_1.2.5-2woody3_arm.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-utils_1.2 .5-2woody3_arm.deb
        Debian Linux 3.0 alpha
        Debian lsh-client_1.2.5-2woody3_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_1. 2.5-2woody3_alpha.deb
        Debian lsh-server_1.2.5-2woody3_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_1. 2.5-2woody3_alpha.deb
        Debian lsh-utils_1.2.5-2woody3_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-utils_1.2 .5-2woody3_alpha.deb
        Debian Linux 3.0 mips
        Debian lsh-client_1.2.5-2woody3_mips.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_1. 2.5-2woody3_mips.deb
        Debian lsh-server_1.2.5-2woody3_mips.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_1. 2.5-2woody3_mips.deb
        Debian lsh-utils_1.2.5-2woody3_mips.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-utils_1.2 .5-2woody3_mips.deb
        Debian Linux 3.0 mipsel
        Debian lsh-client_1.2.5-2woody3_mipsel.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_1. 2.5-2woody3_mipsel.deb
        Debian lsh-server_1.2.5-2woody3_mipsel.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_1. 2.5-2woody3_mipsel.deb
        Debian lsh-utils_1.2.5-2woody3_mipsel.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-utils_1.2 .5-2woody3_mipsel.deb
        Debian Linux 3.0 m68k
        Debian lsh-client_1.2.5-2woody3_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-client_1. 2.5-2woody3_m68k.deb
        Debian lsh-server_1.2.5-2woody3_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-server_1. 2.5-2woody3_m68k.deb
        Debian lsh-utils_1.2.5-2woody3_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/l/lsh-utils/lsh-utils_1.2 .5-2woody3_m68k.deb
        Debian Linux 3.0 sparc
        Debian lsh-server_1.2.5-2woody3_sparc.deb
        Debian GNU/Linux 3.0 alias woody
        http://se

- 漏洞信息

14825
LSH lshd parse_kexinit() Function Malformed Key Exchange Message Remote DoS
Remote / Network Access Denial of Service
Loss of Availability

- 漏洞描述

- 时间线

2005-03-16 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Lysator LSH Unspecified Denial Of Service Vulnerability
Unknown 12829
No No
2005-03-17 12:00:00 2009-07-12 10:56:00
The individual or individuals responsible for the discovery of this issue are currently unknown; the vendor disclosed this issue.

- 受影响的程序版本

Lysator LSH 2.0
Lysator LSH 1.5.5
Lysator LSH 1.5.4
Lysator LSH 1.5.3
Lysator LSH 1.5.2
Lysator LSH 1.5.1
Lysator LSH 1.5
Debian Linux 3.0 sparc
Debian Linux 3.0 s/390
Debian Linux 3.0 ppc
Debian Linux 3.0 mipsel
Debian Linux 3.0 mips
Debian Linux 3.0 m68k
Debian Linux 3.0 ia-64
Debian Linux 3.0 ia-32
Debian Linux 3.0 hppa
Debian Linux 3.0 arm
Debian Linux 3.0 alpha
Debian Linux 3.0
Lysator LSH 2.0.1

- 不受影响的程序版本

Lysator LSH 2.0.1

- 漏洞讨论

An unspecified denial of service vulnerability affects Lysator LSH. The underlying cause of this issue is currently unknown; this BID will be updated as more details become available.

An attacker may leverage this issue to cause the affected application to stop responding or crash, ultimately denying service to legitimate users.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Debian has released advisory DSA 717-1 to address this issue. Please see the referenced advisory for further information on obtaining and applying fixes.

The vendor has released an upgrade along with patches dealing with this issue.


Lysator LSH 1.5

Lysator LSH 1.5.1

Lysator LSH 1.5.2

Lysator LSH 1.5.3

Lysator LSH 1.5.4

Lysator LSH 1.5.5

Lysator LSH 2.0

Debian Linux 3.0 s/390

Debian Linux 3.0 arm

Debian Linux 3.0 alpha

Debian Linux 3.0 mips

Debian Linux 3.0 mipsel

Debian Linux 3.0 m68k

Debian Linux 3.0 sparc

Debian Linux 3.0 ppc

Debian Linux 3.0 hppa

Debian Linux 3.0

Debian Linux 3.0 ia-32

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站