CVE-2005-0785
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:14:29
NMCS    

[原文]Cross-site scripting (XSS) vulnerability in usersrecentposts in YaBB 2.0 rc1 allows remote attackers to inject arbitrary web script or HTML via the username parameter.


[CNNVD]YaBB Remote UsersRecentPosts跨站脚本攻击漏洞(CNNVD-200505-673)

        YaBB 2.0 rc1的usersrecentposts中存在跨站脚本(XSS)漏洞,远程攻击者可以通过用户名参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0785
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0785
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-673
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111083400601759&w=2
(UNKNOWN)  BUGTRAQ  20050313 YaBB2 rc1 XSS
http://securitytracker.com/id?1013420
(UNKNOWN)  SECTRACK  1013420
http://www.securityfocus.com/bid/12756
(PATCH)  BID  12756
http://xforce.iss.net/xforce/xfdb/19671
(VENDOR_ADVISORY)  XF  yabb-usersrecentposts-xss(19671)

- 漏洞信息

YaBB Remote UsersRecentPosts跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        YaBB 2.0 rc1的usersrecentposts中存在跨站脚本(XSS)漏洞,远程攻击者可以通过用户名参数注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        YaBB YaBB 2.0 RC1
        YaBB YaBB_2_RC1_031405.zip
        http://www.yabbforum.com/downloads.php?file=YaBB_2_RC1_031405.zip

- 漏洞信息

YaBB Remote UsersRecentPosts Cross-Site Scripting Vulnerability
Input Validation Error 12756
Yes No
2005-03-08 12:00:00 2009-07-12 10:56:00
trueend5 is credited with the discovery of this issue.

- 受影响的程序版本

YaBB YaBB 2.0 RC1

- 漏洞讨论

A remote cross-site scripting vulnerability affects YaBB. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamically generated Web content.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required to leverage this issue. The following proof of concepts have been provided:

http://www.example.com/YaBB.pl?action=usersrecentposts;username=<IFRAME%20SRC%3Djavascript:alert('PersianHacker.NET-XSS')><%252FIFRAME>
http://wordforlife.com/cgi-bin/yabb2/YaBB.pl?action=usersrecentposts;username=<IFRAME%20SRC%3Djavascript:alert('PersianHacker.NET-XSS')><%252FIFRAME>
http://yabbtest.spikecity.net/cgi-bin/SP2/YaBB.pl?action=usersrecentposts;username=<IFRAME%20SRC%3Djavascript:alert('PersianHacker.NET-XSS')><%252FIFRAME>

- 解决方案

The vendor has released updates to address this vulnerability. The vendor suggests that customers upgrade to the latest development version: 'YaBB 2, March 14th (031405)'.


YaBB YaBB 2.0 RC1

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站