CVE-2005-0781
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:14:23
NMCO    

[原文]SQL injection vulnerability in (1) viewall.php and (2) category.php in paFileDB 3.1 and earlier allows remote attackers to execute arbitrary SQL commands via the start parameter to pafiledb.php.


[CNNVD]PAFileDB 多个SQL注入及跨站脚本执行漏洞(CNNVD-200505-449)

        在paFileDB中存在多个SQL注入和跨站脚本漏洞,漏洞的起因是viewall.php和category.php脚本。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:php_arena:pafiledb:2.1.1
cpe:/a:php_arena:pafiledb:3.0
cpe:/a:php_arena:pafiledb:1.1.3
cpe:/a:php_arena:pafiledb:3.1
cpe:/a:php_arena:pafiledb:3.0_beta_3.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0781
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0781
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-449
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111065796525043&w=2
(UNKNOWN)  BUGTRAQ  20050312 [SECURITYREASON.COM] SQL injection and XSS in paFileDB
http://www.securityfocus.com/bid/12788
(UNKNOWN)  BID  12788
http://xforce.iss.net/xforce/xfdb/19688
(UNKNOWN)  XF  pafiledb-viewall-category-sql-injection(19688)

- 漏洞信息

PAFileDB 多个SQL注入及跨站脚本执行漏洞
高危 SQL注入
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        在paFileDB中存在多个SQL注入和跨站脚本漏洞,漏洞的起因是viewall.php和category.php脚本。

- 公告与补丁

        暂无数据

- 漏洞信息

14839
paFileDB viewall.php start Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

paFileDB contains a flaw that may allow a remote attacker to inject arbitrary SQL queries. The issue is due to the 'start' parameter in the 'viewall.php' script not being properly sanitized and may allow a remote attacker to inject or manipulate SQL queries.

- 时间线

2005-03-12 Unknow
2005-03-12 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, PHP Arena has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站