CVE-2005-0769
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2011-03-07 21:20:33
NMCOS    

[原文]Multiple buffer overflows in OpenSLP before 1.1.5 allow remote attackers to have an unknown impact via malformed SLP packets.


[CNNVD]OpenSLP多个未明缓冲区溢出漏洞(CNNVD-200505-511)

        OpenSLP before 1.1.5存在多个缓冲区溢出,远程攻击者可以通过有缺陷的SLP包来制造未知的影响。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:openslp:openslp:1.0.11
cpe:/a:openslp:openslp:1.0.5
cpe:/a:openslp:openslp:1.0.6
cpe:/a:openslp:openslp:1.0.1
cpe:/a:openslp:openslp:1.0.7
cpe:/a:openslp:openslp:1.0.2
cpe:/a:openslp:openslp:1.2.1
cpe:/a:openslp:openslp:1.1.5
cpe:/a:openslp:openslp:1.0_.0
cpe:/a:openslp:openslp:1.0.4
cpe:/a:openslp:openslp:1.0.9_a
cpe:/a:openslp:openslp:1.0.8_a
cpe:/a:openslp:openslp:1.2_.0
cpe:/a:openslp:openslp:1.0.10
cpe:/a:openslp:openslp:1.0.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0769
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0769
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-511
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/12792
(VENDOR_ADVISORY)  BID  12792
http://secunia.com/advisories/14561
(VENDOR_ADVISORY)  SECUNIA  14561
http://xforce.iss.net/xforce/xfdb/19683
(VENDOR_ADVISORY)  XF  openslp-slp-bo(19683)
http://www.vupen.com/english/advisories/2006/3879
(UNKNOWN)  VUPEN  ADV-2006-3879
http://www.ubuntulinux.org/support/documentation/usn/usn-98-1
(UNKNOWN)  UBUNTU  USN-98-1
http://www.securityfocus.com/archive/1/archive/1/447537/100/0/threaded
(UNKNOWN)  HP  SSRT061149
http://www.novell.com/linux/security/advisories/2005_15_openslp.html
(UNKNOWN)  SUSE  SUSE-SA:2005:015
http://www.gentoo.org/security/en/glsa/glsa-200503-25.xml
(UNKNOWN)  GENTOO  GLSA-200503-25
http://www.securityfocus.com/archive/1/archive/1/447537/100/0/threaded
(UNKNOWN)  HP  SSRT061149
http://www.mandriva.com/security/advisories?name=MDKSA-2005:055
(UNKNOWN)  MANDRAKE  MDKSA-2005:055
http://secunia.com/advisories/22128
(UNKNOWN)  SECUNIA  22128

- 漏洞信息

OpenSLP多个未明缓冲区溢出漏洞
高危 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        OpenSLP before 1.1.5存在多个缓冲区溢出,远程攻击者可以通过有缺陷的SLP包来制造未知的影响。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        HP HP-UX B.11.11
        HP B.11.11 SLP Revision 1.2
        ftp://hpuxslp:hpuxslp@hprc.external.hp.com/upgrade_SLP.depot
        HP HP-UX B.11.23
        HP PHNE_33508
        http://itrc.hp.com
        OpenSLP OpenSLP 1.0 .0
        OpenSLP OpenSLP 1.2.1
        http://sourceforge.net/project/showfiles.php?group_id=1730
        OpenSLP OpenSLP 1.0.1
        OpenSLP OpenSLP 1.2.1
        http://sourceforge.net/project/showfiles.php?group_id=1730
        OpenSLP OpenSLP 1.0.10
        OpenSLP OpenSLP 1.2.1
        http://sourceforge.net/project/showfiles.php?group_id=1730
        OpenSLP OpenSLP 1.0.11
        Mandrake lib64openslp1-1.0.11-5.1.100mdk.amd64.rpm
        Mandrake Linux 10.0/AMD64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lib64openslp1-1.0.11-5.1.101mdk.x86_64.rpm
        Mandrake Linux 10.1/x86_64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lib64openslp1-1.0.11-5.1.C30mdk.x86_64.rpm
        Mandrake Corporate Server 3.0/x86_64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lib64openslp1-devel-1.0.11-5.1.100mdk.amd64.rpm
        Mandrake Linux 10.0/AMD64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lib64openslp1-devel-1.0.11-5.1.101mdk.x86_64.rpm
        Mandrake Linux 10.1/x86_64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lib64openslp1-devel-1.0.11-5.1.C30mdk.x86_64.rpm
        Mandrake Corporate Server 3.0/x86_64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake libopenslp1-1.0.11-5.1.100mdk.i586.rpm
        Mandrake Linux 10.0
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake libopenslp1-1.0.11-5.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake libopenslp1-1.0.11-5.1.C30mdk.i586.rpm
        Mandrake Corporate Server 3.0
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake libopenslp1-devel-1.0.11-5.1.100mdk.i586.rpm
        Mandrake Linux 10.0
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake libopenslp1-devel-1.0.11-5.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake libopenslp1-devel-1.0.11-5.1.C30mdk.i586.rpm
        Mandrake Corporate Server 3.0
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake openslp-1.0.11-5.1.100mdk.amd64.rpm
        Mandrake Linux 10.0/AMD64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake openslp-1.0.11-5.1.100mdk.i586.rpm
        Mandrake Linux 10.0
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake openslp-1.0.11-5.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake openslp-1.0.11-5.1.101mdk.x86_64.rpm
        Mandrake Linux 10.1/x86_64
        http://www.mandrakesecure.net/en/ftp.php
        OpenSLP OpenSLP 1.2.1
        http://sourceforge.net/project/showfiles.php?group_id=1730
        Ubuntu libslp-dev_1.0.11-7ubuntu0.1_amd64.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/o/openslp/libslp-dev_1.0.1 1-7ubuntu0.1_amd64.deb
        Ubuntu libslp-dev_1.0.11-7ubuntu0.1_i386.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/o/openslp/libslp-dev_1.0.1 1-7ubuntu0.1_i386.deb
        Ubuntu libslp-dev_1.0.11-7ubuntu0.1_powerpc.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/o/openslp/libslp-dev_1.0.1 1-7ubuntu0.1_powerpc.deb
        Ubuntu libslp1_1.0.11-7ubuntu0.1_amd64.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/o/openslp/libslp1_1.0.11-7 ubuntu0.1_amd64.deb
        Ubuntu libslp1_1.0.11-7ubuntu0.1_i386.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/o/openslp/libslp1_1.0.11-7 ubuntu0.1_i386.deb
        Ubuntu libslp1_1.0.11-7ubuntu0.1_powerpc.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/o/openslp/libslp1_1.0.11-7 ubuntu0.1_powerpc.deb
        Ubuntu openslp-doc_1.0.11-7ubuntu0.1_all.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/main/o/openslp/openslp-doc_1.0. 11-7ubuntu0.1_all.deb
        Ubuntu slpd_1.0.11-7ubuntu0.1_amd64.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/universe/o/openslp/slpd_1.0.11- 7ubuntu0.1_amd64.deb
        Ubuntu slpd_1.0.11-7ubuntu0.1_i386.deb
        Ubuntu 4.10 (Warty Warthog)
        http://security.ubuntu.com/ubuntu/pool/universe/o/openslp/slpd_1.0.11- 7ubuntu0.1_i386.deb
        Ubuntu slpd_1.0.11-7ubunt

- 漏洞信息

14766
OpenSLP Multiple Unspecified Overflows
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

OpenSLP contains multiple buffer overflows and out-of-bounds memory access flaws that may allow an attacker to remotely execute arbitrary code. No further details have been provided.

- 时间线

2005-03-15 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.2.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

OpenSLP Multiple Unspecified Buffer Overflow Vulnerabilities
Boundary Condition Error 12792
Yes No
2005-03-14 12:00:00 2007-03-09 09:35:00
Discovery is credited to the SUSE Security Team.

- 受影响的程序版本

OpenSLP OpenSLP 1.2.1
OpenSLP OpenSLP 1.2 .0
OpenSLP OpenSLP 1.1.5
+ S.u.S.E. Linux Enterprise Server 9
+ S.u.S.E. Linux Personal 9.2 x86_64
+ S.u.S.E. Linux Personal 9.2
+ S.u.S.E. Linux Personal 9.1 x86_64
+ S.u.S.E. Linux Personal 9.1
+ S.u.S.E. Novell Linux Desktop 9.0
OpenSLP OpenSLP 1.0.11
+ Conectiva Linux 9.0
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
+ Ubuntu Ubuntu Linux 4.1 ppc
+ Ubuntu Ubuntu Linux 4.1 ia64
+ Ubuntu Ubuntu Linux 4.1 ia32
OpenSLP OpenSLP 1.0.10
OpenSLP OpenSLP 1.0.9 a
OpenSLP OpenSLP 1.0.8 a
+ Conectiva Linux 9.0
OpenSLP OpenSLP 1.0.7
OpenSLP OpenSLP 1.0.6
OpenSLP OpenSLP 1.0.5
OpenSLP OpenSLP 1.0.4
OpenSLP OpenSLP 1.0.3
OpenSLP OpenSLP 1.0.2
OpenSLP OpenSLP 1.0.1
OpenSLP OpenSLP 1.0 .0
HP HP-UX B.11.23
HP HP-UX B.11.11
Gentoo Linux
Conectiva Linux 10.0
Conectiva Linux 9.0
OpenSLP OpenSLP 1.2.1

- 不受影响的程序版本

OpenSLP OpenSLP 1.2.1

- 漏洞讨论

OpenSLP is prone to multiple unspecified buffer-overflow vulnerabilities that may be triggered by malformed SLP (Service Location Protocol) packets.

If successfully exploited, these issues could allow remote code execution in the context of the software.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or if you are aware of more recent information, please mail us at: mailto:vuldb@securityfocus.com.

- 解决方案

The vendor has addressed the issue in OpenSLP 1.2.1.

Please see the referenced advisories for more information.


HP HP-UX B.11.11

HP HP-UX B.11.23

OpenSLP OpenSLP 1.0 .0

OpenSLP OpenSLP 1.0.1

OpenSLP OpenSLP 1.0.10

OpenSLP OpenSLP 1.0.11

OpenSLP OpenSLP 1.0.2

OpenSLP OpenSLP 1.0.3

OpenSLP OpenSLP 1.0.4

OpenSLP OpenSLP 1.0.5

OpenSLP OpenSLP 1.0.6

OpenSLP OpenSLP 1.0.7

OpenSLP OpenSLP 1.0.8 a

OpenSLP OpenSLP 1.0.9 a

OpenSLP OpenSLP 1.1.5

OpenSLP OpenSLP 1.2 .0

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站