CVE-2005-0758
CVSS4.6
发布时间 :2005-05-13 00:00:00
修订时间 :2011-03-07 21:20:32
NMCOPS    

[原文]zgrep in gzip before 1.3.5 does not properly sanitize arguments, which allows local users to execute arbitrary commands via filenames that are injected into a sed script.


[CNNVD]Mac OS X 2007-007更新修复多个安全漏洞(CNNVD-200505-1008)

        Mac OS X是苹果家族计算机所使用的操作系统。
        Apple 2007-007安全更新修复了Mac OS X中的多个安全漏洞,远程或本地攻击者可能利用这些漏洞造成多种威胁。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:9797zgrep in gzip before 1.3.5 does not properly sanitize arguments, which allows local users to execute arbitrary commands via filenames that a...
oval:org.mitre.oval:def:1107gzip zgrep Sanitation Vulnerability
oval:org.mitre.oval:def:1081gzip Argument Sanitation Vulnerability
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0758
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0758
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-1008
(官方数据源) CNNVD

- 其它链接及资源

http://www.gentoo.org/security/en/glsa/glsa-200505-05.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200505-05
http://xforce.iss.net/xforce/xfdb/20539
(UNKNOWN)  XF  gzip-zgrep-file-installation(20539)
http://www.vupen.com/english/advisories/2007/2732
(UNKNOWN)  VUPEN  ADV-2007-2732
http://www.ubuntu.com/usn/usn-158-1
(UNKNOWN)  UBUNTU  USN-158-1
http://www.securityfocus.com/bid/13582
(UNKNOWN)  BID  13582
http://www.redhat.com/support/errata/RHSA-2005-474.html
(UNKNOWN)  REDHAT  RHSA-2005:474
http://www.osvdb.org/16371
(UNKNOWN)  OSVDB  16371
http://www.fedoralegacy.org/updates/FC2/2005-11-14-FLSA_2005_158801__Updated_bzip2_packages_fix_security_issues.html
(UNKNOWN)  FEDORA  FLSA:158801
http://securitytracker.com/id?1013928
(UNKNOWN)  SECTRACK  1013928
http://secunia.com/advisories/19183
(UNKNOWN)  SECUNIA  19183
http://secunia.com/advisories/18100
(UNKNOWN)  SECUNIA  18100
http://rhn.redhat.com/errata/RHSA-2005-357.html
(UNKNOWN)  REDHAT  RHSA-2005:357
http://bugs.gentoo.org/show_bug.cgi?id=90626
(VENDOR_ADVISORY)  MISC  http://bugs.gentoo.org/show_bug.cgi?id=90626
ftp://patches.sgi.com/support/free/security/advisories/20060301-01.U.asc
(UNKNOWN)  SGI  20060301-01-U
ftp://ftp.sco.com/pub/updates/UnixWare/SCOSA-2005.58/SCOSA-2005.58.txt
(UNKNOWN)  SCO  SCOSA-2005.58
http://www.securityfocus.com/bid/25159
(UNKNOWN)  BID  25159
http://www.openpkg.com/security/advisories/OpenPKG-SA-2007.002.html
(UNKNOWN)  OPENPKG  OpenPKG-SA-2007.002
http://www.mandriva.com/security/advisories?name=MDKSA-2006:027
(UNKNOWN)  MANDRIVA  MDKSA-2006:027
http://www.mandriva.com/security/advisories?name=MDKSA-2006:026
(UNKNOWN)  MANDRIVA  MDKSA-2006:026
http://slackware.com/security/viewer.php?l=slackware-security&y=2006&m=slackware-security.555852
(UNKNOWN)  SLACKWARE  SSA:2006-262
http://secunia.com/advisories/26235
(UNKNOWN)  SECUNIA  26235
http://secunia.com/advisories/22033
(UNKNOWN)  SECUNIA  22033
http://lists.apple.com/archives/security-announce//2007/Jul/msg00004.html
(UNKNOWN)  APPLE  APPLE-SA-2007-07-31
http://docs.info.apple.com/article.html?artnum=306172
(UNKNOWN)  CONFIRM  http://docs.info.apple.com/article.html?artnum=306172

- 漏洞信息

Mac OS X 2007-007更新修复多个安全漏洞
中危 输入验证
2005-05-13 00:00:00 2006-09-05 00:00:00
远程  
        Mac OS X是苹果家族计算机所使用的操作系统。
        Apple 2007-007安全更新修复了Mac OS X中的多个安全漏洞,远程或本地攻击者可能利用这些漏洞造成多种威胁。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        http://docs.info.apple.com/article.html?artnum=306172

- 漏洞信息 (F53505)

OpenPKG Security Advisory 2007.2 (PacketStormID:F53505)
2007-01-13 00:00:00
OpenPKG Foundation  openpkg.com
advisory
CVE-2005-0953,CVE-2005-0758
[点击下载]

OpenPKG Security Advisory - Together with two portability and stability issues, two older security issues were fixed in the compression tool BZip2, versions up to and including 1.0.3.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

____________________________________________________________________________

Publisher Name:          OpenPKG GmbH
Publisher Home:          http://openpkg.com/

Advisory Id (public):    OpenPKG-SA-2007.002
Advisory Type:           OpenPKG Security Advisory (SA)
Advisory Directory:      http://openpkg.com/go/OpenPKG-SA
Advisory Document:       http://openpkg.com/go/OpenPKG-SA-2007.002
Advisory Published:      2007-01-05 21:58 UTC

Issue Id (internal):     OpenPKG-SI-20070105.01
Issue First Created:     2007-01-05
Issue Last Modified:     2007-01-05
Issue Revision:          04
____________________________________________________________________________

Subject Name:            bzip2
Subject Summary:         Compression Tool
Subject Home:            http://www.bzip.org/
Subject Versions:        * <= 1.0.3

Vulnerability Id:        CVE-2005-0953, CVE-2005-0758
Vulnerability Scope:     global (not OpenPKG specific)

Attack Feasibility:      run-time
Attack Vector:           local system
Attack Impact:           manipulation of data, arbitrary code execution

Description:
    Together with two portability and stability issues, two older
    security issues were fixed in the compression tool BZip2 [0], versions
    up to and including 1.0.3.
    
    The first issue is a race condition which allows local users to
    modify permissions of arbitrary files via a hard link attack on a
    file while it is being decompressed, whose permissions are changed
    by bzip2 after the decompression is complete.
    
    The second issue affects the script bzgrep(1). It does not properly
    sanitize arguments, which allows local users to execute arbitrary
    commands via filenames that are injected into a sed(1) script.

References:
    [0] http://www.bzip.org/
____________________________________________________________________________

Primary Package Name:    bzip2
Primary Package Home:    http://openpkg.org/go/package/bzip2

Corrected Distribution:  Corrected Branch: Corrected Package:
OpenPKG Enterprise       E1.0-SOLID        bzip2-1.0.3-E1.0.1
OpenPKG Enterprise       E1.0-SOLID        openpkg-E1.0.2-E1.0.2
OpenPKG Community        2-STABLE-20061018 bzip2-1.0.4-2.20070105
OpenPKG Community        2-STABLE-20061018 openpkg-2.20070105-2.20070105
OpenPKG Community        2-STABLE          bzip2-1.0.4-2.20070105
OpenPKG Community        2-STABLE          openpkg-2.20070105-2.20070105
OpenPKG Community        CURRENT           bzip2-1.0.4-20070105
OpenPKG Community        CURRENT           openpkg-20070105-20070105
____________________________________________________________________________

For security reasons, this document was digitally signed with the
OpenPGP public key of the OpenPKG GmbH (public key id 61B7AE34)
which you can download from http://openpkg.com/openpkg.com.pgp
or retrieve from the OpenPGP keyserver at hkp://pgp.openpkg.org/.
Follow the instructions at http://openpkg.com/security/signatures/
for more details on how to verify the integrity of this document.
____________________________________________________________________________

-----BEGIN PGP SIGNATURE-----
Comment: OpenPKG GmbH <http://openpkg.com/>

iD8DBQFFnrwRZwQuyWG3rjQRAgkdAJ9YBx7auj7ursOTj5M/78Kq3SlGlACfc0aV
2IRFnTk4CCJwa9FPgv1z7c0=
=Iq2w
-----END PGP SIGNATURE-----
    

- 漏洞信息 (F38412)

Gentoo Linux Security Advisory 200505-5 (PacketStormID:F38412)
2005-07-02 00:00:00
Gentoo  security.gentoo.org
advisory
linux,gentoo
CVE-2005-0758,CVE-2005-0988,CVE-2005-1228
[点击下载]

Gentoo Linux Security Advisory GLSA 200505-05 - The gzip and gunzip programs are vulnerable to a race condition when setting file permissions (CVE-2005-0988), as well as improper handling of filename restoration (CVE-2005-1228). The zgrep utility improperly sanitizes arguments, which may come from an untrusted source (CVE-2005-0758). Versions less than 1.3.5-r6 are affected.

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200505-05
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: gzip: Multiple vulnerabilities
      Date: May 09, 2005
      Bugs: #89946, #90626
        ID: 200505-05

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

gzip contains multiple vulnerabilities potentially allowing an attacker
to execute arbitrary commands.

Background
==========

gzip (GNU zip) is a popular compression program. The included zgrep
utility allows you to grep gzipped files in place.

Affected packages
=================

    -------------------------------------------------------------------
     Package        /  Vulnerable  /                        Unaffected
    -------------------------------------------------------------------
  1  app-arch/gzip     < 1.3.5-r6                          >= 1.3.5-r6

Description
===========

The gzip and gunzip programs are vulnerable to a race condition when
setting file permissions (CAN-2005-0988), as well as improper handling
of filename restoration (CAN-2005-1228). The zgrep utility improperly
sanitizes arguments, which may come from an untrusted source
(CAN-2005-0758).

Impact
======

These vulnerabilities could allow arbitrary command execution, changing
the permissions of arbitrary files, and installation of files to an
aribitrary location in the filesystem.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All gzip users should upgrade to the latest stable version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-arch/gzip-1.3.5-r6"

References
==========

  [ 1 ] CAN-2005-0758
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0758
  [ 2 ] CAN-2005-0988
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0988
  [ 3 ] CAN-2005-1228
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-1228

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200505-05.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0
    

- 漏洞信息

16371
zgrep Unspecified Arbitrary Command Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-05-09 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Gzip Zgrep Arbitrary Command Execution Vulnerability
Input Validation Error 13582
Yes No
2005-05-10 12:00:00 2007-08-01 08:25:00
The discoverer of this issue is unknown.

- 受影响的程序版本

Turbolinux Turbolinux Workstation 8.0
Turbolinux Turbolinux Workstation 7.0
Turbolinux Turbolinux Server 10.0
Turbolinux Turbolinux Server 8.0
Turbolinux Turbolinux Server 7.0
Turbolinux Turbolinux Desktop 10.0
Turbolinux Home
Turbolinux Appliance Server 1.0 Workgroup Edition
Turbolinux Appliance Server 1.0 Hosting Edition
Trustix Secure Linux 3.0
Trustix Secure Linux 2.2
Trustix Secure Enterprise Linux 2.0
SGI ProPack 3.0 SP6
SGI ProPack 3.0 SP5
SGI ProPack 3.0
SGI Advanced Linux Environment 3.0
SCO Unixware 7.1.4
SCO Open Server 6.0
SCO Open Server 5.0.7
RedHat Linux 9.0 i386
RedHat Linux 7.3 i686
RedHat Linux 7.3 i386
RedHat Linux 7.3
RedHat Enterprise Linux WS 4
RedHat Enterprise Linux WS 3
RedHat Enterprise Linux WS 2.1 IA64
RedHat Enterprise Linux WS 2.1
RedHat Enterprise Linux ES 4
RedHat Enterprise Linux ES 3
RedHat Enterprise Linux ES 2.1 IA64
RedHat Enterprise Linux ES 2.1
RedHat Desktop 4.0
RedHat Desktop 3.0
RedHat Advanced Workstation for the Itanium Processor 2.1 IA64
RedHat Advanced Workstation for the Itanium Processor 2.1
Red Hat Fedora Core3
Red Hat Fedora Core2
Red Hat Fedora Core1
Red Hat Enterprise Linux AS 4
Red Hat Enterprise Linux AS 3
Red Hat Enterprise Linux AS 2.1 IA64
Red Hat Enterprise Linux AS 2.1
OpenPKG OpenPKG Stable
OpenPKG OpenPKG E1.0-Solid
OpenPKG OpenPKG Current
OpenPKG OpenPKG 2-Stable-20061018
Mandriva Linux Mandrake 2006.0 x86_64
Mandriva Linux Mandrake 2006.0
Mandriva Linux Mandrake 10.2 x86_64
Mandriva Linux Mandrake 10.2
Mandriva Linux Mandrake 10.1 x86_64
Mandriva Linux Mandrake 10.1
MandrakeSoft Multi Network Firewall 2.0
MandrakeSoft Corporate Server 3.0 x86_64
MandrakeSoft Corporate Server 3.0
MandrakeSoft Corporate Server 2.1 x86_64
MandrakeSoft Corporate Server 2.1
GNU zgrep 1.2.4 a
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ MandrakeSoft Corporate Server 2.1 x86_64
+ MandrakeSoft Corporate Server 2.1
+ Mandriva Linux Mandrake 10.2 x86_64
+ Mandriva Linux Mandrake 10.2
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
GNU zgrep 1.2.4
F5 BigIP 4.6.3
F5 BigIP 4.6.2
F5 BigIP 4.6
F5 BigIP 4.5.12
F5 BigIP 4.5.11
F5 BigIP 4.5.10
F5 BigIP 4.5.9
F5 BigIP 4.5.6
F5 BigIP 4.5
F5 BigIP 4.4
F5 BigIP 4.3
F5 BigIP 4.2
F5 BigIP 4.0
F5 3-DNS 4.6.3
F5 3-DNS 4.6.2
F5 3-DNS 4.6
F5 3-DNS 4.5.12
F5 3-DNS 4.5.11
F5 3-DNS 4.5
F5 3-DNS 4.4
F5 3-DNS 4.3
F5 3-DNS 4.2
bzip2 bzip2 1.0.2
bzip2 bzip2 1.0.1
- FreeBSD FreeBSD 4.5
- FreeBSD FreeBSD 4.4
- Trustix Secure Linux 1.5
- Trustix Secure Linux 1.2
- Trustix Secure Linux 1.1
Avaya S8710 R2.0.1
Avaya S8710 R2.0.0
Avaya S8700 R2.0.1
Avaya S8700 R2.0.0
Avaya S8500 R2.0.1
Avaya S8500 R2.0.0
Avaya S8300 R2.0.1
Avaya S8300 R2.0.0
Avaya Network Messaging
Avaya Modular Messaging (MSS) 2.0
Avaya Modular Messaging (MSS) 1.1
Avaya Intuity LX
Avaya Integrated Management 2.1
Avaya Integrated Management
Avaya CVLAN
Avaya Converged Communications Server 2.0
Apple Mac OS X Server 10.4.10
Apple Mac OS X Server 10.3.9
Apple Mac OS X 10.4.10
Apple Mac OS X 10.3.9
F5 BigIP 4.7
F5 BigIP 4.5.13
F5 3-DNS 4.7
F5 3-DNS 4.5.13

- 不受影响的程序版本

F5 BigIP 4.7
F5 BigIP 4.5.13
F5 3-DNS 4.7
F5 3-DNS 4.5.13

- 漏洞讨论

The 'zgrep' utility is reportedly affected by an arbitrary command-execution vulnerability.

An attacker may execute arbitrary commands through zgrep command arguments to potentially gain unauthorized access to the affected computer. Note that this issue poses a security threat only if the arguments originate from a malicious source.

This issue affects zgrep 1.2.4; other versions may be affected as well.

- 漏洞利用

An exploit is not required.

- 解决方案

Please see the referenced vendor advisories for details on obtaining and applying fixes.


Turbolinux Home

Turbolinux Appliance Server 1.0 Hosting Edition

Turbolinux Appliance Server 1.0 Workgroup Edition

Turbolinux Turbolinux Server 10.0

Turbolinux Turbolinux Desktop 10.0

Mandriva Linux Mandrake 10.1

Mandriva Linux Mandrake 10.1 x86_64

Mandriva Linux Mandrake 10.2

Mandriva Linux Mandrake 10.2 x86_64

Apple Mac OS X Server 10.3.9

Apple Mac OS X 10.4.10

Apple Mac OS X Server 10.4.10

MandrakeSoft Corporate Server 2.1 x86_64

MandrakeSoft Corporate Server 2.1

MandrakeSoft Corporate Server 3.0

SGI ProPack 3.0 SP5

MandrakeSoft Corporate Server 3.0 x86_64

SCO Open Server 5.0.7

SCO Open Server 6.0

Turbolinux Turbolinux Server 7.0

SCO Unixware 7.1.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站