CVE-2005-0754
CVSS7.5
发布时间 :2005-04-22 00:00:00
修订时间 :2016-10-17 23:14:10
NMCOPS    

[原文]Kommander in KDE 3.2 through KDE 3.4.0 executes data files without confirmation from the user, which allows remote attackers to execute arbitrary code.


[CNNVD]KDE Kommander未明任意脚本执行漏洞(CNNVD-200504-084)

        Kommander是一款用于编辑和解释虚拟对话框并执行对话框操作附带脚本的虚拟编辑器和解释器。
        Kommander未经用户确认便执行不可信任位置的数据文件。
        由于这些文件可能包含有代码,因此用户可能无意中执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/o:gentoo:linuxGentoo Linux
cpe:/o:conectiva:linux:10.0Conectiva Linux 10.0
cpe:/o:kde:kde:3.2.2
cpe:/o:kde:kde:3.3.1
cpe:/o:kde:kde:3.2
cpe:/o:kde:kde:3.2.1
cpe:/o:conectiva:linux:9.0Conectiva Linux 9.0
cpe:/o:ubuntu:ubuntu_linux:5.04::i386
cpe:/o:ubuntu:ubuntu_linux:5.04::powerpc
cpe:/o:ubuntu:ubuntu_linux:4.1::ppc
cpe:/o:redhat:fedora_core:core_3.0
cpe:/o:ubuntu:ubuntu_linux:4.1::ia64
cpe:/a:kde:quanta:3.1
cpe:/o:ubuntu:ubuntu_linux:5.04::amd64
cpe:/o:kde:kde:3.3
cpe:/o:kde:kde:3.2.3
cpe:/o:kde:kde:3.3.2
cpe:/o:kde:kde:3.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0754
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0754
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200504-084
(官方数据源) CNNVD

- 其它链接及资源

ftp://ftp.kde.org/pub/kde/security_patches/post-3.4.0-kdewebdev-kommander.diff
(VENDOR_ADVISORY)  CONFIRM  ftp://ftp.kde.org/pub/kde/security_patches/post-3.4.0-kdewebdev-kommander.diff
http://marc.info/?l=bugtraq&m=111419664411051&w=2
(UNKNOWN)  BUGTRAQ  20050422 [KDE Security Advisory]: Kommander untrusted code execution
http://www.kde.org/info/security/advisory-20050420-1.txt
(VENDOR_ADVISORY)  CONFIRM  http://www.kde.org/info/security/advisory-20050420-1.txt
http://www.securityfocus.com/bid/13313
(VENDOR_ADVISORY)  BID  13313

- 漏洞信息

KDE Kommander未明任意脚本执行漏洞
高危 资料不足
2005-04-22 00:00:00 2005-10-20 00:00:00
远程  
        Kommander是一款用于编辑和解释虚拟对话框并执行对话框操作附带脚本的虚拟编辑器和解释器。
        Kommander未经用户确认便执行不可信任位置的数据文件。
        由于这些文件可能包含有代码,因此用户可能无意中执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        KDE KDE 3.3
        Fedora kdewebdev-3.3.1-2.1.i386.rpm
        RedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora kdewebdev-3.3.1-2.1.x86_64.rpm
        RedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora kdewebdev-debuginfo-3.3.1-2.1.i386.rpm
        RedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora kdewebdev-debuginfo-3.3.1-2.1.x86_64.rpm
        RedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora kdewebdev-devel-3.3.1-2.1.i386.rpm
        RedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        Fedora kdewebdev-devel-3.3.1-2.1.x86_64.rpm
        RedHat Fedora Core 3
        http://download.fedora.redhat.com/pub/fedora/linux/core/updates/3/
        KDE KDE 3.3.2
        KDE post-3.3.2-kdewebdev-kommander.diff
        ftp://ftp.kde.org/pub/kde/security_patches/post-3.3.2-kdewebdev-komman der.diff
        KDE KDE 3.4
        KDE post-3.4.0-kdewebdev-kommander.diff
        ftp://ftp.kde.org/pub/kde/security_patches/post-3.4.0-kdewebdev-komman der.diff
        Ubuntu kdewebdev-doc-html_3.4.0-0ubuntu2.2_all.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/universe/k/kdewebdev/kdewebdev- doc-html_3.4.0-0ubuntu2.2_all.deb
        Ubuntu kdewebdev_3.4.0-0ubuntu2.2_all.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/kdewebdev_3.4. 0-0ubuntu2.2_all.deb
        Ubuntu kfilereplace_3.4.0-0ubuntu2.2_amd64.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/kfilereplace_3 .4.0-0ubuntu2.2_amd64.deb
        Ubuntu kfilereplace_3.4.0-0ubuntu2.2_i386.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/kfilereplace_3 .4.0-0ubuntu2.2_i386.deb
        Ubuntu kfilereplace_3.4.0-0ubuntu2.2_powerpc.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/kfilereplace_3 .4.0-0ubuntu2.2_powerpc.deb
        Ubuntu kimagemapeditor_3.4.0-0ubuntu2.2_amd64.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/kimagemapedito r_3.4.0-0ubuntu2.2_amd64.deb
        Ubuntu kimagemapeditor_3.4.0-0ubuntu2.2_i386.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/kimagemapedito r_3.4.0-0ubuntu2.2_i386.deb
        Ubuntu kimagemapeditor_3.4.0-0ubuntu2.2_powerpc.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/kimagemapedito r_3.4.0-0ubuntu2.2_powerpc.deb
        Ubuntu klinkstatus_3.4.0-0ubuntu2.2_amd64.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/klinkstatus_3. 4.0-0ubuntu2.2_amd64.deb
        Ubuntu klinkstatus_3.4.0-0ubuntu2.2_i386.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/klinkstatus_3. 4.0-0ubuntu2.2_i386.deb
        Ubuntu klinkstatus_3.4.0-0ubuntu2.2_powerpc.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/klinkstatus_3. 4.0-0ubuntu2.2_powerpc.deb
        Ubuntu kommander-dev_3.4.0-0ubuntu2.2_amd64.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/universe/k/kdewebdev/kommander- dev_3.4.0-0ubuntu2.2_amd64.deb
        Ubuntu kommander-dev_3.4.0-0ubuntu2.2_i386.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/universe/k/kdewebdev/kommander- dev_3.4.0-0ubuntu2.2_i386.deb
        Ubuntu kommander-dev_3.4.0-0ubuntu2.2_powerpc.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/universe/k/kdewebdev/kommander- dev_3.4.0-0ubuntu2.2_powerpc.deb
        Ubuntu kommander_3.4.0-0ubuntu2.2_amd64.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/kommander_3.4. 0-0ubuntu2.2_amd64.deb
        Ubuntu kommander_3.4.0-0ubuntu2.2_i386.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebdev/kommander_3.4. 0-0ubuntu2.2_i386.deb
        Ubuntu kommander_3.4.0-0ubuntu2.2_powerpc.deb
        Ubuntu 5.04 (Hoary Hedgehog)
        http://security.ubuntu.com/ubuntu/pool/main/k/kdewebd

- 漏洞信息 (F37818)

KDE Security Advisory 2005-04-20.1 (PacketStormID:F37818)
2005-06-01 00:00:00
KDE Desktop  kde.org
advisory,arbitrary
CVE-2005-0754
[点击下载]

KDE Security Advisory: Kommander executes without user confirmation data files from possibly untrusted locations. As they contain scripts, the user might accidentally run arbitrary code.

KDE Security Advisory: Kommander untrusted code execution
Original Release Date: 2005-04-20
URL: http://www.kde.org/info/security/advisory-20050420-1.txt

0. References

        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0754

1. Systems affected:

        Quanta 3.1.x, KDE 3.2 and new up to including KDE 3.4.0.


2. Overview:

        Kommander is a visual editor and interpreter to edit and
        interpret visual dialogs and execute scripts attached to
        dialog actions. 

        Kommander executes without user confirmation data files
        from possibly untrusted locations. As they contain 
        scripts, the user might accidentally run arbitrary code.


3. Impact:

        Remotly supplied kommander files from untrusted sources
        are executed without confirmation. 


4. Solution:

        Source code patches have been made available which fix these
        vulnerabilities. Contact your OS vendor / binary package provider
        for information about how to obtain updated binary packages.


5. Patch:

        A patch for KDE 3.4.0 is available from 
        ftp://ftp.kde.org/pub/kde/security_patches :

        c388b21d91c8326fc9757cd8786713db  post-3.4.0-kdewebdev-kommander.diff

        A patch for KDE 3.3.2 is available from 
        ftp://ftp.kde.org/pub/kde/security_patches :

        d210c07121c1ba3a97660a6e166738e6  post-3.3.2-kdewebdev-kommander.diff


6. Time line and credits:

        13/03/2005 Notification of KDE security by Eckhart W    

- 漏洞信息

15761
KDE Kommander Dialog Action Arbitrary Script Execution

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-20 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

KDE Kommander Arbitrary Script Execution Vulnerability
Unknown 13313
Yes No
2005-04-22 12:00:00 2009-07-12 02:06:00
Discovered by Eckhart Wörner.

- 受影响的程序版本

Ubuntu Ubuntu Linux 5.0 4 powerpc
Ubuntu Ubuntu Linux 5.0 4 i386
Ubuntu Ubuntu Linux 5.0 4 amd64
Ubuntu Ubuntu Linux 4.1 ppc
Ubuntu Ubuntu Linux 4.1 ia64
Ubuntu Ubuntu Linux 4.1 ia32
Red Hat Fedora Core3
KDE Quanta 3.1
KDE KDE 3.4
KDE KDE 3.3.2
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Debian Linux 3.1
+ Debian Linux 3.1
KDE KDE 3.3.2
KDE KDE 3.3.1
+ Red Hat Fedora Core3
KDE KDE 3.3
KDE KDE 3.2.3
KDE KDE 3.2.2
+ KDE KDE 3.2.2
+ Red Hat Fedora Core2
KDE KDE 3.2.1
KDE KDE 3.2
Gentoo Linux
Conectiva Linux 10.0
Conectiva Linux 9.0

- 漏洞讨论

KDE Kommander is prone to a vulnerability that could allow arbitrary script code to be executed without user interaction. Such code would execute in the security context of the user running Kommander.

This issue was reported to affect Quanta 3.1.x and KDE from 3.2 to 3.4.0.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Ubuntu has released an advisory (USN-115-1) and fixes to address this issue. Please see the referenced advisory for further information.

Fedora advisory FEDORA-2005-345 for Fedora Core 3 is available to address this issue. Fixes may be installed using the Red Hat Update Agent; this can be accomplished using the 'up2date' command. Please see the referenced advisory for more information.

Gentoo has released advisory GLSA 200504-23 and a fix to address this issue. To obtain the upgrade, enter the following:

emerge --sync
emerge --ask --oneshot --verbose ">=kde-base/kdewebdev-3.3.2-r1"

Fixes are available.

Conectiva Linux has released advisory CLA-2005:953 to address this, and other issues. Please see the referenced advisory for further information.

Gentoo has updated advisory GLSA 200504-23 to GLSA 200504-23:02. This advisory includes updated packages to address this issue. The previous fixes did not properly address this issue. To obtain the upgrade, enter the following:

emerge --sync
emerge --ask --oneshot --verbose ">=kde-base/kdewebdev-3.3.2-r2"


KDE KDE 3.3

KDE KDE 3.3.2

KDE KDE 3.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站