CVE-2005-0712
CVSS4.6
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-10 15:36:49
NMCOS    

[原文]Mac OS X before 10.3.8 users world-writable permissions for certain directories, which may allow local users to gain privileges, possibly via the receipt cache or ColorSync profiles.


[CNNVD]Mac OS X CF_CHARSET_PATH环境变量处理缓冲区溢出漏洞(CNNVD-200505-759)

        Mac OS X中默认捆绑的Core Foundation程序库中存在缓冲区溢出漏洞,可能允许攻击者获取root用户权限。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.2Apple Mac OS X 10.2
cpe:/o:apple:mac_os_x:10.1Apple Mac OS X 10.1
cpe:/o:apple:mac_os_x:10.3.4Apple Mac OS X 10.3.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0712
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0712
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-759
(官方数据源) CNNVD

- 其它链接及资源

http://lists.apple.com/archives/security-announce/2005/Mar/msg00000.html
(UNKNOWN)  APPLE  APPLE-SA-2005-03-21

- 漏洞信息

Mac OS X CF_CHARSET_PATH环境变量处理缓冲区溢出漏洞
中危 设计错误
2005-05-02 00:00:00 2005-10-20 00:00:00
本地  
        Mac OS X中默认捆绑的Core Foundation程序库中存在缓冲区溢出漏洞,可能允许攻击者获取root用户权限。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        http://docs.info.apple.com/article.html?artnum=301061

- 漏洞信息

15007
Apple Mac OS X World Writable Directories Privilege Escalation
Local Access Required Race Condition
Loss of Integrity
Exploit Unknown

- 漏洞描述

Mac OS X contains a flaw that may allow a malicious local user to create arbitrary files on the system. The issue is due to the world-writable default permissions on some directories. It is possible for a user to use a symlink style attack to manipulate arbitrary files, resulting in a loss of integrity.

- 时间线

2005-03-21 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Apple has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Apple Mac OS X Insecure Folder Permissions Privilege Escalation Vulnerability
Design Error 13220
No Yes
2005-03-22 12:00:00 2009-07-12 02:06:00
Discovery credited to Eric Hall of DarkArt Consulting Services.

- 受影响的程序版本

Apple Mac OS X Server 10.3.8
Apple Mac OS X Server 10.3.7
Apple Mac OS X Server 10.3.6
Apple Mac OS X Server 10.3.5
Apple Mac OS X Server 10.3.4
Apple Mac OS X Server 10.3.3
Apple Mac OS X Server 10.3.2
Apple Mac OS X Server 10.3.1
Apple Mac OS X Server 10.3
Apple Mac OS X 10.3.8
Apple Mac OS X 10.3.7
Apple Mac OS X 10.3.6
Apple Mac OS X 10.3.5
Apple Mac OS X 10.3.4
Apple Mac OS X 10.3.3
Apple Mac OS X 10.3.2
Apple Mac OS X 10.3.1
Apple Mac OS X 10.3

- 漏洞讨论

Mac OS X is prone to a privilege escalation issue because of insecure folder permissions. The insecure permissions are on folders that contain the installer 'receipt cache' and 'system-level ColorSync profiles'.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Apple has released an advisory (APPLE-SA-2005-03-21) and fixes to address this issue.


Apple Mac OS X Server 10.3.8

Apple Mac OS X 10.3.8

- 相关参考

     

     

    关于SCAP中文社区

    SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

    版权声明

    CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站