CVE-2005-0690
CVSS2.1
发布时间 :2005-03-07 00:00:00
修订时间 :2016-10-17 23:13:44
NMCOS    

[原文]Gene6 FTP Server does not properly restrict access to the control console, which allows local users to modify the server configuration and gain privileges, as demonstrated by defining a SITE command.


[CNNVD]Gene6 FTP Server本地权限提升漏洞(CNNVD-200503-054)

        Gene6 FTP Server是一款非常流行的Microsoft Windows平台的FTP Server。
        默认安装后,本地的非特权用户可以修改Gene6 FTP Server的设置,例如添加新的SITE命令。由于Gene6 FTP Server是以SYSTEM权限运行的,因此攻击者可以轻易的提升权限。

- CVSS (基础分值)

CVSS分值: 2.1 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:gene6:g6_ftp_server:3.1
cpe:/a:gene6:g6_ftp_server:3.3.1
cpe:/a:gene6:g6_ftp_server:3.0.1
cpe:/a:gene6:g6_ftp_server:3.4
cpe:/a:gene6:g6_ftp_server:3.0.2
cpe:/a:gene6:g6_ftp_server:3.3
cpe:/a:gene6:g6_ftp_server:3.0
cpe:/a:gene6:g6_ftp_server:2.0
cpe:/a:gene6:g6_ftp_server:3.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0690
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0690
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200503-054
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=111022496826680&w=2
(UNKNOWN)  BUGTRAQ  20050307 Gene6 FTP Server Local Privilege Escalation Vulnerability
http://marc.info/?l=bugtraq&m=111026585431080&w=2
(UNKNOWN)  BUGTRAQ  20050308 Re: Gene6 FTP Server Local Privilege Escalation Vulnerability
http://secway.org/Advisory/ad20050303.txt
(VENDOR_ADVISORY)  MISC  http://secway.org/Advisory/ad20050303.txt
http://www.securityfocus.com/bid/12739
(VENDOR_ADVISORY)  BID  12739

- 漏洞信息

Gene6 FTP Server本地权限提升漏洞
低危 配置错误
2005-03-07 00:00:00 2005-10-20 00:00:00
远程  
        Gene6 FTP Server是一款非常流行的Microsoft Windows平台的FTP Server。
        默认安装后,本地的非特权用户可以修改Gene6 FTP Server的设置,例如添加新的SITE命令。由于Gene6 FTP Server是以SYSTEM权限运行的,因此攻击者可以轻易的提升权限。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.g6ftpserver.com/

- 漏洞信息

14602
Gene6 FTP Server Local Privilege Escalation

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-03-07 Unknow
2005-03-07 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Gene6 FTP Server Remote Default Install Code Execution Vulnerability
Configuration Error 12739
Yes No
2005-03-07 12:00:00 2007-09-17 05:20:00
Sowhat <isowhat@gmail.com> is credited with the discovery of this issue.

- 受影响的程序版本

Gene6 G6 FTP Server 3.4
Gene6 G6 FTP Server 3.3.1
Gene6 G6 FTP Server 3.3
Gene6 G6 FTP Server 3.2
Gene6 G6 FTP Server 3.1
Gene6 G6 FTP Server 3.0.2
Gene6 G6 FTP Server 3.0.1
Gene6 G6 FTP Server 3.0
Gene6 G6 FTP Server 2.0
- Microsoft Windows 95
- Microsoft Windows 98
- Microsoft Windows NT 4.0

- 漏洞讨论

A remote code-execution vulnerability reportedly affects Gene6 FTP Server because of a configuration error that fails to secure critical functionality from default users.

An attacker that can authenticate to the affected FTP server can execute arbitrary code with SYSTEM privileges; this will facilitate privilege escalation.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

The vendor has released the following configuration details that will resolve this issue:

- Create a new administrator account
- In Administration / Properties, uncheck Options / Allow all access to localhost.

Do not forget to adjust the 'local machine' properties to use the new administration account.

NOTE: The installer for the next release of the affected application will include a fix for this issue.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站