CVE-2005-0670
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:46:58
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in phpCOIN 1.2.0 through 1.2.1b allows remote attackers to inject arbitrary web script or HTML via (1) the new parameter to mod.php, (2) the w parameter to mod.php, (3) the e parameter to login.php, (4) the o parameter to login.php, and possibly other scripts.


[CNNVD]PHPCoin多个远程输入验证漏洞(CNNVD-200505-488)

        phpCOIN 1.2.0至1.2.1b中存在跨站脚本攻击(XSS)漏洞,允许远程攻击者通过(1)mod.php的new参数,(2)mod.php的w参数,(3)login.php的e参数,(4)login.php和可能其他脚本的o参数来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:coinsoft_technologies:phpcoin:1.2.1
cpe:/a:coinsoft_technologies:phpcoin:1.2
cpe:/a:coinsoft_technologies:phpcoin:1.2.1b

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0670
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0670
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-488
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/14439
(PATCH)  SECUNIA  14439
http://forums.phpcoin.com/index.php?showtopic=4116
(PATCH)  CONFIRM  http://forums.phpcoin.com/index.php?showtopic=4116
http://xforce.iss.net/xforce/xfdb/19572
(UNKNOWN)  XF  phpcoin-xss(19572)
http://www.securityfocus.com/bid/12686
(UNKNOWN)  BID  12686
http://securitytracker.com/id?1013329
(UNKNOWN)  SECTRACK  1013329
http://lostmon.blogspot.com/2005/03/phpcoin-posible-sql-injection-comands.html
(UNKNOWN)  MISC  http://lostmon.blogspot.com/2005/03/phpcoin-posible-sql-injection-comands.html
http://forums.phpcoin.com/index.php?showtopic=4118
(UNKNOWN)  CONFIRM  http://forums.phpcoin.com/index.php?showtopic=4118
http://forums.phpcoin.com/index.php?showtopic=4101
(UNKNOWN)  CONFIRM  http://forums.phpcoin.com/index.php?showtopic=4101

- 漏洞信息

PHPCoin多个远程输入验证漏洞
中危 跨站脚本
2005-05-02 00:00:00 2006-03-29 00:00:00
远程  
        phpCOIN 1.2.0至1.2.1b中存在跨站脚本攻击(XSS)漏洞,允许远程攻击者通过(1)mod.php的new参数,(2)mod.php的w参数,(3)login.php的e参数,(4)login.php和可能其他脚本的o参数来注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

14280
phpCOIN mod.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

phpCOIN contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'mode' and 'w' variables upon submission to the 'mod.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-03-01 2005-02-27
2005-03-01 Unknow

- 解决方案

Upgrade to version 1.2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站