发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:46:58

[原文]Multiple SQL injection vulnerabilities in mod.php for phpCOIN 1.2.0 through 1.2.1b allow remote attackers to execute arbitrary SQL commands via the (1) the faq_id in the faq mod, (2) the id parameter in the pages mod, (3) the id parameter in the siteinfo module, (4) the topic_id parameter in the articles module, (5) the ord_id in the orders module, (6) the dom_id parameter in the domains module, or (7) the invd_id parameter in the invoices module.


        phpCOIN 1.2.0至1.2.1b的mod.php存在多个SQL注入漏洞,远程攻击者可以通过(1)faq模块中的faq_id参数,(2)pages模块中的id参数,(3)siteinfo模块中的id参数,(4)articles模块中的topic_id参数,(5)orders模块中的ord_id参数,(6)domains模块中的dom_id参数,或(7)invoices模块中的invd_id参数,来执行任意SQL命令。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  XF  phpcoin-id-sql-injection(19571)
(UNKNOWN)  BID  12686

- 漏洞信息

高危 SQL注入
2005-05-02 00:00:00 2006-03-29 00:00:00
        phpCOIN 1.2.0至1.2.1b的mod.php存在多个SQL注入漏洞,远程攻击者可以通过(1)faq模块中的faq_id参数,(2)pages模块中的id参数,(3)siteinfo模块中的id参数,(4)articles模块中的topic_id参数,(5)orders模块中的ord_id参数,(6)domains模块中的dom_id参数,或(7)invoices模块中的invd_id参数,来执行任意SQL命令。

- 公告与补丁


- 漏洞信息

phpCOIN Faq Module faq_id Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

phpCOIN contains a flaw that will allow an attacker to inject arbitrary SQL code. The problem is that the 'faq_id' variable in the Faq module is not verified properly and will allow an attacker to inject or manipulate SQL queries.

- 时间线

2005-03-01 2005-02-27
2005-03-01 Unknow

- 解决方案

Upgrade to version 1.2.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

phpCOIN Multiple Remote Input Validation Vulnerabilities
Input Validation Error 12686
Yes No
2005-03-01 12:00:00 2010-02-24 03:52:00
Lostmon <> is credited with the discovery of this issue.

- 受影响的程序版本

phpCOIN phpCOIN 1.2.1 b
phpCOIN phpCOIN 1.2.1
phpCOIN phpCOIN 1.2

- 漏洞讨论

Multiple remote input-validation vulnerabilities affect phpCOIN because the application fails to properly sanitize user-supplied input before using it to carry out critical functionality.

An attacker may leverage these issues to manipulate and view arbitrary database contents (by exploiting various SQL-injection issues) and to run arbitrary script code in the browser of an unsuspecting user (by exploiting multiple cross-site scripting vulnerabilities).

- 漏洞利用

No exploit is required to leverage any of these issues. The following proofs of concept have been provided:

SQL injection:;mode=show&amp;faq_id=2%20or%201=1;mode=view&amp;id=25%20or%201=1;id=4%20or%201=1;mode=show&amp;faq_id=-1+UNION+SELECT+1,2,3,4,5,6,7,concat(admin_user_name,0x3a,admin_user_pword),9,10,11,12,13,14,15,16+from+phpcoin_admins--

Cross-site scripting:;mode=new

- 解决方案

Currently we are not aware of any vendor-supplied patches. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 相关参考