发布时间 :2005-03-02 00:00:00
修订时间 :2008-09-05 16:46:53

[原文]Multiple vulnerabilities in xli before 1.17 may allow remote attackers to execute arbitrary code via "buffer management errors" from certain image properties, some of which may be related to integer overflows in PPM files.

[CNNVD]XLI 未明整数溢出漏洞(CNNVD-200503-037)

        xli 1.17之前版本中存在多个漏洞,远程攻击者可能会通过源自特定图像属性的"缓冲区管理错误"执行任意代码,部分图像属性可能与PPM文件中的整数溢出有关。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:suse:suse_linux:4.3SuSE SuSE Linux 4.3
cpe:/o:suse:suse_linux:6.4SuSE SuSE Linux 6.4
cpe:/o:suse:suse_linux:1.0SuSE SuSE Linux 1.0
cpe:/o:suse:suse_linux:4.4SuSE SuSE Linux 4.4
cpe:/o:suse:suse_linux:5.3SuSE SuSE Linux 5.3
cpe:/o:suse:suse_linux:4.2SuSE SuSE Linux 4.2
cpe:/o:suse:suse_linux:4.4.1SuSE SuSE Linux 4.4.1
cpe:/o:suse:suse_linux:9.0SuSE SuSE Linux 9.0
cpe:/o:suse:suse_linux:7.0SuSE SuSE Linux 7.0
cpe:/o:suse:suse_linux:8.2SuSE SuSE Linux 8.2
cpe:/o:suse:suse_linux:6.0SuSE SuSE Linux 6.0
cpe:/o:suse:suse_linux:5.1SuSE SuSE Linux 5.1
cpe:/o:suse:suse_linux:7.3SuSE SuSE Linux 7.3
cpe:/o:suse:suse_linux:6.3SuSE SuSE Linux 6.3
cpe:/o:suse:suse_linux:7.1SuSE SuSE Linux 7.1
cpe:/o:suse:suse_linux:8.1SuSE SuSE Linux 8.1
cpe:/o:suse:suse_linux:6.4:alphaSuSE SuSE Linux 6.4 alpha
cpe:/o:suse:suse_linux:9.2SuSE SuSE Linux 9.2
cpe:/o:suse:suse_linux:7.0:alphaSuSE SuSE Linux 7.0 alpha
cpe:/o:suse:suse_linux:6.1:alphaSuSE SuSE Linux 6.1 alpha
cpe:/o:suse:suse_linux:9.1SuSE SuSE Linux 9.1
cpe:/o:suse:suse_linux:5.0SuSE SuSE Linux 5.0
cpe:/o:suse:suse_linux:7.2SuSE SuSE Linux 7.2
cpe:/o:suse:suse_linux:8.0SuSE SuSE Linux 8.0
cpe:/o:suse:suse_linux:9.3SuSE SuSE Linux 9.3
cpe:/o:suse:suse_linux:6.1SuSE SuSE Linux 6.1
cpe:/o:suse:suse_linux:6.2SuSE SuSE Linux 6.2
cpe:/o:suse:suse_linux:7.1:alphaSuSE SuSE Linux 7.1 alpha
cpe:/o:suse:suse_linux:6.3:alphaSuSE SuSE Linux 6.3 alpha
cpe:/o:suse:suse_linux:5.2SuSE SuSE Linux 5.2

- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

XLI 未明整数溢出漏洞
高危 缓冲区溢出
2005-03-02 00:00:00 2005-10-20 00:00:00
        xli 1.17之前版本中存在多个漏洞,远程攻击者可能会通过源自特定图像属性的"缓冲区管理错误"执行任意代码,部分图像属性可能与PPM文件中的整数溢出有关。

- 公告与补丁

        xli xli 1.17
        Debian xli_1.17.0-11woody1_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_arm.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_hppa.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_i386.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_ia64.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_mips.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_mipsel.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_powerpc.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_s390.deb
        Debian GNU/Linux 3.0 alias woody
        Debian xli_1.17.0-11woody1_sparc.deb
        Debian GNU/Linux 3.0 alias woody
        Mandriva xli-1.17.0-4.1.C21mdk.i586.rpm
        Mandrake Corporate Server 2.1
        Mandriva xli-1.17.0-4.1.C21mdk.x86_64.rpm
        Mandrake Corporate Server 2.1/x86_64
        Mandriva xli-1.17.0-8.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        Mandriva xli-1.17.0-8.1.101mdk.x86_64.rpm
        Mandrake Linux 10.1/x86_64
        Mandriva xli-1.17.0-8.1.102mdk.i586.rpm
        Mandrake Linux 10.2
        Mandriva xli-1.17.0-8.1.102mdk.x86_64.rpm
        Mandrake Linux 10.2/x86_64
        Mandriva xli-1.17.0-8.2.C30mdk.i586.rpm
        Mandrake Corporate Server 3.0
        Mandriva xli-1.17.0-8.2.C30mdk.x86_64.rpm
        Mandrake Corporate Server 3.0/x86_64

- 漏洞信息 (F36737)

dsa-695.txt (PacketStormID:F36737)
2005-03-22 00:00:00

Debian Security Advisory 695-1 - Several vulnerabilities have been discovered in xli, an image viewer for X11.

Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 695-1                                        Martin Schulze
March 21st, 2005              
- --------------------------------------------------------------------------

Package        : xli
Vulnerability  : buffer overflow, input sanitising, integer overflow
Problem-Type   : local (remote)
Debian-specific: no
CVE IDs        : CAN-2001-0775 CAN-2005-0638 CAN-2005-0639
BugTraq ID     : 3006
Debian Bug     : 298039

Several vulnerabilities have been discovered in xli, an image viewer
for X11.  The Common Vulnerabilities and Exposures project identifies
the following problems:


    A buffer overflow in the decoder for FACES format images could be
    exploited by an attacker to execute arbitrary code.  This problem
    has been fixed in xloadimage in DSA 069 already.


    Tavis Ormandy of the Gentoo Linux Security Audit Team has reported
    a flaw in the handling of compressed images, where shell
    meta-characters are not adequately escaped.


    Insufficient validation of image properties in have been
    discovered which could potentially result in buffer management

For the stable distribution (woody) these problems have been fixed in
version 1.17.0-11woody1.

For the unstable distribution (sid) these problems have been fixed in
version 1.17.0-18.

We recommend that you upgrade your xli package.

Upgrade Instructions
- --------------------

wget url
        will fetch the file for you
dpkg -i file.deb
        will install the referenced file.

If you are using the apt-get package manager, use the line for
sources.list as given below:

apt-get update
        will update the internal database
apt-get upgrade
        will install corrected packages

You may use an automated update by adding the resources from the
footer to the proper configuration.

Debian GNU/Linux 3.0 alias woody
- --------------------------------

  Source archives:
      Size/MD5 checksum:      620 6d2f4c8e2485b6bd0ef76de7bacd0160
      Size/MD5 checksum:    17569 5ce0a794f50dd69cc0faedd0d49f6f3a
      Size/MD5 checksum:   200070 504f916c9a7d062c8f856f1625634ba8

  Alpha architecture:
      Size/MD5 checksum:   173094 97c6717b0574e1fecd8e52da876a5974

  ARM architecture:
      Size/MD5 checksum:   143198 6f509ec11267fd9df59b87922bdb54b4

  Intel IA-32 architecture:
      Size/MD5 checksum:   137082 0bb37ade30c9f15a1d01f3abad8d25d8

  Intel IA-64 architecture:
      Size/MD5 checksum:   210170 bf8a0a75471db3a865c7bc86c8d06a11

  HP Precision architecture:
      Size/MD5 checksum:   158322 3132e418ecf89e97a861fcbb95f7e84f

  Motorola 680x0 architecture:
      Size/MD5 checksum:   128284 8e3a7559a5637cd2c0ec51b95d1b27c4

  Big endian MIPS architecture:
      Size/MD5 checksum:   149080 3d8fb60a87739c312d5763cfb24ad73d

  Little endian MIPS architecture:
      Size/MD5 checksum:   149736 dbca603f4bd2fca9a34a5ab7823708f1

  PowerPC architecture:
      Size/MD5 checksum:   143336 4c809fe5d90fc60e7e02ce2eaa949f85

  IBM S/390 architecture:
      Size/MD5 checksum:   144662 f3f4c65a1ddaaa0bf6f5f8eef5302e4a

  Sun Sparc architecture:
      Size/MD5 checksum:   145954 821e695fb31681b653aec3922a3c76c5

  These files will probably be moved into the stable distribution on
  its next update.

- ---------------------------------------------------------------------------------
For apt-get: deb stable/updates main
For dpkg-ftp: dists/stable/updates/main
Mailing list:
Package info: `apt-cache show <pkg>' and<pkg>

Version: GnuPG v1.4.0 (GNU/Linux)



- 漏洞信息

xli Unspecified Image Properties Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown

- 漏洞描述

xli contains a flaw related to the validation of image properties that may allow a remote attacker to execute arbitrary code. No further details have been provided.

- 时间线

2005-03-02 2001-01-01
2001-01-01 Unknow

- 解决方案

Upgrade to version 1.17.0-r1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

XLI Unspecified Remote Buffer Mismanagement Vulnerability
Boundary Condition Error 12713
Yes No
2005-03-02 12:00:00 2009-07-12 10:56:00
The individual or individuals responsible for the discovery of this issue are currently unknown; the vendor disclosed this issue.

- 受影响的程序版本

xli xli 1.17
+ Debian Linux 3.1 sparc
+ Debian Linux 3.1 s/390
+ Debian Linux 3.1 ppc
+ Debian Linux 3.1 mipsel
+ Debian Linux 3.1 mips
+ Debian Linux 3.1 m68k
+ Debian Linux 3.1 ia-64
+ Debian Linux 3.1 ia-32
+ Debian Linux 3.1 hppa
+ Debian Linux 3.1 arm
+ Debian Linux 3.1 amd64
+ Debian Linux 3.1 alpha
+ Debian Linux 3.1
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Gentoo Linux
+ MandrakeSoft Corporate Server 3.0 x86_64
+ MandrakeSoft Corporate Server 3.0
+ MandrakeSoft Corporate Server 2.1 x86_64
+ MandrakeSoft Corporate Server 2.1
+ Mandriva Linux Mandrake 10.2 x86_64
+ Mandriva Linux Mandrake 10.2
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
+ Mandriva Linux Mandrake 10.0 AMD64
+ Mandriva Linux Mandrake 10.0
- Mandriva Linux Mandrake 8.0
xli xli 1.16
- MandrakeSoft Corporate Server 1.0.1
- Mandriva Linux Mandrake 7.2
- Mandriva Linux Mandrake 7.1
+ S.u.S.E. Linux 7.2
+ S.u.S.E. Linux 7.1
+ S.u.S.E. Linux 7.0
+ S.u.S.E. Linux 6.4
+ S.u.S.E. Linux 6.3
xli xli 1.15
xli xli 1.14
S.u.S.E. Linux Personal 9.3
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
S.u.S.E. Linux Personal 9.1 x86_64
S.u.S.E. Linux Personal 9.1
S.u.S.E. Linux Personal 9.0 x86_64
S.u.S.E. Linux Personal 9.0
S.u.S.E. Linux Personal 8.2
S.u.S.E. Linux 8.1
S.u.S.E. Linux 8.0 i386
S.u.S.E. Linux 8.0
S.u.S.E. Linux 7.3 sparc
S.u.S.E. Linux 7.3 ppc
S.u.S.E. Linux 7.3 i386
S.u.S.E. Linux 7.3
S.u.S.E. Linux 7.2 i386
S.u.S.E. Linux 7.2
S.u.S.E. Linux 7.1 x86
S.u.S.E. Linux 7.1 sparc
S.u.S.E. Linux 7.1 ppc
S.u.S.E. Linux 7.1 alpha
S.u.S.E. Linux 7.1
S.u.S.E. Linux 7.0 sparc
S.u.S.E. Linux 7.0 ppc
S.u.S.E. Linux 7.0 i386
S.u.S.E. Linux 7.0 alpha
S.u.S.E. Linux 7.0
S.u.S.E. Linux 6.4 ppc
S.u.S.E. Linux 6.4 i386
S.u.S.E. Linux 6.4 alpha
S.u.S.E. Linux 6.4
S.u.S.E. Linux 6.3 ppc
S.u.S.E. Linux 6.3 alpha
S.u.S.E. Linux 6.3
S.u.S.E. Linux 6.2
S.u.S.E. Linux 6.1 alpha
S.u.S.E. Linux 6.1
S.u.S.E. Linux 6.0
S.u.S.E. Linux 5.3
S.u.S.E. Linux 5.2
S.u.S.E. Linux 5.1
S.u.S.E. Linux 5.0
S.u.S.E. Linux 4.4.1
S.u.S.E. Linux 4.4
S.u.S.E. Linux 4.3
S.u.S.E. Linux 4.2
S.u.S.E. Linux 4.0
S.u.S.E. Linux 3.0
S.u.S.E. Linux 2.0
S.u.S.E. Linux 1.0
ALT Linux ALT Linux Junior 2.3
ALT Linux ALT Linux Compact 2.3

- 漏洞讨论

An unspecified remote buffer mismanagement vulnerability affects xli. This issue is due to a failure of the application to securely manage internal buffers when processing user-supplied input.

An attacker may leverage this issue to execute arbitrary code with the privileges of the affected application, facilitating privilege escalation or unauthorized access.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: &lt;;.

- 解决方案

ALT Linux has released updates dealing with this and other issues. Please see the reference section for more information.

Gentoo linux has released an advisory (GLSA 200503-05) dealing with this and other issues. Gentoo advises that all xli users should upgrade to the latest version by executing the following commands with superuser privileges:

emerge --sync
emerge --ask --oneshot --verbose ">=media-gfx/xli-1.17.0-r1"

For more information please see the referenced Gentoo linux advisory.

Debian has made advisory DSA 695-1 available along with fixes dealing with this issue. For more information, please see the referenced advisory.

Mandriva has released advisory MDKSA-2005:076 to address this issue. Please see the attached advisory for details on obtaining and applying fixes.

SuSE has released advisory SUSE-SR:2005:012 and fixes for this issue. Fixes can be obtained through the SuSE FTP server or by using the YaST Online Update.

xli xli 1.17

- 相关参考