CVE-2005-0629
CVSS4.3
发布时间 :2005-03-01 00:00:00
修订时间 :2016-10-17 23:13:16
NMCOS    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in profile.php in 427BB 2.2 allow remote attackers to inject arbitrary web script or HTML via the (1) user or (2) Avatar parameters.


[CNNVD]427BB 'profile.php' 跨站脚本攻击漏洞(CNNVD-200503-004)

        427BB 2.2的profile.php中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过(1) user或(2) Avatar参数注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:427bb:fourtwosevenbb:2.1.2
cpe:/a:427bb:fourtwosevenbb:2.2.1
cpe:/a:427bb:fourtwosevenbb:2.1.1
cpe:/a:427bb:fourtwosevenbb:2.0
cpe:/a:427bb:fourtwosevenbb:2.0.1
cpe:/a:427bb:fourtwosevenbb:2.1
cpe:/a:427bb:fourtwosevenbb:2.1.3
cpe:/a:427bb:fourtwosevenbb:2.2

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0629
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0629
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200503-004
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110970474726113&w=2
(UNKNOWN)  BUGTRAQ  20050301 427BB profile.php XSS vulnerability.
http://marc.info/?l=bugtraq&m=110970911514167&w=2
(UNKNOWN)  BUGTRAQ  20050301 427BB profile.php XSS vulnerability.
http://securitytracker.com/id?1013337
(VENDOR_ADVISORY)  SECTRACK  1013337
http://www.securityfocus.com/bid/12693
(VENDOR_ADVISORY)  BID  12693
http://xforce.iss.net/xforce/xfdb/19546
(VENDOR_ADVISORY)  XF  427bb-profile-xss(19546)

- 漏洞信息

427BB 'profile.php' 跨站脚本攻击漏洞
中危 跨站脚本
2005-03-01 00:00:00 2005-10-20 00:00:00
远程  
        427BB 2.2的profile.php中存在多个跨站脚本攻击(XSS)漏洞,远程攻击者可以通过(1) user或(2) Avatar参数注入任意Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

14302
427BB profile.php Avatar Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-03-01 Unknow
2005-03-01 Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

427BB Multiple Remote HTML Injection Vulnerabilities
Input Validation Error 12693
Yes No
2005-03-01 12:00:00 2009-07-12 10:56:00
Discovery of this vulnerability is credited to HRG - Hackerlounge Research Group.

- 受影响的程序版本

427BB fourtwosevenbb 2.2.1
427BB fourtwosevenbb 2.2
427BB fourtwosevenbb 2.1.3
427BB fourtwosevenbb 2.1.2
427BB fourtwosevenbb 2.1.1
427BB fourtwosevenbb 2.1
427BB fourtwosevenbb 2.0.1
427BB fourtwosevenbb 2.0

- 漏洞讨论

427BB is reportedly affected by multiple remote HTML injection vulnerabilities. These issues occur because the application fails to properly sanitize user-supplied input before using it in dynamically generated content.

The attacker-supplied HTML and script code would be able to access properties of the site, potentially allowing for theft of cookie-based authentication credentials. An attacker could also exploit this issue to control how the site is rendered to the user; other attacks are also possible.

These issues are reported to affect all versions of 427BB.

- 漏洞利用

No exploit is required.

The following proof of concept is available:
http://www.example.com/profile.php?user=%3Ciframe%20src=http://www.attacker.com%20height=1%20width=1%3E%3C/iframe%3E

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站