[原文]Cross-site scripting (XSS) vulnerability in settings.inc.php for CubeCart 2.0.0 through 2.0.5, as used in multiple PHP files, allows remote attackers to inject arbitrary HTML or web script via the (1) cat_id, (2) PHPSESSID, (3) view_doc, (4) product, (5) session, (6) catname, (7) search, or (8) page parameters.
CubeCart contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'cat_id', 'PHPSESSID', 'view_doc', 'product', 'session', 'catname', 'search' and 'page' variables upon
submission to all scripts that include the 'settings.inc.php' file. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.
Upgrade to version 2.0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.