CVE-2005-0606
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:46:47
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in settings.inc.php for CubeCart 2.0.0 through 2.0.5, as used in multiple PHP files, allows remote attackers to inject arbitrary HTML or web script via the (1) cat_id, (2) PHPSESSID, (3) view_doc, (4) product, (5) session, (6) catname, (7) search, or (8) page parameters.


[CNNVD]CubeCart多个跨站脚本攻击漏洞(CNNVD-200505-234)

        CubeCart 2.0.0至2.0.5的settings.inc.php当在多个PHP文件中使用时,其包含的跨站脚本攻击(XSS)漏洞允许远程攻击者通过(1)cat_id,(2)PHPSESSID,(3)view_doc,(4)product,(5)session,(6)catname,(7)search或(8)page参数来注入任意HTML或Web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:devellion:cubecart:2.0.5
cpe:/a:devellion:cubecart:2.0.2
cpe:/a:devellion:cubecart:2.0.1
cpe:/a:devellion:cubecart:2.0.3
cpe:/a:devellion:cubecart:2.0.0

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0606
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0606
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-234
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/12658
(PATCH)  BID  12658
http://www.cubecart.com/site/forums/index.php?showtopic=6032
(PATCH)  CONFIRM  http://www.cubecart.com/site/forums/index.php?showtopic=6032
http://xforce.iss.net/xforce/xfdb/20637
(UNKNOWN)  XF  cubecart-multiple-xss(20637)
http://securitytracker.com/id?1013304
(UNKNOWN)  SECTRACK  1013304
http://secunia.com/advisories/14416
(UNKNOWN)  SECUNIA  14416
http://lostmon.blogspot.com/2005/02/cubecart-20x-multiple-variable-xss.html
(UNKNOWN)  MISC  http://lostmon.blogspot.com/2005/02/cubecart-20x-multiple-variable-xss.html

- 漏洞信息

CubeCart多个跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        CubeCart 2.0.0至2.0.5的settings.inc.php当在多个PHP文件中使用时,其包含的跨站脚本攻击(XSS)漏洞允许远程攻击者通过(1)cat_id,(2)PHPSESSID,(3)view_doc,(4)product,(5)session,(6)catname,(7)search或(8)page参数来注入任意HTML或Web脚本。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.cubecart.com/site/downloads

- 漏洞信息

13810
CubeCart settings.inc.php Multiple Script XSS
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

CubeCart contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the 'cat_id', 'PHPSESSID', 'view_doc', 'product', 'session', 'catname', 'search' and 'page' variables upon submission to all scripts that include the 'settings.inc.php' file. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-02-25 2005-02-15
2005-02-25 2005-02-21

- 解决方案

Upgrade to version 2.0.6 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站