CVE-2005-0567
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:12:43
NMCO    

[原文]Multiple PHP remote file inclusion vulnerabilities in phpMyAdmin 2.6.1 allow remote attackers to execute arbitrary PHP code by modifying the (1) theme parameter to phpmyadmin.css.php or (2) cfg[Server][extension] parameter to database_interface.lib.php to reference a URL on a remote web server that contains the code.


[CNNVD]PHPMyAdmin多个本地文件包含漏洞(CNNVD-200505-085)

        phpMyAdmin 2.6.1中存在多个PHP远程文件包含漏洞,允许远程攻击者通过修改(1)phpmyadmin.css.php的theme参数或者(2)database_interface.lib.php的cfg[Server][extension]参数以引用包含代码的远程Web服务器的URL来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0567
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0567
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-085
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110929725801154&w=2
(UNKNOWN)  BUGTRAQ  20050224 [SECURITYREASON.COM] phpMyAdmin 2.6.1 Remote file inclusion and XSS cXIb8O3.4
http://sourceforge.net/tracker/index.php?func=detail&aid=1149381&group_id=23067&atid=377408
(PATCH)  CONFIRM  http://sourceforge.net/tracker/index.php?func=detail&aid=1149381&group_id=23067&atid=377408
http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2005-1
(VENDOR_ADVISORY)  CONFIRM  http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2005-1
http://www.securityfocus.com/bid/12645
(PATCH)  BID  12645
http://xforce.iss.net/xforce/xfdb/19465
(PATCH)  XF  phpmyadmin-file-include(19465)

- 漏洞信息

PHPMyAdmin多个本地文件包含漏洞
高危 输入验证
2005-05-02 00:00:00 2006-09-28 00:00:00
远程  
        phpMyAdmin 2.6.1中存在多个PHP远程文件包含漏洞,允许远程攻击者通过修改(1)phpmyadmin.css.php的theme参数或者(2)database_interface.lib.php的cfg[Server][extension]参数以引用包含代码的远程Web服务器的URL来执行任意PHP代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.1-pl1.tar.gz?download

- 漏洞信息

14094
phpMyAdmin phpmyadmin.css.php Remote File Inclusion
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpMyAdmin contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to phpmyadmin.css.php not properly sanitizing user input supplied to the GLOBALS[cfg][ThemePath] variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2005-02-24 Unknow
2005-02-24 Unknow

- 解决方案

Upgrade to version 2.6.1-pl1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站