CVE-2005-0563
CVSS4.3
发布时间 :2005-06-14 00:00:00
修订时间 :2008-09-05 16:46:39
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in Microsoft Outlook Web Access (OWA) component in Exchange Server 5.5 allows remote attackers to inject arbitrary web script or HTML via an email message with an encoded javascript: URL ("jav&#X41sc
ript:") in an IMG tag.


[CNNVD]Microsoft Outlook Web Access跨站脚本执行漏洞(CNNVD-200506-122)

        Microsoft Exchange Server是一款企业级的邮件服务程序。
        Microsoft Outlook Web Access在处理URL时存在问题,远程攻击者可以利用这个漏洞进行跨站脚本执行攻击。
        攻击者利用这个漏洞通过发送恶意邮件等手段诱使用户访问某个链接,可以在用户机器上执行恶意脚本代码,导致敏感信息泄露。
        <*链接:http://www.microsoft.com/technet/security/Bulletin/MS05-029.mspx
        *>
        

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0563
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0563
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200506-122
(官方数据源) CNNVD

- 其它链接及资源

http://www.microsoft.com/technet/security/bulletin/ms05-029.mspx
(VENDOR_ADVISORY)  MS  MS05-029
http://www.idefense.com/application/poi/display?id=261&type=vulnerabilities
(VENDOR_ADVISORY)  IDEFENSE  20050614 Microsoft Outlook Web Access Cross-Site Scripting Vulnerability
http://secunia.com/advisories/15697
(UNKNOWN)  SECUNIA  15697

- 漏洞信息

Microsoft Outlook Web Access跨站脚本执行漏洞
中危 跨站脚本
2005-06-14 00:00:00 2006-04-07 00:00:00
远程  
        Microsoft Exchange Server是一款企业级的邮件服务程序。
        Microsoft Outlook Web Access在处理URL时存在问题,远程攻击者可以利用这个漏洞进行跨站脚本执行攻击。
        攻击者利用这个漏洞通过发送恶意邮件等手段诱使用户访问某个链接,可以在用户机器上执行恶意脚本代码,导致敏感信息泄露。
        <*链接:http://www.microsoft.com/technet/security/Bulletin/MS05-029.mspx
        *>
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        http://www.microsoft.com/technet/security/Bulletin/MS05-029.mspx

- 漏洞信息

17307
Microsoft Exchange Outlook Web Access HTML Email XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

Exchange Outlook Web Access contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate the IMG SRC tag contained in HTML emails. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-06-14 2005-04-08
2005-06-14 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Microsoft has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Microsoft Exchange Server Outlook Web Access HTML Injection Vulnerability
Input Validation Error 13952
Yes No
2005-06-14 12:00:00 2009-07-12 02:56:00
Gael Delalleau is credited with discovery.

- 受影响的程序版本

Microsoft Outlook Web Access for Exchange Server 5.5
+ Microsoft Exchange Server 5.5 SP4
+ Microsoft Exchange Server 5.5 SP3
+ Microsoft Exchange Server 5.5 SP2
+ Microsoft Exchange Server 5.5 SP1
+ Microsoft Exchange Server 5.5
Microsoft Exchange Server 5.5 SP4
- Microsoft BackOffice 4.5
- Microsoft BackOffice 4.5
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP2
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional SP1
- Microsoft Windows 2000 Professional
- Microsoft Windows 2000 Professional
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP6a
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP6
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP5
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP4
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP3
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP2
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0 SP1
- Microsoft Windows NT 4.0
- Microsoft Windows NT 4.0
Microsoft Outlook Web Access for Exchange Server 2003
+ Microsoft Exchange Server 2003 SP1
+ Microsoft Exchange Server 2003
Microsoft Outlook Web Access for Exchange 2000 Server
+ Microsoft Exchange Server 2000 SP3
+ Microsoft Exchange Server 2000 SP2
+ Microsoft Exchange Server 2000 SP1
+ Microsoft Exchange Server 2000
Microsoft Exchange Server 2003 SP1
Microsoft Exchange Server 2003
Microsoft Exchange Server 2000 SP3

- 不受影响的程序版本

Microsoft Outlook Web Access for Exchange Server 2003
+ Microsoft Exchange Server 2003 SP1
+ Microsoft Exchange Server 2003
Microsoft Outlook Web Access for Exchange 2000 Server
+ Microsoft Exchange Server 2000 SP3
+ Microsoft Exchange Server 2000 SP2
+ Microsoft Exchange Server 2000 SP1
+ Microsoft Exchange Server 2000
Microsoft Exchange Server 2003 SP1
Microsoft Exchange Server 2003
Microsoft Exchange Server 2000 SP3

- 漏洞讨论

Outlook Web Access is prone to an HTML injection vulnerability. This issue is due to a failure in the application to properly sanitize user-supplied input.

An attacker may leverage this issue to have arbitrary script code executed in the affected application of an unsuspecting user in the context of the affected user.

This issue is reported to affect Outlook Web Access for Exchange Server 5.5.

- 漏洞利用

No exploit required.

- 解决方案

Microsoft has released fixes to address supported versions of the software.


Microsoft Exchange Server 5.5 SP4

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站