发布时间 :2005-04-12 00:00:00
修订时间 :2008-09-10 15:36:10

[原文]GIF file validation error in MSN Messenger 6.2 allows remote attackers in a user's contact list to execute arbitrary code via a GIF image with an improper height and width.

[CNNVD]MSN Messenger畸形GIF文件处理远程溢出漏洞(MS05-022)(CNNVD-200504-026)

        MSN Messenger是微软发布的非常流行的即时通讯软件。MSN Messenger能够渲染并浏览GIF图形格式文件。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:4927MSN Messenger GIF Size Buffer Overflow

- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  XF  msn-messenger-gif-execute-code (19950)

- 漏洞信息

MSN Messenger畸形GIF文件处理远程溢出漏洞(MS05-022)
高危 边界条件错误
2005-04-12 00:00:00 2005-10-20 00:00:00
        MSN Messenger是微软发布的非常流行的即时通讯软件。MSN Messenger能够渲染并浏览GIF图形格式文件。

- 公告与补丁


- 漏洞信息

MSN Messenger Malformed GIF Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity Patch / RCS
Vendor Verified

- 漏洞描述

A remote code execution flaw exists in MSN Messenger. The program fails to validate GIF image height and width information. With a specially crafted request, an attacker can cause arbitrary code execution resulting in a loss of integrity.

- 时间线

2005-04-12 Unknow
Unknow Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, Microsoft has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

- 漏洞信息

Microsoft MSN Messenger GIF Image Processing Remote Buffer Overflow Vulnerability
Boundary Condition Error 13114
Yes No
2005-04-12 12:00:00 2009-01-23 02:32:00
Discovery is credited to Hongzhen Zhou.

- 受影响的程序版本

Microsoft MSN Messenger Service 7.0 beta
Microsoft MSN Messenger Service 6.2
Microsoft MSN Messenger Service 7.0

- 不受影响的程序版本

Microsoft MSN Messenger Service 7.0

- 漏洞讨论

Microsoft MSN Messenger is prone to a remote buffer-overflow vulnerability when handling malformed Graphic Interchange Format (GIF) images. This may allow an attacker to gain unauthorized access to an affected computer by executing arbitrary code, reportedly resulting in system-level compromise. Specially crafted emoticons or display pictures are likely to be used in a client-to-client attack.

Other attack vectors may exist as well.

MSN Messenger 6.2 and MSN Messenger 7.0 beta are vulnerable.

- 漏洞利用

Currently we are not aware of any working exploits. If you feel we are in error or if you are aware of more recent information, please mail us at:

- 解决方案

Microsoft has released updates to address this vulnerability on supported platforms.

UPDATE (January 22, 2009): Microsoft has updated its security bulletin to advise users that an update for MSN Messenger 6.2 is available via the download links in MS07-054 or by logging into the MSN Messenger service to accept the update.

- 相关参考