CVE-2005-0543
CVSS4.3
发布时间 :2005-02-24 00:00:00
修订时间 :2016-11-04 16:22:03
NMCO    

[原文]Cross-site scripting (XSS) vulnerability in phpMyAdmin 2.6.1 allows remote attackers to inject arbitrary HTML and web script via (1) the strServer, cfg[BgcolorOne], or strServerChoice parameters in select_server.lib.php, (2) the bg_color or row_no parameters in display_tbl_links.lib.php, the left_font_family parameter in theme_left.css.php, or the right_font_family parameter in theme_right.css.php.


[CNNVD]PHPMyAdmin多个程序库和主题远程跨站脚本攻击漏洞(CNNVD-200502-092)

        phpMyAdmin 就是一种MySQL 数据库的管理工具。
        phpMyAdmin 2.6.1中的跨站脚本攻击漏洞,可让远程攻击者通过以下方式注入任意HTML和Web脚本:(1) select_server.lib.php中的strServer、cfg[BgcolorOne]或strServerChoice参数,(2) display_tbl_links.lib.php中的bg_color or row_no参数、theme_left.css.php中的left_font_family参数或theme_right.css.php中的right_font_family参数。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CWE (弱点类目)

CWE-79 [在Web页面生成时对输入的转义处理不恰当(跨站脚本)]

- CPE (受影响的平台与产品)

cpe:/a:phpmyadmin:phpmyadmin:2.6.0_pl3
cpe:/a:phpmyadmin:phpmyadmin:2.6.1_rc1
cpe:/a:phpmyadmin:phpmyadmin:2.6.0_pl2
cpe:/a:phpmyadmin:phpmyadmin:2.6.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0543
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0543
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200502-092
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110929725801154&w=2
(VENDOR_ADVISORY)  BUGTRAQ  20050224 [SECURITYREASON.COM] phpMyAdmin 2.6.1 Remote file inclusion and XSS cXIb8O3.4
http://www.gentoo.org/security/en/glsa/glsa-200503-07.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200503-07
http://www.securityfocus.com/bid/12644
(VENDOR_ADVISORY)  BID  12644
http://xforce.iss.net/xforce/xfdb/19462
(VENDOR_ADVISORY)  XF  phpmyadmin-multiple-php-xss(19462)

- 漏洞信息

PHPMyAdmin多个程序库和主题远程跨站脚本攻击漏洞
中危 跨站脚本
2005-02-24 00:00:00 2005-10-20 00:00:00
远程  
        phpMyAdmin 就是一种MySQL 数据库的管理工具。
        phpMyAdmin 2.6.1中的跨站脚本攻击漏洞,可让远程攻击者通过以下方式注入任意HTML和Web脚本:(1) select_server.lib.php中的strServer、cfg[BgcolorOne]或strServerChoice参数,(2) display_tbl_links.lib.php中的bg_color or row_no参数、theme_left.css.php中的left_font_family参数或theme_right.css.php中的right_font_family参数。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        phpMyAdmin phpMyAdmin 2.6 .0pl3
        phpMyAdmin phpMyAdmin 2.6.1-pl1
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.1-pl1.tar.gz?download
        phpMyAdmin phpMyAdmin 2.6 .0pl2
        phpMyAdmin phpMyAdmin 2.6.1-pl1
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.1-pl1.tar.gz?download
        phpMyAdmin phpMyAdmin 2.6.1 -rc1
        phpMyAdmin phpMyAdmin 2.6.1-pl1
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.1-pl1.tar.gz?download
        phpMyAdmin phpMyAdmin 2.6.1
        phpMyAdmin phpMyAdmin 2.6.1-pl1
        http://prdownloads.sourceforge.net/phpmyadmin/phpMyAdmin-2.6.1-pl1.tar.gz?download

- 漏洞信息

14096
phpMyAdmin select_server.lib.php Multiple Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

phpMyAdmin contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate multiple variables upon submission to the select_server.lib.php script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-02-24 Unknow
2005-02-24 Unknow

- 解决方案

Upgrade to version 2.6.1-pl1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站