CVE-2005-0514
CVSS4.3
发布时间 :2005-02-22 00:00:00
修订时间 :2008-09-05 16:46:31
NMCOS    

[原文]Cross-site scripting (XSS) vulnerability in Verity Ultraseek before 5.3.3 allows remote attackers to inject arbitrary HTML and web script via search parameters.


[CNNVD]Verity Ultraseek搜索请求跨站脚本攻击漏洞(CNNVD-200502-080)

        Ultraseek是纯粹的,可下载的特定为商业服务的搜索引擎 。
        Verity Ultraseek 5.3.3之前版本中的跨站脚本攻击(XSS)漏洞,可让远程攻击者通过搜索参数注入任意HTML和Web脚本。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0514
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0514
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200502-080
(官方数据源) CNNVD

- 其它链接及资源

http://www.kb.cert.org/vuls/id/716144
(VENDOR_ADVISORY)  CERT-VN  VU#716144
http://www.mikx.de/index.php?p=6
(VENDOR_ADVISORY)  MISC  http://www.mikx.de/index.php?p=6
http://secunia.com/advisories/14367
(VENDOR_ADVISORY)  SECUNIA  14367
http://lists.grok.org.uk/pipermail/full-disclosure/2004-December/030222.html
(VENDOR_ADVISORY)  FULLDISC  20041223 Cross-Site Scripting - an industry-wide problem

- 漏洞信息

Verity Ultraseek搜索请求跨站脚本攻击漏洞
中危 跨站脚本
2005-02-22 00:00:00 2005-10-20 00:00:00
远程  
        Ultraseek是纯粹的,可下载的特定为商业服务的搜索引擎 。
        Verity Ultraseek 5.3.3之前版本中的跨站脚本攻击(XSS)漏洞,可让远程攻击者通过搜索参数注入任意HTML和Web脚本。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Verity Inc. Ultraseek 5.2.1
        Verity Ultraseek 5.3.3
        http://downloadcenter.verity.com/dlc/download-ultraseek.do?product=Ultraseek+5.3.3
        Verity Inc. Ultraseek 5.2.2
        Verity Ultraseek 5.3.3
        http://downloadcenter.verity.com/dlc/download-ultraseek.do?product=Ultraseek+5.3.3
        Verity Inc. Ultraseek 5.3
        Verity Ultraseek 5.3.3
        http://downloadcenter.verity.com/dlc/download-ultraseek.do?product=Ultraseek+5.3.3
        Verity Inc. Ultraseek 5.3.1
        Verity Ultraseek 5.3.3
        http://downloadcenter.verity.com/dlc/download-ultraseek.do?product=Ultraseek+5.3.3
        Verity Inc. Ultraseek 5.3.2
        Verity Ultraseek 5.3.3
        http://downloadcenter.verity.com/dlc/download-ultraseek.do?product=Ultraseek+5.3.3

- 漏洞信息

14045
Verity Ultraseek Search Request XSS
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Ultraseek contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate user input upon submission to the search engine script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-02-21 Unknow
2005-02-21 Unknow

- 解决方案

Upgrade to version 5.3.3 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

- 漏洞信息

Verity Ultraseek Search Request Cross-Site Scripting Vulnerability
Input Validation Error 12617
Yes No
2005-02-22 12:00:00 2009-07-12 10:56:00
Michael Krax is credited with the discovery of this issue.

- 受影响的程序版本

Verity Inc. Ultraseek 5.3.2
Verity Inc. Ultraseek 5.3.1
Verity Inc. Ultraseek 5.3
Verity Inc. Ultraseek 5.2.2
Verity Inc. Ultraseek 5.2.1
Verity Inc. Ultraseek 5.3.3

- 不受影响的程序版本

Verity Inc. Ultraseek 5.3.3

- 漏洞讨论

A cross-site scripting vulnerability reportedly affects Verity Ultraseek. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamically generated Web content.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required to leverage this vulnerability.

- 解决方案

The vendor has released version 5.3.3 of the affected software that reportedly deals with this issue.


Verity Inc. Ultraseek 5.2.1

Verity Inc. Ultraseek 5.2.2

Verity Inc. Ultraseek 5.3

Verity Inc. Ultraseek 5.3.1

Verity Inc. Ultraseek 5.3.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站