CVE-2005-0513
CVSS7.5
发布时间 :2005-02-19 00:00:00
修订时间 :2016-10-17 23:12:17
NMCO    

[原文]PHP remote file inclusion vulnerability in mail_autocheck.php in the Email This Entry add-on for pMachine Pro 2.4, and possibly other versions including pMachine Free, allows remote attackers to execute arbitrary PHP code by directly requesting mail_autocheck.php and modifying the pm_path parameter to reference a URL on a remote web server that contains the code, a different vulnerability than CVE-2003-1086.


[CNNVD]Pmachine Pro Email This Entry Mail_autocheck.PHP远程文件包含漏洞(CNNVD-200502-070)

        pMachine 是一款CMS管理系统。
        pMachine Pro 2.4以及包含pMachine Free在内的其他可能版本的Email This Entry插件之mail_autocheck.php中的PHP远程文件包含漏洞,这可让远程攻击者通过直接请求mail_autocheck.php并将pm_path参数修改为引用包含PHP代码的远程Web服务器上的URL来执行任意PHP代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0513
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0513
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200502-070
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=full-disclosure&m=110883604531802&w=2
(UNKNOWN)  FULLDISC  20050219 pMachine Pro / pMachine Free Remote Code Execution
http://www.securityfocus.com/bid/12597
(VENDOR_ADVISORY)  BID  12597
http://www.securityfocus.com/bid/15473
(UNKNOWN)  BID  15473

- 漏洞信息

Pmachine Pro Email This Entry Mail_autocheck.PHP远程文件包含漏洞
高危 输入验证
2005-02-19 00:00:00 2006-09-28 00:00:00
远程  
        pMachine 是一款CMS管理系统。
        pMachine Pro 2.4以及包含pMachine Free在内的其他可能版本的Email This Entry插件之mail_autocheck.php中的PHP远程文件包含漏洞,这可让远程攻击者通过直接请求mail_autocheck.php并将pm_path参数修改为引用包含PHP代码的远程Web服务器上的URL来执行任意PHP代码。

- 公告与补丁

        暂无数据

- 漏洞信息

14028
pMachine mail_autocheck.php Arbitrary Code Execution
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

pMachine contains a flaw that may allow a remote attacker to execute arbitrary commands. The issue is due to mail_autocheck.php script not properly sanitizing user input supplied to the pm_path variable. This may allow an attacker to include a file from a remote host that contains arbitrary commands which will be executed by the vulnerable script.

- 时间线

2005-02-19 Unknow
2005-02-19 Unknow

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, pMachine has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站