CVE-2005-0503
CVSS4.6
发布时间 :2005-02-21 00:00:00
修订时间 :2008-09-10 15:36:04
NMCOPS    

[原文]uim before 0.4.5.1 trusts certain environment variables when libUIM is used in setuid or setgid applications, which allows local users to gain privileges.


[CNNVD]UIM LibUIM 环境变量特权升级漏洞(CNNVD-200502-075)

        UIM是支持多种语言的输入方法模块库。
        uim 0.4.5.1之前的版本,在libUIM用于setuid或setgid应用程序中时,信任某些环境变量,这可让本地用户获取特权。

- CVSS (基础分值)

CVSS分值: 4.6 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:mandrakesoft:mandrake_linux:10.1MandrakeSoft Mandrake Linux 10.1
cpe:/o:mandrakesoft:mandrake_linux:10.1::x86_64
cpe:/a:uim:uim:0.4.5

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0503
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0503
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200502-075
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/12604
(VENDOR_ADVISORY)  BID  12604
http://secunia.com/advisories/13981
(VENDOR_ADVISORY)  SECUNIA  13981
http://lists.freedesktop.org/archives/uim/2005-February/000996.html
(VENDOR_ADVISORY)  MLIST  [uim] 20050220 uim 0.4.5.1 released
http://www.mandriva.com/security/advisories?name=MDKSA-2005:046
(UNKNOWN)  MANDRAKE  MDKSA-2005:046

- 漏洞信息

UIM LibUIM 环境变量特权升级漏洞
中危 设计错误
2005-02-21 00:00:00 2007-07-24 00:00:00
本地  
        UIM是支持多种语言的输入方法模块库。
        uim 0.4.5.1之前的版本,在libUIM用于setuid或setgid应用程序中时,信任某些环境变量,这可让本地用户获取特权。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Uim Uim 0.4.5
        Uim uim-0.4.5.1.tar.gz
        http://uim.freedesktop.org/releases/uim-0.4.5.1.tar.gz
        MandrakeSoft Linux Mandrake 10.1
        Mandrake libuim0-0.4.5.1-0.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake libuim0-devel-0.4.5.1-0.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake uim-0.4.5.1-0.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake uim-applet-0.4.5.1-0.1.101mdk.i586.rpm
        Mandrake Linux 10.1
        http://www.mandrakesecure.net/en/ftp.php
        MandrakeSoft Linux Mandrake 10.1 x86_64
        Mandrake lib64uim0-0.4.5.1-0.1.101mdk.x86_64.rpm
        Mandrake Linux 10.1/x86_64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake lib64uim0-devel-0.4.5.1-0.1.101mdk.x86_64.rpm
        Mandrake Linux 10.1/x86_64
        http://www.mandrakesecure.net/en/ftp.php
        Mandrake libuim0-0.4.5.1-0.1.101mdk.i586.rpm
        Mandrake Linux 10.1/x86_64
        http://www.mandrakesecure.net/en/ftp.php

- 漏洞信息 (F36371)

Gentoo Linux Security Advisory 200502-31 (PacketStormID:F36371)
2005-03-01 00:00:00
Gentoo  security.gentoo.org
advisory,arbitrary
linux,gentoo
CVE-2005-0503
[点击下载]

Gentoo Linux Security Advisory GLSA 200502-31 - Takumi Asaki discovered that uim insufficiently checks environment variables. setuid/setgid applications linked against libuim could end up executing arbitrary code. Versions below 0.4.5.1 are affected.

--nextPart5396885.Yyr1AgGVqz
Content-Type: text/plain;
  charset="us-ascii"
Content-Transfer-Encoding: 7bit
Content-Disposition: inline

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200502-31
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: uim: Privilege escalation vulnerability
      Date: February 28, 2005
      Bugs: #82678
        ID: 200502-31

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Under certain conditions, applications linked against uim suffer from a
privilege escalation vulnerability.

Background
==========

uim is a simple, secure and flexible input method library.

Affected packages
=================

    -------------------------------------------------------------------
     Package       /  Vulnerable  /                         Unaffected
    -------------------------------------------------------------------
  1  app-i18n/uim      < 0.4.5.1                            >= 0.4.5.1

Description
===========

Takumi Asaki discovered that uim insufficiently checks environment
variables. setuid/setgid applications linked against libuim could end
up executing arbitrary code. This vulnerability only affects
immodule-enabled Qt (if you build Qt 3.3.2 or later versions with
USE="immqt" or USE="immqt-bc").

Impact
======

A malicious local user could exploit this vulnerability to execute
arbitrary code with escalated privileges.

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All uim users should upgrade to the latest available version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=app-i18n/uim-0.4.5.1"

References
==========

  [ 1 ] CAN-2005-0503
        http://www.cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0503
  [ 2 ] uim announcement
        http://lists.freedesktop.org/archives/uim/2005-February/000996.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200502-31.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0

--nextPart5396885.Yyr1AgGVqz
Content-Type: application/pgp-signature

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.6 (GNU/Linux)

iD8DBQBCI0RFzKC5hMHO6rkRAhfoAKCKK0j+B9wTCXMuP1E91MdNFRVieACeI9uP
PNqHWSycfw6PBg6hlPdUY1Q=
=C19i
-----END PGP SIGNATURE-----

--nextPart5396885.Yyr1AgGVqz--
    

- 漏洞信息

14013
uim Environment Variable Local Privilege Escalation

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-02-20 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 0.4.5.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

UIM LibUIM Environment Variables Privilege Escalation Weakness
Design Error 12604
No Yes
2005-02-21 12:00:00 2009-07-12 10:56:00
Discovery of this weakness is credited to Takumi Asaki.

- 受影响的程序版本

Uim Uim 0.4.5
+ Gentoo Linux
+ Mandriva Linux Mandrake 10.1 x86_64
+ Mandriva Linux Mandrake 10.1
Mandriva Linux Mandrake 10.1 x86_64
Mandriva Linux Mandrake 10.1
Uim Uim 0.4.5 .1

- 不受影响的程序版本

Uim Uim 0.4.5 .1

- 漏洞讨论

Uim is reported prone to an privilege escalation weakness. It is reported that the Uim library will always trust user-supplied environment variables, and that this may be exploited in circumstances where the Uim library is linked to a setuid/setgid application.

An attacker that has local interactive to a system that has a vulnerable application installed may potentially exploit this weakness to escalate privileges.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

The vendor has released version 0.4.5.1 to address this issue.

Mandrake has released an advisory (MDKSA-2005:046) and fixes to address this vulnerability. Customers are advised to peruse the referenced advisory for further information regarding obtaining and applying appropriate updates.

Gentoo has released advisory GLSA 200502-31 to address this issue. Gentoo updates can be applied by running the following commands as the superuser:
emerge --sync
emerge --ask --oneshot --verbose ">=app-i18n/uim-0.4.5.1"


Uim Uim 0.4.5

Mandriva Linux Mandrake 10.1

Mandriva Linux Mandrake 10.1 x86_64

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站