CVE-2005-0470
CVSS5.0
发布时间 :2005-03-14 00:00:00
修订时间 :2008-09-05 16:46:23
NMCOS    

[原文]Buffer overflow in wpa_supplicant before 0.2.7 allows remote attackers to cause a denial of service (segmentation fault) via invalid EAPOL-Key packet data.


[CNNVD]WPA_Supplicant 缓冲区溢出漏洞(CNNVD-200503-104)

        wpa_supplicant 0.2.7之前版本中存在缓冲区溢出,远程攻击者可以通过无效的EAPOL-Key分组数据实施拒绝服务攻击(分段故障)。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:wpa_supplicant:wpa_supplicant:0.2.4
cpe:/a:wpa_supplicant:wpa_supplicant:0.2.2
cpe:/o:gentoo:linuxGentoo Linux
cpe:/a:wpa_supplicant:wpa_supplicant:0.2.3
cpe:/a:wpa_supplicant:wpa_supplicant:0.2.6
cpe:/a:wpa_supplicant:wpa_supplicant:0.2
cpe:/o:suse:suse_linux:9.2SuSE SuSE Linux 9.2
cpe:/a:wpa_supplicant:wpa_supplicant:0.2.5
cpe:/o:suse:suse_linux:9.2::x86_64
cpe:/a:wpa_supplicant:wpa_supplicant:0.2.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0470
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0470
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200503-104
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/19357
(VENDOR_ADVISORY)  XF  wpasupplicant-bo(19357)
http://www.gentoo.org/security/en/glsa/glsa-200502-22.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200502-22
http://secunia.com/advisories/14313
(VENDOR_ADVISORY)  SECUNIA  14313
http://securitytracker.com/id?1013226
(UNKNOWN)  SECTRACK  1013226
http://lists.shmoo.com/pipermail/hostap/2005-February/009465.html
(UNKNOWN)  MLIST  [HostAP] 20050213 wpa_supplicant - new stable releases v0.3.8 and v0.2.7

- 漏洞信息

WPA_Supplicant 缓冲区溢出漏洞
中危 缓冲区溢出
2005-03-14 00:00:00 2005-10-20 00:00:00
远程  
        wpa_supplicant 0.2.7之前版本中存在缓冲区溢出,远程攻击者可以通过无效的EAPOL-Key分组数据实施拒绝服务攻击(分段故障)。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        wpa_supplicant wpa_supplicant 0.2
        wpa_supplicant wpa_supplicant 0.2.7
        http://hostap.epitest.fi/releases/wpa_supplicant-0.2.7.tar.gz
        wpa_supplicant wpa_supplicant 0.2.1
        wpa_supplicant wpa_supplicant 0.2.7
        http://hostap.epitest.fi/releases/wpa_supplicant-0.2.7.tar.gz
        wpa_supplicant wpa_supplicant 0.2.2
        wpa_supplicant wpa_supplicant 0.2.7
        http://hostap.epitest.fi/releases/wpa_supplicant-0.2.7.tar.gz
        wpa_supplicant wpa_supplicant 0.2.3
        wpa_supplicant wpa_supplicant 0.2.7
        http://hostap.epitest.fi/releases/wpa_supplicant-0.2.7.tar.gz
        wpa_supplicant wpa_supplicant 0.2.4
        SuSE wpa_supplicant-0.2.4-5.2.i586.rpm
        ftp://ftp.suse.com/pub/suse/i386/update/9.2/rpm/i586/wpa_supplicant-0.2.4-5.2.i586.rpm
        SuSE wpa_supplicant-0.2.4-5.2.x86_64.rpm
        ftp://ftp.suse.com/pub/suse/x86_64/update/9.2/rpm/x86_64/wpa_supplicant-0.2.4-5.2.x86_64.rpm
        wpa_supplicant wpa_supplicant 0.2.7
        http://hostap.epitest.fi/releases/wpa_supplicant-0.2.7.tar.gz
        wpa_supplicant wpa_supplicant 0.2.5
        wpa_supplicant wpa_supplicant 0.2.7
        http://hostap.epitest.fi/releases/wpa_supplicant-0.2.7.tar.gz
        wpa_supplicant wpa_supplicant 0.2.6
        wpa_supplicant wpa_supplicant 0.2.7
        http://hostap.epitest.fi/releases/wpa_supplicant-0.2.7.tar.gz

- 漏洞信息

13901
wpa_supplicant EAPOL-Key Frames Overflow
Input Manipulation
Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-02-13 Unknow
Unknow Unknow

- 解决方案

Unknown or Incomplete

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

WPA_Supplicant Remote Buffer Overflow Vulnerability
Boundary Condition Error 12664
Yes No
2005-02-16 12:00:00 2009-07-12 10:56:00
The individual or individuals responsible for the discovery of this issue are currently unknown; the vendor disclosed this issue.

- 受影响的程序版本

wpa_supplicant wpa_supplicant 0.2.6
wpa_supplicant wpa_supplicant 0.2.5
wpa_supplicant wpa_supplicant 0.2.4
wpa_supplicant wpa_supplicant 0.2.3
wpa_supplicant wpa_supplicant 0.2.2
wpa_supplicant wpa_supplicant 0.2.1
wpa_supplicant wpa_supplicant 0.2
S.u.S.E. Linux Personal 9.2 x86_64
S.u.S.E. Linux Personal 9.2
Gentoo Linux
wpa_supplicant wpa_supplicant 0.2.7
+ Gentoo Linux

- 不受影响的程序版本

wpa_supplicant wpa_supplicant 0.2.7
+ Gentoo Linux

- 漏洞讨论

A remote buffer overflow vulnerability affects wpa_supplicant. This issue is due to a failure of the application to securely copy network-derived data into internal process buffers.

Reportedly this issue may be leveraged to carry out denial of service attacks against affected computers. It should also be noted that due to the nature of this issue code execution may also be possible.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

The vendor has made an advisory available.

Gentoo Linux has released advisory GLSA 200502-22 dealing with this issue. Gentoo advises that all wpa_supplicant users should upgrade to the latest version:

emerge --sync
emerge --ask --oneshot --verbose ">=net-wireless/wpa_supplicant-0.2.7"

For more information, please see the referenced Gentoo Linux advisory.

SuSE Linux has released a security summary report (SUSE-SR:2005:006) that contains fixes to address this and other vulnerabilities. Customers are advised to peruse the referenced advisory for further information regarding obtaining and applying appropriate updates.


wpa_supplicant wpa_supplicant 0.2

wpa_supplicant wpa_supplicant 0.2.1

wpa_supplicant wpa_supplicant 0.2.2

wpa_supplicant wpa_supplicant 0.2.3

wpa_supplicant wpa_supplicant 0.2.4

wpa_supplicant wpa_supplicant 0.2.5

wpa_supplicant wpa_supplicant 0.2.6

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站