CVE-2005-0442
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:11:41
NMCO    

[原文]Directory traversal vulnerability in index.php for CubeCart 2.0.4 allows remote attackers to read arbitrary files via the language parameter.


[CNNVD]Brooky CubeCart多个漏洞(CNNVD-200505-104)

        CubeCart 2.0.4内的index.php中的目录遍历漏洞使得远程攻击者可以通过language参数读取任意文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:devellion:cubecart:2.0.4
cpe:/a:devellion:cubecart:2.0.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0442
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0442
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-104
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110842125901191&w=2
(UNKNOWN)  BUGTRAQ  20050214 [NOBYTES.COM: #2] CubeCart 2.0.4 - Multiple Vulnerabilities
http://marc.info/?l=bugtraq&m=111281888605580&w=2
(UNKNOWN)  BUGTRAQ  20050406 RE: [NOBYTES.COM: #6] CubeCart 2.0.6 - Information Disclosure
http://www.cubecart.com/site/forums/index.php?showtopic=5741
(VENDOR_ADVISORY)  CONFIRM  http://www.cubecart.com/site/forums/index.php?showtopic=5741
http://www.securityfocus.com/bid/12549
(PATCH)  BID  12549
http://xforce.iss.net/xforce/xfdb/19322
(UNKNOWN)  XF  cubecart-dotdot-directory-traversal(19322)

- 漏洞信息

Brooky CubeCart多个漏洞
中危 路径遍历
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        CubeCart 2.0.4内的index.php中的目录遍历漏洞使得远程攻击者可以通过language参数读取任意文件。

- 公告与补丁

        厂商现已发布CubeCart 2.0.5解决此问题。请联系厂商以获取修复版本。

- 漏洞信息

13777
CubeCart settings.inc.php Local File Inclusion
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity
Exploit Public

- 漏洞描述

Cubecart contains a flaw that may allow a remote attacker to include files outside of the web path. The issue is due to the settings.inc.php script not properly sanitizing user input, specifically traversal style attacks (../../) supplied via the 'language' variable.

- 时间线

2005-02-14 2005-02-09
2005-02-09 Unknow

- 解决方案

Upgrade to version 2.0.5 or higher, as it has been reported to fix this vulnerability. In addition, cubecart.com has released a patch for some older versions.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站