CVE-2005-0402
CVSS2.6
发布时间 :2005-05-02 00:00:00
修订时间 :2011-03-07 21:19:55
NMCOPS    

[原文]Firefox before 1.0.2 allows remote attackers to execute arbitrary code by tricking a user into saving a page as a Firefox sidebar panel, then using the sidebar panel to inject Javascript into a privileged page.


[CNNVD]Mozilla Firefox 脚本注入漏洞(CNNVD-200505-407)

        Mozilla Firefox中存在的漏洞可能允许远程代码执行。如果在侧栏中将恶意网页标记为书签的话就会出现这个漏洞。然后恶意的网页就会打开特权页面,注入JavaScript。这可能导致以受害客户端用户的权限执行任意代码。
        

- CVSS (基础分值)

CVSS分值: 2.6 [轻微(LOW)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: HIGH [漏洞利用存在特定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mozilla:firefox:0.10.1Mozilla Firefox 0.10.1
cpe:/a:mozilla:firefox:0.9Mozilla Firefox 0.9
cpe:/a:mozilla:firefox:0.8Mozilla Firefox 0.8
cpe:/a:mozilla:firefox:1.0.1Mozilla Firefox 1.0.1
cpe:/a:mozilla:firefox:0.9.2Mozilla Firefox 0.9.2
cpe:/a:mozilla:firefox:0.9.1Mozilla Firefox 0.9.1
cpe:/a:mozilla:firefox:1.0Mozilla Firefox 1.0
cpe:/a:mozilla:firefox:0.9.3Mozilla Firefox 0.9.3
cpe:/a:mozilla:firefox:1.0.2Mozilla Firefox 1.0.2
cpe:/a:mozilla:firefox:0.10Mozilla Firefox 0.10
cpe:/a:mozilla:firefox:0.9:rcMozilla Firefox 0.9 rc

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:11868Multiple unknown vulnerabilities in the (1) TZSP, (2) MGCP, (3) ISUP, (4) SMB, or (5) Bittorrent dissectors in Ethereal before 0.10.11 allow...
oval:org.mitre.oval:def:100027Firefox Sidebar Panel Code Execution Vulnerability
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0402
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0402
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-407
(官方数据源) CNNVD

- 其它链接及资源

https://bugzilla.mozilla.org/show_bug.cgi?id=284627
(PATCH)  MISC  https://bugzilla.mozilla.org/show_bug.cgi?id=284627
http://www.redhat.com/support/errata/RHSA-2005-336.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:336
http://secunia.com/advisories/14654
(VENDOR_ADVISORY)  SECUNIA  14654
http://www.vupen.com/english/advisories/2005/0296
(UNKNOWN)  VUPEN  ADV-2005-0296
http://www.mozilla.org/security/announce/mfsa2005-31.html
(VENDOR_ADVISORY)  CONFIRM  http://www.mozilla.org/security/announce/mfsa2005-31.html

- 漏洞信息

Mozilla Firefox 脚本注入漏洞
低危 访问验证错误
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        Mozilla Firefox中存在的漏洞可能允许远程代码执行。如果在侧栏中将恶意网页标记为书签的话就会出现这个漏洞。然后恶意的网页就会打开特权页面,注入JavaScript。这可能导致以受害客户端用户的权限执行任意代码。
        

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.mozilla.org/products/firefox/" target="_blank

- 漏洞信息 (F36817)

Gentoo Linux Security Advisory 200503-31 (PacketStormID:F36817)
2005-03-25 00:00:00
Gentoo  security.gentoo.org
advisory,remote,arbitrary,vulnerability
linux,gentoo
CVE-2005-0399,CVE-2005-0401,CVE-2005-0402
[点击下载]

Gentoo Linux Security Advisory GLSA 200503-31 - Mozilla Firefox 1.0.2 fixes new security vulnerabilities, including the remote execution of arbitrary code through malicious GIF images or sidebars. Versions less than 1.0.2 are affected.

This is an OpenPGP/MIME signed message (RFC 2440 and 3156)
--------------enig1748988B0F00C81084BBFAED
Content-Type: text/plain; charset=ISO-8859-1
Content-Transfer-Encoding: 7bit

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
Gentoo Linux Security Advisory                           GLSA 200503-31
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
                                            http://security.gentoo.org/
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

  Severity: Normal
     Title: Mozilla Firefox: Multiple vulnerabilities
      Date: March 25, 2005
      Bugs: #86148
        ID: 200503-31

- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -

Synopsis
========

Mozilla Firefox 1.0.2 fixes new security vulnerabilities, including the
remote execution of arbitrary code through malicious GIF images or
sidebars.

Background
==========

Mozilla Firefox is the popular next-generation browser from the Mozilla
project.

Affected packages
=================

    -------------------------------------------------------------------
     Package                         /  Vulnerable  /       Unaffected
    -------------------------------------------------------------------
  1  www-client/mozilla-firefox           < 1.0.2             >= 1.0.2
  2  www-client/mozilla-firefox-bin       < 1.0.2             >= 1.0.2
    -------------------------------------------------------------------
     2 affected packages on all of their supported architectures.
    -------------------------------------------------------------------

Description
===========

The following vulnerabilities were found and fixed in Mozilla Firefox:

* Mark Dowd from ISS X-Force reported an exploitable heap overrun in
  the GIF processing of obsolete Netscape extension 2 (CAN-2005-0399)

* Kohei Yoshino discovered that a page bookmarked as a sidebar could
  bypass privileges control (CAN-2005-0402)

* Michael Krax reported a new way to bypass XUL security restrictions
  through drag-and-drop of items like scrollbars (CAN-2005-0401)

Impact
======

* The GIF heap overflow could be triggered by a malicious GIF image
  that would end up executing arbitrary code with the rights of the
  user running Firefox

* By tricking the user into bookmarking a malicious page as a
  Sidebar, a remote attacker could potentially execute arbitrary code
  with the rights of the user running the browser

* By setting up a malicious website and convincing users to obey very
  specific drag-and-drop instructions, attackers may leverage
  drag-and-drop features to bypass XUL security restrictions, which
  could be used as a stepping stone to exploit other vulnerabilities

Workaround
==========

There is no known workaround at this time.

Resolution
==========

All Mozilla Firefox users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-1.0.2"

All Mozilla Firefox binary users should upgrade to the latest version:

    # emerge --sync
    # emerge --ask --oneshot --verbose
">=www-client/mozilla-firefox-bin-1.0.2"

References
==========

  [ 1 ] CAN-2005-0399
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0399
  [ 2 ] CAN-2005-0401
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0401
  [ 3 ] CAN-2005-0402
        http://cve.mitre.org/cgi-bin/cvename.cgi?name=CAN-2005-0402
  [ 4 ] Mozilla Security Advisories
        http://www.mozilla.org/projects/security/known-vulnerabilities.html

Availability
============

This GLSA and any updates to it are available for viewing at
the Gentoo Security Website:

  http://security.gentoo.org/glsa/glsa-200503-31.xml

Concerns?
=========

Security is a primary focus of Gentoo Linux and ensuring the
confidentiality and security of our users machines is of utmost
importance to us. Any security concerns should be addressed to
security@gentoo.org or alternatively, you may file a bug at
http://bugs.gentoo.org.

License
=======

Copyright 2005 Gentoo Foundation, Inc; referenced text
belongs to its owner(s).

The contents of this document are licensed under the
Creative Commons - Attribution / Share Alike license.

http://creativecommons.org/licenses/by-sa/2.0


--------------enig1748988B0F00C81084BBFAED
Content-Type: application/pgp-signature; name="signature.asc"
Content-Description: OpenPGP digital signature
Content-Disposition: attachment; filename="signature.asc"

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)

iD8DBQFCRAvjvcL1obalX08RApogAKCC3t+lSd+pyUuf1rCtRxo7PbHm6ACeOIZN
4BrWzJXpiQ0It5MU4D6YgTQ=
=nKOo
-----END PGP SIGNATURE-----

--------------enig1748988B0F00C81084BBFAED--
    

- 漏洞信息

15009
Mozilla Firefox Sidebar Panel Script Injection
Remote / Network Access Input Manipulation
Loss of Confidentiality
Exploit Public Vendor Verified

- 漏洞描述

Mozilla Firefox contains a flaw that may allow a malicious user to inject script code in the browser environment with the privleges of the locally-logged on user. The issue is triggered when a malicious web site is bookmarked as a sidebar panel. It is possible that the flaw may allow an attacker to run arbitrary code on the victim's machine, resulting in a loss of integrity.

- 时间线

2005-03-24 2005-03-03
2005-03-03 Unknow

- 解决方案

Upgrade to version 1.0.2 or higher, as it has been reported to fix this vulnerability. It is also possible to correct the flaw by implementing the following workaround(s): Do not bookmark untrusted sites as sidebar panels.

- 相关参考

- 漏洞作者

- 漏洞信息

Mozilla Firefox Sidebar Panel Script Injection Vulnerability
Access Validation Error 12884
Yes No
2005-03-23 12:00:00 2009-07-12 11:56:00
Discovery is credited to Kohei Yoshino.

- 受影响的程序版本

Netscape Netscape 7.2
Netscape Netscape 7.1
Netscape Netscape 7.0
Mozilla Firefox 1.0.1
+ Red Hat Fedora Core3
Mozilla Firefox 1.0
+ Gentoo Linux
+ Gentoo Linux
+ S.u.S.E. Linux Personal 9.2 x86_64
+ S.u.S.E. Linux Personal 9.2 x86_64
+ S.u.S.E. Linux Personal 9.2
+ S.u.S.E. Linux Personal 9.2
+ S.u.S.E. Linux Personal 9.1 x86_64
+ S.u.S.E. Linux Personal 9.1 x86_64
+ S.u.S.E. Linux Personal 9.1
+ S.u.S.E. Linux Personal 9.1
+ S.u.S.E. Linux Personal 9.0 x86_64
+ S.u.S.E. Linux Personal 9.0 x86_64
+ S.u.S.E. Linux Personal 9.0
+ S.u.S.E. Linux Personal 9.0
+ Slackware Linux 10.1
+ Slackware Linux 10.0
+ Slackware Linux 10.0
+ Slackware Linux 9.1
+ Slackware Linux 9.1
+ Slackware Linux -current
+ Slackware Linux -current
Mozilla Firefox 0.9.3
Mozilla Firefox 0.9.2
Mozilla Firefox 0.9.1
Mozilla Firefox 0.9 rc
Mozilla Firefox 0.9
Mozilla Firefox 0.8
Gentoo Linux
Netscape Netscape 8.0
Mozilla Firefox 1.0.2
+ Mandriva Linux Mandrake 10.2 x86_64
+ Mandriva Linux Mandrake 10.2
+ Mandriva Linux Mandrake 10.2
+ Red Hat Enterprise Linux AS 4
+ Red Hat Enterprise Linux AS 4
+ RedHat Desktop 4.0
+ RedHat Desktop 4.0
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux WS 4
+ RedHat Enterprise Linux WS 4

- 不受影响的程序版本

Netscape Netscape 8.0
Mozilla Firefox 1.0.2
+ Mandriva Linux Mandrake 10.2 x86_64
+ Mandriva Linux Mandrake 10.2
+ Mandriva Linux Mandrake 10.2
+ Red Hat Enterprise Linux AS 4
+ Red Hat Enterprise Linux AS 4
+ RedHat Desktop 4.0
+ RedHat Desktop 4.0
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux ES 4
+ RedHat Enterprise Linux WS 4
+ RedHat Enterprise Linux WS 4

- 漏洞讨论

Mozilla Firefox is prone to a vulnerability that could allow remote code execution.

This may occur if a malicious Web page is bookmarked as a sidebar panel. The malicious page may then reportedly open a privileged page and inject JavaScript. This may be leveraged to execute arbitrary code as the victim client user.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com &lt;mailto:vuldb@securityfocus.com&gt;.

- 解决方案

This issue has been addressed in Firefox 1.0.2.

RedHat has released an advisory (FEDORA-2005-246) for their Fedora Core 3 product. Please see the reference section for more information.

Gentoo has released advisory GLSA 200503-31 to address this issue in Firefox. Please see the referenced advisory for more information. Gentoo users may carry out the following commands to update their computers:

Mozilla Firefox users:
emerge --sync
emerge --ask --oneshot --verbose ">=www-client/mozilla-firefox-1.0.2"

Mozilla Firefox binary users:
emerge --sync
emerge --ask --oneshot ?verbose ">=www-client/mozilla-firefox-bin-1.0.2"

Netscape Browser 8.0 has been released to address various security issues. Please see the vendor advisory in Web references for more information.


Mozilla Firefox 0.8

Mozilla Firefox 0.9 rc

Mozilla Firefox 0.9

Mozilla Firefox 0.9.1

Mozilla Firefox 0.9.2

Mozilla Firefox 0.9.3

Mozilla Firefox 1.0

Mozilla Firefox 1.0.1

Netscape Netscape 7.0

Netscape Netscape 7.1

Netscape Netscape 7.2

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站