CVE-2005-0390
CVSS7.5
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:46:09
NMCOPS    

[原文]Buffer overflow in the HTTP redirection capability in conn.c for Axel before 1.0b may allow remote attackers to execute arbitrary code.


[CNNVD]Axel HTTP重定向缓冲区溢出漏洞(CNNVD-200505-580)

        用于Axel的1.0b之前版本的conn.c中的HTTP重定向功能存在缓冲区溢出,远程攻击者可以借此执行任意代码。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0390
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0390
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-580
(官方数据源) CNNVD

- 其它链接及资源

http://www.securityfocus.com/bid/13059
(PATCH)  BID  13059
http://www.debian.org/security/2005/dsa-706
(VENDOR_ADVISORY)  DEBIAN  DSA-706
http://security.gentoo.org/glsa/glsa-200504-09.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200504-09
http://secunia.com/advisories/14831
(PATCH)  SECUNIA  14831
http://www.mail-archive.com/debian-devel-changes@lists.debian.org/msg118978.html
(UNKNOWN)  CONFIRM  http://www.mail-archive.com/debian-devel-changes@lists.debian.org/msg118978.html

- 漏洞信息

Axel HTTP重定向缓冲区溢出漏洞
高危 缓冲区溢出
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        用于Axel的1.0b之前版本的conn.c中的HTTP重定向功能存在缓冲区溢出,远程攻击者可以借此执行任意代码。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Axel Axel 1.0 a
        Axel Axel 1.0b
        http://wilmer.gaast.net/downloads/axel-1.0b.tar.gz
        Debian axel-kapt_1.0a-1woody1_all.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel-kapt_1.0a-1wo ody1_all.deb
        Debian axel_1.0a-1woody1_alpha.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ alpha.deb
        Debian axel_1.0a-1woody1_arm.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ arm.deb
        Debian axel_1.0a-1woody1_hppa.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ hppa.deb
        Debian axel_1.0a-1woody1_i386.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ i386.deb
        Debian axel_1.0a-1woody1_ia64.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ ia64.deb
        Debian axel_1.0a-1woody1_m68k.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ m68k.deb
        Debian axel_1.0a-1woody1_mips.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ mips.deb
        Debian axel_1.0a-1woody1_mipsel.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ mipsel.deb
        Debian axel_1.0a-1woody1_powerpc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ powerpc.deb
        Debian axel_1.0a-1woody1_s390.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ s390.deb
        Debian axel_1.0a-1woody1_sparc.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/a/axel/axel_1.0a-1woody1_ sparc.deb
        

- 漏洞信息 (F37200)

dsa-706.txt (PacketStormID:F37200)
2005-04-19 00:00:00
 
advisory,remote,overflow,arbitrary
linux,debian
CVE-2005-0390
[点击下载]

Debian Security Advisory 706-1 - The Debian Security Audit Project discovered a buffer overflow in axel, a light download accelerator. When reading remote input the program did not check if a part of the input can overflow a buffer and maybe trigger the execution of arbitrary code.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 706-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
April 13th, 2005                        http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : axel
Vulnerability  : buffer overflow
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2005-0390
BugTraq ID     : 13059

Ulf H    

- 漏洞信息

15310
Axel HTTP conn.c Redirection Overflow
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Unknown Vendor Verified

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-04-06 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 1.0b or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Axel HTTP Redirection Buffer Overflow Vulnerability
Boundary Condition Error 13059
Yes No
2005-04-07 12:00:00 2009-07-12 12:56:00
Discovered by Ulf Härnhammar from the Debian Security Audit Project.

- 受影响的程序版本

Axel Axel 1.0 a
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
+ Gentoo Linux

- 漏洞讨论

Axel is prone to a buffer overflow vulnerability when handling HTTP redirection. A malicious HTTP response can trigger this issue, potentially allowing for arbitrary code execution.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

Gentoo Linux has released advisory GLSA 200504-09 to address this issue. Users of affected packages are urged to execute the following commands with superuser privileges:
emerge --sync
emerge --ask --oneshot --verbose ">=net-misc/axel-1.0b"
Please see the referenced advisory for further information.

Debian has released advisory DSA 706-1 to address this issue. Please see the referenced advisory for more information.

This issue was addressed in Axel 1.0b:


Axel Axel 1.0 a

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站