CVE-2005-0386
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:46:08
NMCOPS    

[原文]Cross-site scripting (XSS) vulnerability in network.cgi in mailreader before 2.3.29 earlier allows remote attackers to inject arbitrary web script or HTML via MIME text/enriched or text/richtext messages.


[CNNVD]Mailreader 跨站脚本攻击漏洞(CNNVD-200505-588)

        mailreader的2.3.29之前版本中的network.cgi存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过MIME text/enriched或text/richtext信息来注入任意Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: NONE [对系统的机密性无影响]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: NONE [对系统可用性无影响]
攻击复杂度: MEDIUM [漏洞利用存在一定的访问条件]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/a:mailreader.com:mailreader.com:2.3.29
cpe:/a:mailreader.com:mailreader.com:2.3.27
cpe:/a:mailreader.com:mailreader.com:2.3.25
cpe:/a:mailreader.com:mailreader.com:2.3.23
cpe:/a:mailreader.com:mailreader.com:2.3.24
cpe:/a:mailreader.com:mailreader.com:2.3.26
cpe:/a:mailreader.com:mailreader.com:2.3.28
cpe:/a:mailreader.com:mailreader.com:2.3.22
cpe:/a:mailreader.com:mailreader.com:2.3.21
cpe:/a:mailreader.com:mailreader.com:2.3.20

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0386
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0386
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-588
(官方数据源) CNNVD

- 其它链接及资源

http://www.debian.org/security/2005/dsa-700
(VENDOR_ADVISORY)  DEBIAN  DSA-700
http://secunia.com/advisories/14777
(VENDOR_ADVISORY)  SECUNIA  14777

- 漏洞信息

Mailreader 跨站脚本攻击漏洞
中危 跨站脚本
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        mailreader的2.3.29之前版本中的network.cgi存在跨站脚本攻击(XSS)漏洞,远程攻击者可以通过MIME text/enriched或text/richtext信息来注入任意Web脚本或HTML。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        Mailreader.com Mailreader.com 2.3.29
        Debian mailreader_2.3.29-5woody2_all.deb
        Debian GNU/Linux 3.0 alias woody
        http://security.debian.org/pool/updates/main/m/mailreader/mailreader_2.3.29-5woody2_all.deb

- 漏洞信息 (F36903)

dsa-700.txt (PacketStormID:F36903)
2005-04-14 00:00:00
 
advisory,xss
linux,debian
CVE-2005-0386
[点击下载]

Debian Security Advisory 700-1 - The Debian Security Audit Project discovered a cross-site scripting problem in mailreader, a simple, but powerful WWW mail reader system, when displaying messages of the MIME types text/enriched or text/richtext.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

- --------------------------------------------------------------------------
Debian Security Advisory DSA 700-1                     security@debian.org
http://www.debian.org/security/                             Martin Schulze
March 30th, 2005                        http://www.debian.org/security/faq
- --------------------------------------------------------------------------

Package        : mailreader
Vulnerability  : missing input sanitising
Problem-Type   : remote
Debian-specific: no
CVE ID         : CAN-2005-0386

Ulf H    

- 漏洞信息

15157
Mailreader network.cgi enriched/richtext MIME Message XSS
Remote / Network Access Input Manipulation
Loss of Integrity Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2005-03-30 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.3.36 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

Mailreader Remote HTML Injection Vulnerability
Input Validation Error 12945
Yes No
2005-03-30 12:00:00 2009-07-12 11:56:00
Ulf Harnhammar is credited with the discovery of this issue.

- 受影响的程序版本

Mailreader.com Mailreader.com 2.3.29

- 漏洞讨论

A remote HTML injection vulnerability affects Mailreader. This issue is due to a failure of the application to properly sanitize user-supplied input prior to including it in dynamically generated Web content.

An attacker may leverage this issue to have arbitrary script code executed in the browser of an unsuspecting user. This may facilitate the theft of cookie-based authentication credentials as well as other attacks.

- 漏洞利用

No exploit is required to leverage this issue.

- 解决方案

Debian Linux has released an advisory (DSA 700-1) dealing with this issue. Please see the referenced advisory for more information.


Mailreader.com Mailreader.com 2.3.29

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站