CVE-2005-0373
CVSS7.5
发布时间 :2004-10-07 00:00:00
修订时间 :2008-09-10 15:35:27
NMCO    

[原文]Buffer overflow in digestmd5.c CVS release 1.170 (also referred to as digestmda5.c), as used in the DIGEST-MD5 SASL plugin for Cyrus-SASL but not in any official releases, allows remote attackers to execute arbitrary code.


[CNNVD]Cyrus SASL SASL_PATH环境变量权限提升漏洞(CNNVD-200410-006)

        
        Cyrus SASL提供多个用于安全认证的开放源代码实现。
        Cyrus SASL对SASL_PATH环境变量处理不正确,本地攻击者可以利用这个漏洞进行提升特权攻击。
        攻击者可以利用SASL_PATH环境变量,使特权应用程序从用户指定的任意目录中装载任意库文件,可导致恶意程序以高特权运行。
        

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

cpe:/o:apple:mac_os_x:10.1.5Apple Mac OS X 10.1.5
cpe:/o:apple:mac_os_x_server:10.2.1Apple Mac OS X Server 10.2.1
cpe:/o:apple:mac_os_x:10.2Apple Mac OS X 10.2
cpe:/a:cyrus:sasl:1.5.27
cpe:/o:apple:mac_os_x:10.1.4Apple Mac OS X 10.1.4
cpe:/o:apple:mac_os_x_server:10.0Apple Mac OS X Server 10.0
cpe:/a:cyrus:sasl:2.1.17
cpe:/o:apple:mac_os_x:10.2.5Apple Mac OS X 10.2.5
cpe:/o:apple:mac_os_x_server:10.2Apple Mac OS X Server 10.2
cpe:/a:openpkg:openpkg:2.1OpenPKG 2.1
cpe:/o:apple:mac_os_x_server:10.2.4Apple Mac OS X Server 10.2.4
cpe:/a:cyrus:sasl:2.1.11
cpe:/a:cyrus:sasl:2.1.12
cpe:/o:apple:mac_os_x:10.0Apple Mac OS X 10.0
cpe:/a:cyrus:sasl:2.1.14
cpe:/a:openpkg:openpkg:2.2OpenPKG 2.2
cpe:/a:cyrus:sasl:2.1.18
cpe:/o:suse:suse_linux:1.0::desktop
cpe:/a:cyrus:sasl:2.1.15
cpe:/o:apple:mac_os_x:10.0.3Apple Mac OS X 10.0.3
cpe:/a:cyrus:sasl:2.1.18_r1
cpe:/o:apple:mac_os_x:10.1.3Apple Mac OS X 10.1.3
cpe:/o:apple:mac_os_x:10.3.6Apple Mac OS X 10.3.6
cpe:/o:apple:mac_os_x:10.2.1Apple Mac OS X 10.2.1
cpe:/o:apple:mac_os_x:10.3.8Apple Mac OS X 10.3.8
cpe:/o:conectiva:linux:9.0Conectiva Linux 9.0
cpe:/o:apple:mac_os_x:10.2.6Apple Mac OS X 10.2.6
cpe:/o:suse:suse_linux:9.2::x86_64
cpe:/o:suse:suse_linux:8.0::i386
cpe:/o:suse:suse_linux:9.0SuSE SuSE Linux 9.0
cpe:/o:suse:suse_linux:8.2SuSE SuSE Linux 8.2
cpe:/o:apple:mac_os_x:10.3.7Apple Mac OS X 10.3.7
cpe:/o:redhat:fedora_core:core_1.0
cpe:/o:apple:mac_os_x:10.3Apple Mac OS X 10.3
cpe:/o:apple:mac_os_x_server:10.2.2Apple Mac OS X Server 10.2.2
cpe:/o:apple:mac_os_x:10.3.1Apple Mac OS X 10.3.1
cpe:/a:cyrus:sasl:1.5.28
cpe:/a:cyrus:sasl:2.1.13
cpe:/o:apple:mac_os_x_server:10.2.6Apple Mac OS X Server 10.2.6
cpe:/o:apple:mac_os_x:10.2.7Apple Mac OS X 10.2.7
cpe:/o:apple:mac_os_x_server:10.1Apple Mac OS X Server 10.1
cpe:/o:suse:suse_linux:9.0::enterprise_server
cpe:/o:suse:suse_linux:8.1SuSE SuSE Linux 8.1
cpe:/o:apple:mac_os_x:10.1Apple Mac OS X 10.1
cpe:/o:apple:mac_os_x_server:10.3.5Apple Mac OS X Server 10.3.5
cpe:/o:suse:suse_linux:9.2SuSE SuSE Linux 9.2
cpe:/o:apple:mac_os_x:10.0.1Apple Mac OS X 10.0.1
cpe:/o:apple:mac_os_x_server:10.1.2Apple Mac OS X Server 10.1.2
cpe:/o:apple:mac_os_x:10.0.4Apple Mac OS X 10.0.4
cpe:/o:apple:mac_os_x_server:10.2.7Apple Mac OS X Server 10.2.7
cpe:/o:apple:mac_os_x:10.2.2Apple Mac OS X 10.2.2
cpe:/o:suse:suse_linux:9.1SuSE SuSE Linux 9.1
cpe:/o:apple:mac_os_x:10.3.3Apple Mac OS X 10.3.3
cpe:/o:conectiva:linux:10.0Conectiva Linux 10.0
cpe:/o:suse:suse_linux:9.1::x86_64
cpe:/o:apple:mac_os_x:10.2.4Apple Mac OS X 10.2.4
cpe:/o:apple:mac_os_x_server:10.3.3Apple Mac OS X Server 10.3.3
cpe:/o:apple:mac_os_x_server:10.3.4Apple Mac OS X Server 10.3.4
cpe:/o:apple:mac_os_x:10.2.3Apple Mac OS X 10.2.3
cpe:/o:apple:mac_os_x:10.3.2Apple Mac OS X 10.3.2
cpe:/a:cyrus:sasl:2.1.9
cpe:/o:apple:mac_os_x:10.2.8Apple Mac OS X 10.2.8
cpe:/o:suse:suse_linux:9.0::x86_64
cpe:/o:suse:suse_linux:8.0SuSE SuSE Linux 8.0
cpe:/o:apple:mac_os_x_server:10.2.8Apple Mac OS X Server 10.2.8
cpe:/o:apple:mac_os_x:10.1.1Apple Mac OS X 10.1.1
cpe:/a:suse:suse_cvsup:16.1h_36.i586
cpe:/a:cyrus:sasl:2.1.10
cpe:/o:apple:mac_os_x_server:10.3.1Apple Mac OS X Server 10.3.1
cpe:/o:apple:mac_os_x_server:10.2.5Apple Mac OS X Server 10.2.5
cpe:/o:apple:mac_os_x:10.3.4Apple Mac OS X 10.3.4
cpe:/o:apple:mac_os_x_server:10.3.2Apple Mac OS X Server 10.3.2
cpe:/o:apple:mac_os_x:10.0.2Apple Mac OS X 10.0.2
cpe:/a:cyrus:sasl:1.5.24
cpe:/o:apple:mac_os_x_server:10.3Apple Mac OS X Server 10.3
cpe:/o:apple:mac_os_x_server:10.1.3Apple Mac OS X Server 10.1.3
cpe:/o:apple:mac_os_x_server:10.3.8Apple Mac OS X Server 10.3.8
cpe:/o:apple:mac_os_x_server:10.2.3Apple Mac OS X Server 10.2.3
cpe:/o:apple:mac_os_x:10.3.5Apple Mac OS X 10.3.5
cpe:/o:apple:mac_os_x_server:10.3.7Apple Mac OS X Server 10.3.7
cpe:/o:apple:mac_os_x_server:10.1.1Apple Mac OS X Server 10.1.1
cpe:/o:apple:mac_os_x_server:10.1.5Apple Mac OS X Server 10.1.5
cpe:/o:apple:mac_os_x:10.1.2Apple Mac OS X 10.1.2
cpe:/a:cyrus:sasl:2.1.16
cpe:/o:apple:mac_os_x_server:10.3.6Apple Mac OS X Server 10.3.6
cpe:/o:apple:mac_os_x_server:10.1.4Apple Mac OS X Server 10.1.4

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0373
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0373
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200410-006
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/17642
(VENDOR_ADVISORY)  XF  cyrus-sasl-digestmda5-bo(17642)
http://www.securityfocus.com/bid/11347
(VENDOR_ADVISORY)  BID  11347
http://www.monkey.org/openbsd/archive/ports/0407/msg00265.html
(VENDOR_ADVISORY)  MLIST  [openbsd-ports] 20040717 UPDATE: cyrus-sasl-2.1.19
http://www.linuxcompatible.org/print42495.html
(VENDOR_ADVISORY)  SUSE  SUSE-SR:2005:006
http://www.gentoo.org/security/en/glsa/glsa-200410-05.xml
(VENDOR_ADVISORY)  GENTOO  GLSA-200410-05
https://bugzilla.andrew.cmu.edu/cgi-bin/cvsweb.cgi/src/sasl/plugins/digestmd5.c?rev=1.171&content-type=text/x-cvsweb-markup
(VENDOR_ADVISORY)  CONFIRM  https://bugzilla.andrew.cmu.edu/cgi-bin/cvsweb.cgi/src/sasl/plugins/digestmd5.c?rev=1.171&content-type=text/x-cvsweb-markup
https://bugzilla.andrew.cmu.edu/cgi-bin/cvsweb.cgi/src/sasl/plugins/digestmd5.c.diff?r1=1.170&r2=1.171
(VENDOR_ADVISORY)  CONFIRM  https://bugzilla.andrew.cmu.edu/cgi-bin/cvsweb.cgi/src/sasl/plugins/digestmd5.c.diff?r1=1.170&r2=1.171
http://www.mandriva.com/security/advisories?name=MDKSA-2005:054
(UNKNOWN)  MANDRAKE  MDKSA-2005:054

- 漏洞信息

Cyrus SASL SASL_PATH环境变量权限提升漏洞
高危 边界条件错误
2004-10-07 00:00:00 2005-10-20 00:00:00
远程※本地  
        
        Cyrus SASL提供多个用于安全认证的开放源代码实现。
        Cyrus SASL对SASL_PATH环境变量处理不正确,本地攻击者可以利用这个漏洞进行提升特权攻击。
        攻击者可以利用SASL_PATH环境变量,使特权应用程序从用户指定的任意目录中装载任意库文件,可导致恶意程序以高特权运行。
        

- 公告与补丁

        厂商补丁:
        Carnegie Mellon University
        --------------------------
        目前厂商已经发布了升级补丁以修复这个安全问题,请到厂商的主页下载:
        https://bugzilla.andrew.cmu.edu/cgi-bin/cvsweb.cgi/src/sasl/lib/common.c.diff?r1=1.103&r2=1.104
        Cyrus SASL 2.1.19已经修复此漏洞。

- 漏洞信息

10554
Cyrus SASL digestmda5.c Buffer Overflow
Input Manipulation
Loss of Integrity Patch / RCS, Upgrade
Vendor Verified

- 漏洞描述

- 时间线

2004-10-08 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 2.1.20 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站