发布时间 :2005-01-17 00:00:00
修订时间 :2016-10-17 23:09:46

[原文]Multiple SQL injection vulnerabilities in index.php in PHP Gift Registry (phpGiftReg) 1.4.0, and possibly other versions before 1.5.0b1, allow remote attackers to execute arbitrary SQL commands via the (1) messageid, (2) shopper, (3) shopfor, or (4) itemid parameters.

[CNNVD] PHPGiftRegistry index.php SQL注入漏洞(CNNVD-200501-250)

        PHP Gift Registry是一套Web应用系统,为其成员提供接收到的礼物的跟踪。
        PHP Gift Registry 1.4.0版本中的index.php存在SQL注入漏洞。其1.5.0b1之前版本也可能存在该漏洞。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  FULLDISC  20050116 phpGiftReq SQL Injection
(UNKNOWN)  BUGTRAQ  20050116 phpGiftReq SQL Injection
(VENDOR_ADVISORY)  BUGTRAQ  20050307 Re: phpGiftReq SQL Injection
(VENDOR_ADVISORY)  XF  phpgiftregistry-sql-injection(18925)

- 漏洞信息

PHPGiftRegistry index.php SQL注入漏洞
高危 SQL注入
2005-01-17 00:00:00 2005-10-20 00:00:00
        PHP Gift Registry是一套Web应用系统,为其成员提供接收到的礼物的跟踪。
        PHP Gift Registry 1.4.0版本中的index.php存在SQL注入漏洞。其1.5.0b1之前版本也可能存在该漏洞。

- 公告与补丁


- 漏洞信息

PHP Gift Registry index.php Multiple Parameter SQL Injection
Remote / Network Access Information Disclosure, Input Manipulation
Loss of Confidentiality, Loss of Integrity

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-01-16 2004-12-31
2005-01-16 Unknow

- 解决方案

Upgrade to version 1.5.0b1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

PHP Gift Registry Multiple SQL Injection Vulnerabilities
Input Validation Error 12289
Yes No
2005-01-17 12:00:00 2009-07-12 10:06:00
Discovery of this vulnerability is credited to Madelman <>.

- 受影响的程序版本

PHP Gift Registry phpgiftreg 1.4
PHP Gift Registry phpgiftreg 1.5 b1

- 不受影响的程序版本

PHP Gift Registry phpgiftreg 1.5 b1

- 漏洞讨论

PHP Gift Registry is reportedly affected by multiple SQL injection vulnerabilities. These issues are due to the application failing to properly sanitize user-supplied input before being used in SQL queries.

It is reported that successful exploitation could result in a compromise of the application, disclosure or modification of data or may permit an attacker to exploit vulnerabilities in the underlying database implementation.

- 漏洞利用

No exploit is required and the following proof of concepts were provided by the discoverer of this vulnerability:

Acknowledge all messages;messageid=2%20OR%201%3d1

Approve all pending requests;shopper=1%20OR%201%3d1

Decline all pending requests;shopper=1%20OR%201%3d1

Inserts current shopper for buying to user 3 without need for approval;shopfor=3%2c0%29%2c%2899%2c100

Delete all data from table shoppers;shopfor=3%20OR%201%3d1

Delete all data from table items;itemid=3%20OR%201%3d1

- 解决方案

The vendor has released phpgiftreg 1.5.0 b1 to address these issues.

PHP Gift Registry phpgiftreg 1.4

- 相关参考