发布时间 :2005-01-17 00:00:00
修订时间 :2016-10-17 23:09:44

[原文]NETGEAR FVS318 running firmware 2.4, and possibly other versions, allows remote attackers to bypass the filters using hex encoded URLs, as demonstrated using a hex encoded file extension.

[CNNVD]Netgear FVS318 filter 绕过检测漏洞(CNNVD-200501-249)

        Netgear FVS318是一款方便使用的小型路由器。
        固件版本为2.4的Netgear FVS318中存在绕过过滤检测漏洞。

- CVSS (基础分值)

CVSS分值: 7.5 [严重(HIGH)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(VENDOR_ADVISORY)  FULLDISC  20050117 Multiple Vulnerabilities in Netgear FVS318 Router
(UNKNOWN)  BUGTRAQ  20050117 Multiple Vulnerabilities in Netgear FVS318 Router
(VENDOR_ADVISORY)  XF  netgear-fvs318-filter-bypass(18920)

- 漏洞信息

Netgear FVS318 filter 绕过检测漏洞
高危 输入验证
2005-01-17 00:00:00 2005-10-20 00:00:00
        Netgear FVS318是一款方便使用的小型路由器。
        固件版本为2.4的Netgear FVS318中存在绕过过滤检测漏洞。

- 公告与补丁


- 漏洞信息

NETGEAR FVS318 Router HEX Encoded Character Filter Bypass
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

FVS318 router contains a flaw that may allow a malicious user to bypass URL filtering. The issue is triggered when one or more characters in the URL are HEX encoded. It is possible that the flaw may allow a user to access filtered URL phrases resulting in a loss of integrity.

- 时间线

2005-01-17 2005-01-14
2005-01-17 Unknow

- 解决方案

Currently, there are no known upgrades, patches, or workarounds available to correct this issue.

- 相关参考

- 漏洞作者

- 漏洞信息

NetGear FVS318 ProSafe VPN Firewall Switch Multiple Vulnerabilities
Input Validation Error 12278
Yes No
2005-01-17 12:00:00 2009-07-12 10:06:00
Discovery is credited to Paul Kurczaba <>.

- 受影响的程序版本

NetGear FVS318v2 2.4
NetGear FVS318 2.4

- 漏洞讨论

NetGear FVS318 is reported prone to multiple vulnerabilities. These issues result from insufficient sanitization of user-supplied data and may allow an attacker to bypass URI filters and carry out cross-site scripting attacks.

The following issues were identified:

It is reported that an attacker can bypass URI filters of the device.

The URI filter log viewer is reported prone to a cross-site scripting vulnerability.

The research report specified that FVS318 devices with firmware 2.4 are vulnerable to these issues. FVS318 and FVS318v2 are shipped with firmware 2.4, however, it is possible that FVS318v3 and other firmware versions are affected as well. This BID will be updated when more information about affected packages is available.

- 漏洞利用

An exploit is not required.

The following proof of concept is available:

Filter Bypass:
Replace 'x' in '".exe' with '.e%78e'

Cross-site scripting:;/textarea&gt;&lt;script&gt;alert('XSS')&lt;/script&gt;

- 解决方案

Currently we are not aware of any vendor-supplied patches for this issue. If you feel we are in error or are aware of more recent information, please mail us at: <>.

- 相关参考