CVE-2005-0270
CVSS4.3
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:09:19
NMCO    

[原文]Multiple cross-site scripting (XSS) vulnerabilities in ReviewPost PHP Pro before 2.84 allow remote attackers to inject arbitrary web script or HTML via the (1) si parameter to showcat.php, (2) cat or (3) page parameter to showproduct.php, or (4) report parameter to reportproduct.php.


[CNNVD]ReviewPost PHP 多个跨站脚本漏洞(CNNVD-200505-004)

        ReviewPost PHP Pro 2.84 之前的版本存在多个跨站脚本(XSS)漏洞,远程攻击者可以通过showcat.php的(1)si参数,showproduct.php的(2)cat或(3)page参数或reportproduct.php的(4)report参数来注入Web脚本或HTML。

- CVSS (基础分值)

CVSS分值: 4.3 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)

cpe:/a:photopost:reviewpost_php_pro:2.5
cpe:/a:photopost:reviewpost_php_pro:2.84
cpe:/a:photopost:reviewpost_php_pro:1.0.2
cpe:/a:photopost:reviewpost_php_pro:2.5.1

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0270
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0270
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-004
(官方数据源) CNNVD

- 其它链接及资源

http://marc.info/?l=bugtraq&m=110485682424110&w=2
(UNKNOWN)  BUGTRAQ  20050103 Serious Vulnerabilities In PhotoPost ReviewPost
http://www.gulftech.org/?node=research&article_id=00062-01022005
(VENDOR_ADVISORY)  MISC  http://www.gulftech.org/?node=research&article_id=00062-01022005
http://xforce.iss.net/xforce/xfdb/18731
(UNKNOWN)  XF  reviewpost-php-xss(18731)

- 漏洞信息

ReviewPost PHP 多个跨站脚本漏洞
中危 跨站脚本
2005-05-02 00:00:00 2006-09-22 00:00:00
远程  
        ReviewPost PHP Pro 2.84 之前的版本存在多个跨站脚本(XSS)漏洞,远程攻击者可以通过showcat.php的(1)si参数,showproduct.php的(2)cat或(3)page参数或reportproduct.php的(4)report参数来注入Web脚本或HTML。

- 公告与补丁

        暂无数据

- 漏洞信息

12703
ReviewPost PHP Pro showcat.php si Parameter XSS
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

ReviewPost PHP Pro contains a flaw that allows a remote cross site scripting attack. This flaw exists because the application does not validate 'si' variables upon submission to the 'showcat.php' script. This could allow a user to create a specially crafted URL that would execute arbitrary code in a user's browser within the trust relationship between the browser and the server, leading to a loss of integrity.

- 时间线

2005-01-03 Unknow
2005-01-03 Unknow

- 解决方案

Upgrade to version 2.84 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站