发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:09:10

[原文]BibORB 1.3.2, and possibly earlier versions, does not properly enforce a restriction for uploading only PDF and PS files, which allows remote attackers to upload arbitrary files that are presented to other users with PDF or PS icons, which may trick some users into downloading and executing those files.


        BibORB 1.3.2及可能的更早版本,未将上载文件类型限制为PDF和PS,远程攻击者可能把上载的任意文件以PDF或PS图标显示给其他用户,从而欺骗一些用户来下载和执行这些文件。

- CVSS (基础分值)

CVSS分值: 5 [中等(MEDIUM)]
机密性影响: [--]
完整性影响: [--]
可用性影响: [--]
攻击复杂度: [--]
攻击向量: [--]
身份认证: [--]

- CPE (受影响的平台与产品)


- OVAL (用于检测的技术细节)


- 官方数据库链接
(官方数据源) MITRE
(官方数据源) NVD
(官方数据源) CNNVD

- 其它链接及资源
(UNKNOWN)  BUGTRAQ  20050217 Advisory: Multiple Vulnerabilities in BibORB
(UNKNOWN)  FULLDISC  20050217 Advisory: Multiple Vulnerabilities in BibORB
(PATCH)  BID  12583

- 漏洞信息

中危 输入验证
2005-05-02 00:00:00 2005-10-20 00:00:00
        BibORB 1.3.2及可能的更早版本,未将上载文件类型限制为PDF和PS,远程攻击者可能把上载的任意文件以PDF或PS图标显示给其他用户,从而欺骗一些用户来下载和执行这些文件。

- 公告与补丁

        BibORB BibORB 1.3.2
        BibORB BibORB 1.3.2 Security Update

- 漏洞信息 (F36209)

BibORB.txt (PacketStormID:F36209)
2005-02-25 00:00:00
Patrick Hof  
exploit,arbitrary,vulnerability,xss,sql injection,file upload

BibORB 1.3.2 is susceptible to SQL injection, cross site scripting, directory traversal, and arbitrary file upload vulnerabilities. Detailed exploitation provided.

= Advisory: Multiple Vulnerabilities in BibORB =

Multiple vulnerabilities were found in BibORB which result in SQL 
injection, XSS, directory traversal and arbitrary file upload.

== Details ==

Product: BibORB
Affected Version: 1.3.2, probably all lower versions
Immune Version: 1.3.2 Security Update, 1.3.3 RC1
OS affected: all
Security-Risk: high
Remote-Exploit: yes
Vendor-Status: notified
CVE: CAN-2005-0251 - 0254

== Introduction ==

"BibORB is a web-interface to BibTeX bibliographies (the bibliographic 
system used with LaTeX). It offers an easy to use solution to manage and 
share BibTeX bibliographies and electronic releases of papers."
(from maintainer's page)

XSS, SQL injection, directory traversal and arbitrary file upload make 
it possible to completely compromise the application and its users.

== More Details ==

=== XSS ===


Some variables containing user data are not filtered, so XSS is possible.

=== Proof of Concept ===



Add Database -> Description: <script>alert('XSS')</script>

executed everytime the Database is shown.

=== SQL Injection ===


If MySQL is used as authorization backend, SQL Injection may be used to 
get admin status.

=== Proof of Concept ===

When logging in, use the following username and password:

Username: x' or 1=1 or login='x
Password: x') or 1=1 or password=md5('x

=== Directory Traversal ===


If a user has the right to delete database entries, arbitrary files 
accessable by the user under which the application runs may be deleted.

=== Proof of Concept ===


=== Arbitrary file upload ===


When a new entry is created, the user is presented with a mask where PDF 
and PS files can be uploaded as an addition to the entry. There is no 
check what files the user uploads, and those files are linked with 
standard icons widely used to show that the file is a PDF or PS file. 
Users may be fooled to click the icon and download malicious code 
instead of the desired PDF or PS file.

=== Proof of Concept ===

Just upload some arbitrary data file when creating a new entry.

== Fix ==

Update to either BibORB 1.3.2 Security Update or to 1.3.3 RC1.

== Security Risk ==

High, because the application can be completely compromised.

== Vendor Status ==

01.02.2005 Maintainer contacted
08.02.2005 Delayed response due to mail problems
09.02.2005 First release of a patch
16.02.2005 Final patched version released

- 漏洞信息

BibORB Arbitrary File Upload
Remote / Network Access Input Manipulation
Loss of Integrity
Exploit Public

- 漏洞描述

BibORB contains a flaw that may allow a remote attacker to upload arbitrary files. The issue is due to program not properly sanitizing user input supplied to the upload file. This may allow an attacker to include a file from a remote host that contains arbitrary commands which is linked with standard icons of a PDF or PS file. Users may be fooled to click the icon and download malicious code instead of the desired PDF or PS file.

- 时间线

2005-02-17 2005-02-01
2005-02-17 Unknow

- 解决方案

Upgrade to version 1.3.3 RC1 or higher, as it has been reported to fix this vulnerability. In addition, BibORB has released a patch for 1.3.2 versions.

- 相关参考

- 漏洞作者