CVE-2005-0244
CVSS6.5
发布时间 :2005-05-02 00:00:00
修订时间 :2016-10-17 23:09:01
NMCO    

[原文]PostgreSQL 8.0.0 and earlier allows local users to bypass the EXECUTE permission check for functions by using the CREATE AGGREGATE command.


[CNNVD]PostgreSQL 未明漏洞(CNNVD-200505-321)

        PostgreSQL 8.0.0以及较早的版本允许本地用户通过使用CREATE AGGREGATE命令来绕过函数的EXECUTE权限检查。

- CVSS (基础分值)

CVSS分值: 6.5 [中等(MEDIUM)]
机密性影响: PARTIAL [很可能造成信息泄露]
完整性影响: PARTIAL [可能会导致系统文件被修改]
可用性影响: PARTIAL [可能会导致性能下降或中断资源访问]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: NETWORK [攻击者不需要获取内网访问权或本地访问权]
身份认证: SINGLE_INSTANCE [--]

- CWE (弱点类目)

CWE-264 [权限、特权与访问控制]

- CPE (受影响的平台与产品)

cpe:/a:postgresql:postgresql:7.2.6
cpe:/a:postgresql:postgresql:7.3.5
cpe:/a:postgresql:postgresql:7.4.4PostgreSQL PostgreSQL 7.4.4
cpe:/a:postgresql:postgresql:7.2.5
cpe:/a:postgresql:postgresql:7.3.4
cpe:/a:postgresql:postgresql:7.4.3PostgreSQL PostgreSQL 7.4.3
cpe:/a:postgresql:postgresql:7.2.4
cpe:/a:postgresql:postgresql:7.3.3
cpe:/a:postgresql:postgresql:7.4.2PostgreSQL PostgreSQL 7.4.2
cpe:/a:postgresql:postgresql:7.2.3
cpe:/a:postgresql:postgresql:7.3.2
cpe:/a:postgresql:postgresql:7.4.1PostgreSQL PostgreSQL 7.4.1
cpe:/a:postgresql:postgresql:7.3.9
cpe:/a:postgresql:postgresql:7.3.8
cpe:/a:postgresql:postgresql:7.4.7PostgreSQL PostgreSQL 7.4.7
cpe:/a:postgresql:postgresql:7.3.7
cpe:/a:postgresql:postgresql:7.4.6PostgreSQL PostgreSQL 7.4.6
cpe:/a:postgresql:postgresql:7.2.7
cpe:/a:postgresql:postgresql:7.3.6
cpe:/a:postgresql:postgresql:7.4.5PostgreSQL PostgreSQL 7.4.5
cpe:/a:postgresql:postgresql:8.0.0
cpe:/a:postgresql:postgresql:7.2.2
cpe:/a:postgresql:postgresql:7.3.1
cpe:/a:postgresql:postgresql:7.2.1
cpe:/a:postgresql:postgresql:7.4PostgreSQL PostgreSQL 7.4
cpe:/a:postgresql:postgresql:7.3 PostgreSQL 7.3
cpe:/a:postgresql:postgresql:7.2 PostgreSQL 7.2

- OVAL (用于检测的技术细节)

oval:org.mitre.oval:def:10927Buffer overflow in the readline function in util/texindex.c, as used by the (1) texi2dvi and (2) texindex commands, in texinfo 4.8 and earli...
*OVAL详细的描述了检测该漏洞的方法,你可以从相关的OVAL定义中找到更多检测该漏洞的技术细节。

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0244
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0244
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-321
(官方数据源) CNNVD

- 其它链接及资源

http://archives.postgresql.org/pgsql-hackers/2005-01/msg00922.php
(VENDOR_ADVISORY)  MLIST  [pgsql-hackers] 20050127 Permissions on aggregate component functions
http://marc.info/?l=bugtraq&m=110806034116082&w=2
(UNKNOWN)  BUGTRAQ  20050210 [USN-79-1] PostgreSQL vulnerabilities
http://www.mandriva.com/security/advisories?name=MDKSA-2005:040
(UNKNOWN)  MANDRAKE  MDKSA-2005:040
http://www.novell.com/linux/security/advisories/2005_36_sudo.html
(UNKNOWN)  SUSE  SUSE-SA:2005:036
http://www.redhat.com/support/errata/RHSA-2005-138.html
(VENDOR_ADVISORY)  REDHAT  RHSA-2005:138
http://www.securityfocus.com/bid/12417
(UNKNOWN)  BID  12417
http://xforce.iss.net/xforce/xfdb/19184
(PATCH)  XF  postgresql-security-bypass(19184)

- 漏洞信息

PostgreSQL 未明漏洞
中危 资料不足
2005-05-02 00:00:00 2005-10-20 00:00:00
远程  
        PostgreSQL 8.0.0以及较早的版本允许本地用户通过使用CREATE AGGREGATE命令来绕过函数的EXECUTE权限检查。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复此安全问题,补丁获取链接:
        http://www.mandriva.com/en/download

- 漏洞信息

13355
PostgreSQL Aggregate Function EXECUTE Restriction Bypass

- 漏洞描述

Unknown or Incomplete

- 时间线

2005-01-31 Unknow
Unknow Unknow

- 解决方案

Upgrade to version 8.0.1 or higher, as it has been reported to fix this vulnerability. An upgrade is required as there are no known workarounds.

- 相关参考

- 漏洞作者

Unknown or Incomplete
 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站