CVE-2005-0240
CVSS7.2
发布时间 :2005-05-02 00:00:00
修订时间 :2008-09-05 16:45:43
NMCOS    

[原文]Format string vulnerability in chdev on IBM AIX 5.2 allows local users to execute arbitrary code via format string specifiers in a command line argument, which is not properly handled when printing an error message.


[CNNVD]IBM AIX多个设备管理实用程序本地格式化字符串漏洞(CNNVD-200505-704)

        IBM AIX 5.2中的chdev存在格式化字符串漏洞,本地用户可以通过在命令行参数中的格式化字符串限定符,来执行任意代码。系统在打出错误信息时未正确处理这种说明符。

- CVSS (基础分值)

CVSS分值: 7.2 [严重(HIGH)]
机密性影响: COMPLETE [完全的信息泄露导致所有系统文件暴露]
完整性影响: COMPLETE [系统完整性可被完全破坏]
可用性影响: COMPLETE [可能导致系统完全宕机]
攻击复杂度: LOW [漏洞利用没有访问限制 ]
攻击向量: LOCAL [漏洞利用需要具有物理访问权限或本地帐户]
身份认证: NONE [漏洞利用无需身份认证]

- CPE (受影响的平台与产品)

产品及版本信息(CPE)暂不可用

- OVAL (用于检测的技术细节)

未找到相关OVAL定义

- 官方数据库链接

http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2005-0240
(官方数据源) MITRE
http://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2005-0240
(官方数据源) NVD
http://www.cnnvd.org.cn/vulnerability/show/cv_cnnvdid/CNNVD-200505-704
(官方数据源) CNNVD

- 其它链接及资源

http://xforce.iss.net/xforce/xfdb/19244
(UNKNOWN)  XF  aix-chdev-format-string(19244)
http://www.idefense.com/application/poi/display?type=vulnerabilities
(UNKNOWN)  IDEFENSE  20050207 IBM AIX chdev Local Format String Vulnerability
http://www-1.ibm.com/support/docview.wss?uid=isg1IY67654
(VENDOR_ADVISORY)  AIXAPAR  IY67654
http://www-1.ibm.com/support/docview.wss?uid=isg1IY67455
(VENDOR_ADVISORY)  AIXAPAR  IY67455

- 漏洞信息

IBM AIX多个设备管理实用程序本地格式化字符串漏洞
高危 格式化字符串
2005-05-02 00:00:00 2005-10-20 00:00:00
本地  
        IBM AIX 5.2中的chdev存在格式化字符串漏洞,本地用户可以通过在命令行参数中的格式化字符串限定符,来执行任意代码。系统在打出错误信息时未正确处理这种说明符。

- 公告与补丁

        目前厂商已经发布了升级补丁以修复这个安全问题,补丁下载链接:
        IBM AIX 5.1
        IBM IY67455
        http://www-1.ibm.com/servers/eserver/support/pseries/aixfixes.html
        IBM IY67654
        http://www-1.ibm.com/servers/eserver/support/pseries/aixfixes.html
        IBM IY67741
        http://www-1.ibm.com/servers/eserver/support/pseries/aixfixes.html
        IBM AIX 5.2
        IBM IY67455
        http://www-1.ibm.com/servers/eserver/support/pseries/aixfixes.html
        IBM IY67654
        http://www-1.ibm.com/servers/eserver/support/pseries/aixfixes.html
        IBM IY67741
        http://www-1.ibm.com/servers/eserver/support/pseries/aixfixes.html
        IBM AIX 5.3
        IBM IY67455
        http://www-1.ibm.com/servers/eserver/support/pseries/aixfixes.html
        IBM IY67654
        http://www-1.ibm.com/servers/eserver/support/pseries/aixfixes.html
        IBM IY67741
        http://www-1.ibm.com/servers/eserver/support/pseries/aixfixes.html
        

- 漏洞信息

13587
IBM AIX chdev Format String Local Privilege Escalation
Local / Remote, Context Dependent Input Manipulation
Loss of Integrity
Vendor Verified

- 漏洞描述

- 时间线

2005-02-07 Unknow
Unknow 2005-03-23

- 解决方案

Currently, there are no known workarounds or upgrades to correct this issue. However, IBM has released a patch to address this vulnerability.

- 相关参考

- 漏洞作者

Unknown or Incomplete

- 漏洞信息

IBM AIX Multiple Device Management Utilities Local Format String Vulnerability
Input Validation Error 12472
No Yes
2005-02-07 12:00:00 2009-07-12 10:06:00
Discovery of this vulnerability is credited to iDEFENSE Labs.

- 受影响的程序版本

IBM AIX 5.3
IBM AIX 5.2
IBM AIX 5.1

- 漏洞讨论

A format string vulnerability has been discovered in the 'chdev', 'mkdev, and 'rmdev' commands that can be exploited locally.

It is reported by the vendor that this issue may be exploitable locally by a member of the 'system' group in order to gain superuser privileges.

- 漏洞利用

Currently we are not aware of any exploits for this issue. If you feel we are in error or are aware of more recent information, please mail us at: vuldb@securityfocus.com <mailto:vuldb@securityfocus.com>.

- 解决方案

The vendor has released an advisory IBM-02-07-2005 to address this vulnerability. Fixes are not yet available, customers are advised to peruse the referenced advisory for further information pertaining to obtaining and applying an appropriate update.

The vendor has released an update to their original advisory. It has been reported that this issue affects the 'mkdev' and 'rmdev' utilities as well as the 'chdev' utilities. Please see the referenced updated advisory for more information.


IBM AIX 5.1

IBM AIX 5.2

IBM AIX 5.3

- 相关参考

 

 

关于SCAP中文社区

SCAP中文社区是国内第一个以SCAP为主题的中文开放社区。了解更多信息,请查阅[关于本站]

版权声明

CVE/CWE/OVAL均为MITRE公司的注册商标,它们的官方数据源均保存在MITRE公司的相关网站